none
Exchange 2016 Testinstallation - hohe RAM Last durch "IIS Worker Process" RRS feed

  • Frage

  • Hallo zusammen….!

     

    Ich habe derzeit eine kleine Testumgebung mit 1x DC 2016 und 2x Ex 2010 SP3 UR18 (Server 2008 R2). Gestern habe ich auf der VM des zukünftigen Exchange 2016 Servers (Server 2016) die Installation angestoßen und während dessen mitbekommen, dass diese irgendwie .Net Framework 4.7 drauf hatte. Die Installation habe ich durchlaufen lassen und nach einem Neustart das .Net Framework 4.7 Update deinstalliert sowie den Registryeintrag zum blockieren des Updates hinterlegt.

     

    Jetzt zu meinem derzeitigen Problem.

    Der Server mit der Exchange 2016 Installation hat 8 GB RAM und 2 Kerne (2 Sockets a 1 Kern) und läuft als vSphere VM (Version 10). Zugriff auf die Exchange Admin Verwaltungswebseite funktioniert auch.

    Der Server läuft durchgängig mit 80% RAM Auslastung und die CPU-Last liegt bei ca. 10-20%.

    Den RAM krallt sich der „IIS Worker Process“ der ca. 14-mal vorhanden ist und das erzeugt die Last obwohl die automatische Postfachdatenbank (durch die Installation) offline ist.

     

    Ich finde bisher kein Ansatz warum die RAM Last durch diesen Prozess so hoch ist und ich habe schon von 4 auf 8GB erhöhen lassen. Es erscheint die Meldung das zu wenig RAM zur Verfügung steht.

     

    Im Eventlog tauchen folgende Meldungen vermehrt auf:

     

    Schwerwiegender Kommunikationsfehler im Windows-Prozessaktivierungsdienst bei einem Prozess für den Anwendungspool "MSExchangeMapiFrontEndAppPool". Die Prozess-ID ist "2200". Das Datenfeld enthält die Fehlernummer.

     

    Schwerwiegender Kommunikationsfehler im Windows-Prozessaktivierungsdienst bei einem Prozess für den Anwendungspool "MSExchangeMapiMailboxAppPool". Die Prozess-ID ist "11472". Das Datenfeld enthält die Fehlernummer.

     

    Die Beschreibung für die Ereignis-ID "1009" aus der Quelle "MSExchangeFastSearch" wurde nicht gefunden. Entweder ist die Komponente, die dieses Ereignis auslöst, nicht auf dem lokalen Computer installiert, oder die Installation ist beschädigt. Sie können die Komponente auf dem lokalen Computer installieren oder reparieren.

    Vielen Dank vorab für Tipps

    • Bearbeitet Lexxitus Donnerstag, 20. Juli 2017 11:04
    Donnerstag, 20. Juli 2017 10:08

Antworten

Alle Antworten

  • Moin,

    ich würde Exchange deinstallieren und nach dem Reboot neu installieren. Die Installation kommt aus einem unsupporteten Zustand, wer weiß, welche Bezüge durch das nachträgliche Entfernen von .Net 4.7 kaputt gegangen sind. Wenn's zu aufwendig erscheint, könntest Du erst mal nur das CU6 erneut anwenden.

    Davon aber völlig abgesehen, ist die Idee, Exchange 2016 mit 4GB zu betreiben, per se zum Scheitern verurteilt. Man kriegt's schon irgendwie ans Laufen, aber Spass macht es keinen. Von produktiven oder ähnlichen Workloads rede ich schon gar nicht.


    Evgenij Smirnov

    I work @ msg services ag, Berlin -> http://www.msg-services.de
    I blog (in German) @ http://it-pro-berlin.de
    my stuff in PSGallery --> https://www.powershellgallery.com/profiles/it-pro-berlin.de/
    Exchange User Group, Berlin -> http://exusg.de
    Windows Server User Group, Berlin -> http://www.winsvr-berlin.de
    Mark Minasi Technical Forum, reloaded -> http://newforum.minasi.com

    Donnerstag, 20. Juli 2017 11:21
  • Hallo Evgenij,

    vielen Dank für die Rückmeldung und ich werde erstmal das CU 6 neu drüber installieren. Gehen hier meine Einstellungen verloren (wovon ich mal nicht ausgehe)? Es ist ja erstmal nur eine kleine Testumgebung wo keine Benutzer aktiv sind aber bei dem RAM gehe ich mit. Unsere zukünftiger Exchange 2016 (VM) hat da schon 8 Kerne und 52 GB RAM ;-)

    Auf den zukünftigen produktem System für Exchange 2016 war das .Net 4.7 auch drauf welches ich aber deinstallieren konnte (jetzt: Version 4.6.01586 und Release 394802)

    Wenn ich das Update (.Net 4.7) vor der produktiven Exchange Installation entfernt habe, sollte ich da sicher sein oder ist eine neue VM besser?

    MfG Paul

    Donnerstag, 20. Juli 2017 12:08
  • Wenn ich das Update (.Net 4.7) vor der produktiven Exchange Installation entfernt habe, sollte ich da sicher sein oder ist eine neue VM besser?

    Wenn da vorher kein Exchange drauf war, würde ich sagen, dass Du im grünen Bereich bist.

    Evgenij Smirnov

    I work @ msg services ag, Berlin -> http://www.msg-services.de
    I blog (in German) @ http://it-pro-berlin.de
    my stuff in PSGallery --> https://www.powershellgallery.com/profiles/it-pro-berlin.de/
    Exchange User Group, Berlin -> http://exusg.de
    Windows Server User Group, Berlin -> http://www.winsvr-berlin.de
    Mark Minasi Technical Forum, reloaded -> http://newforum.minasi.com

    Donnerstag, 20. Juli 2017 12:12
  • Hallo Evgenij,

    obwohl in meiner Testumgebung kein aktiver Benutzer mit seinem Postfach unterwegs ist, waren 8GB RAM (MS mind. Empfehlung) zu wenig. Der Server lag trotzdem bei 90% Auslastung. Erst als ich den RAM auf 16 GB hab erhöhen lassen, pendelte sich die RAM-Last bei 50% ein.

    MfG Paul

    Dienstag, 22. August 2017 12:27
  • Und noch ein Ergänzung für die produktiv Umgebung: Ein DC mit Windows 2016 ist in Verbindung mit Exchange 2010 nicht supported und kann zum Totalverlust führen.

    Daher: Nicht machen. ;)


    Gruesse aus Berlin schickt Robert - MVP Office Servers and Services (Exchange Server)

    Mittwoch, 23. August 2017 08:26
  • Hallo Robert,

    auf diese Information (Technet) bin vor deinem Post bisher nirgends gestossen. In meiner Testumgebung habe ich bisher keine Auswirkung gemerkt obwohl der DC auf einem Windows Server 2016 läuft und die Funktionsebenen schon auf 2016 laufen.

    Was mir jetzt aber Sorgen bereitet, ist die Tatsache, das Wir in unserer Gesamtstrutur (Multidomänenmodell) bis auf 2 DC`s alle auf Server 2016 hochgezogen haben. Die Domänenfunktionsebene und Gesamtstrukturfunktionsebene ist derzeit noch "Windows Server 2008 R2". Wir haben bisher keine Auswirkungen auf unsere Exchange 2010 Server gemerkt und wollen die Migration zu Exchange 2016 demnächst starten. Was würdest Du uns empfehlen um bis zur Migration doch noch eine Sicherheit vor einem Totalausfall zu erlangen? Wäre hier die Bereitstellung eines Server 2016 (DC) als GC eine gute Maßnahme?

    Vielen Dank....


    • Bearbeitet Lexxitus Freitag, 25. August 2017 06:28
    Freitag, 25. August 2017 06:28
  • Hallo,

    ändert nichts dran, das es eine nicht supportete Umgebung ist.

    Und mache bitte einen neuen Thread auf, das hat mit dem Original nichts zu tun.

    Ich kann den Thread auch splitten.

    ;)


    Gruß Norbert

    Freitag, 25. August 2017 08:33
    Moderator
  • Habe das Thema in einem neuen Thread dargelegt.

    Hier -> "serverdc-2016-exchange-2010-not-supported"

    MfG Paul

    Freitag, 25. August 2017 13:40