none
SSL für eine bestehende Web Application aktivieren RRS feed

  • Allgemeine Diskussion

  • Ich möchte bei einer bestehenden Web Application SSL einrichten.
    Dafür habe ich bereits folgende Schritte unternommen (Mehrheitlich nach folgender Quelle - http://www.techtask.com/sharepoint-news/ssl-verschlusselung-auf-einer-sharepoint-2010-web-application-aktivieren/ ):

    • Alternate Access Mapping eingerichtet für die WebApp
    • Auf dem IIS ein Zertifikat für die Seite hinterlegt
      Zertifikat per Create/Complete Request über Zertifikat-Server erstellt.
    • Ebenfalls im IIS das Binding der Seite angepasst (neben http noch den https mit Zerti)
    • das Ganze habe ich auf allen meiner SP-Servern eingerichtet
    • IIS Reset auf allen Servern

    Wenn ich nun per Browser versuche auf die https Seite zuzugreifen erhalte ich die Meldung "Die Webseite kann nicht angezeigt werden".
    Was ebenfalls speziell ist, wenn ich direkt im IIS auf "Browse *:443 (https)" gehe öffnet er sauber die Seite, aber als Adresse wird "localhost" angezeigt anstelle der normalen URL...

    Jemand eine Idee was hier das Problem ist? Eigentlich müsste es so doch funktionieren oder?

    Gruss Daniel

    Mittwoch, 20. Juni 2012 09:37

Alle Antworten

  • Hallo Daniel,

    ist die https://... URL als alternative Zugriffszuordnungen (Eng. Alternate Access Mappings) für die Webanwendung eingetragen?

    Gruß,
    Andrei

    Mittwoch, 20. Juni 2012 12:31
  • Hallo Andrei

    Ja, siehe Punkt 1 in meiner Auflistung ;-)

    Ich habe die http-URLin der Zone "Default" und die https-URL in der "Intranet" Zone. Übernahm ich so dem Anleitungsbeispiel.
    Meiner Meinung nach ist die Zone an sich ja egal die man wählt oder?

    Mittwoch, 20. Juni 2012 14:01
  • Hi,

    sorry habe den Punkt übersprungen. Ich würde dann mal von vorne anfangen:

    1. DNS Einstellungen überprüfen: die Webanwendungs URL weist auf IP x.x.x.x
    2. Auf dem SP Server mit IP x.x.x.x Zertifikat und IIS Binding nochmal überprüfen.
    3. Internet Explorer Show Friendly HTTP Error Messages über Internet Options - Advanced ausschalten um den HTTP Error Code rauszubgekommen. Alternativ auf dem selben Server die IIS Logs nach den Requests (es sind mehrere, der erste ist fast immer 401) suchen und den HTTP Status raussuchen (404, 500, 200, ...)

    Bitte HTTP Status hier posten, dann schauen wir weiter.

    Gruß,
    Andrei

    Mittwoch, 20. Juni 2012 14:45
  • Hallo!

    Host-Header-Names und SSL vertragen sich nicht. Wie Andrei schrieb solltest Du DNS und/oder HOSTS-Datei auf dem Server prüfen! - Ist das SSL-Zert ok? Da sollte der Host-Header-Name der WebApp drinstehen.

    Gruß

    Ingo 

    Mittwoch, 20. Juni 2012 15:14
  • Ich glaube das Problem gefunden zu haben, konnte es aber noch nicht anpassen.

    Wir benutzen einen LoadBalancer und wie es scheint, leitet dieser bisher nur http aber kein https weiter...

    update:

    Der Loadbalancer war tatsächlich das Problem. Es gab noch keine gesonderte Regel für https, nachdem wir diese erstellt hatten, klappte dann alles.

    • Bearbeitet DanZu_CH Mittwoch, 4. Juli 2012 06:54
    Dienstag, 26. Juni 2012 09:20