none
Flash Player per GPO verteilen RRS feed

  • Frage

  • Hallo zusammen,

    ich versuche den Flash Player per GPO Server 2008 auf win7 -Rechner zu verteilen und habe folgendes gemacht:

    In der OU per Computerkonfiguration --> Richtlinieen-->Softwareeinstellungen-> softwareinstalltion das MSI-Paket in einer NETLOGON-Freigabe eingestellt und "zugewiesen".

    Leider klappts net. Was habe ich vergessen??

    Donnerstag, 11. Februar 2010 15:14

Antworten

  • Hallo Nochmal,
    es lööööft, es lag an einem ganz absurden Fehler meinerseits, der nichts mit dem ursprünglich geschilderten Problem zu tun hatte.

    Tut mir leid, dass ich Euch herausgefordert habe.

    Vielen Dank nochmals
    Dieter
    Donnerstag, 11. Februar 2010 18:06

Alle Antworten

  • Weiß nicht... hab keine Kristallkugel. Hast du denn schon ein RSOP auf einem der Client generiert? Dann noch ne Frage zum Server... 2008 oder 2008R2?
    Donnerstag, 11. Februar 2010 15:38
  • Vielen Dank für die Antwort; weiß leider nicht was ein " RSOP" ist. Werde weiter suchen. Vielen Dank nochmals. Vielleicht hilfts ja. server 2008.
    Donnerstag, 11. Februar 2010 15:48
  • Hi,

    Am 11.02.2010 16:14, schrieb ngawa:
    > In der OU per Computerkonfiguration -->
    > Richtlinieen-->Softwareeinstellungen-> softwareinstalltion das MSI-Paket
    > in einer NETLOGON-Freigabe eingestellt und "zugewiesen".
    > Leider klappts net. Was habe ich vergessen??

    gpupdate /sync
    wenn es dann geht liegts an FAQ.36

    Tschö
    Mark
    --
    Mark Heitbrink - MVP Windows Server - Group Policy

    Homepage: www.gruppenrichtlinien.de - deutsch
    Discuss : www.freelists.org/list/gpupdate
    Donnerstag, 11. Februar 2010 16:01
  • Hi ihr beiden,

    >> ich versuche den Flash Player per GPO Server 2008 auf
    >> win7 -Rechner zu verteilen und habe folgendes gemacht:
    >>
    >> In der OU per Computerkonfiguration --> Richtlinieen--
    >> Softwareeinstellungen-> softwareinstalltion das MSI-Paket
    >> in einer NETLOGON-Freigabe eingestellt und "zugewiesen".
    >>
    >> Leider klappts net. Was habe ich vergessen??
    [..]
    > Weiß nicht... hab keine Kristallkugel. Hast du denn schon ein RSOP auf
    > einem der Client generiert?
    > Dann noch ne Frage zum Server... 2008 oder 2008R2

    Eine zugehörige Fehlermeldung aus der Ereignisanzeige des Clients und ggf.
    Server wäre aufschlussreich.

    Vermutlich wird es jedoch der übliche Kandidat sein:
    Gruppenrichtlinieneinstellung in der COMPUTER-Konfiguration auf eine
    Freigabe, auf den jedoch lediglich Benutzer (und keine Computerkonten)
    sowohl mind. Leserechte auf Freigabeebene UND Lese/Ausführungsrechte auf
    NTFS-Ebene besitzen.

    Nebenbei bemerkt: Wieso die Freigabe "netlogon"? Ich würde kein Systemordner
    für sowas verwenden..

    Merke: "Authenticated Users" != "Domain Computers"

    --
    Tobias Redelberger
    StarNET Services (HomeOffice)
    Frankfurter Allee 193
    D-10365 Berlin
    Tel: +49 (30) 86 87 02 678
    Mobil: +49 (163) 84 74 421
    Email: T.Redelberger@starnet-services.net
    Web: http://www.starnet-services.net



    Donnerstag, 11. Februar 2010 16:02
  • Hallo,
    vielen Dank für Eure Mühe; habs leider noch nicht hingekriegt.
    Habe eine neue Freigabe eingerichtet (anderes Verzeichnis) und dem "domänen-computer" probehalber volle Zugriffsrechte gegeben sowohl auf Freigabe-Ebene als auch auf NTFS-ebene.

    Eine Ereignismeldung  des MSIinstaller des Servers lautet: Windows Installer-Transaktion wird gestartet: \\dc01\...\install_flash_player_10_plugin.msi. und 1 Sekunde später wieder beendet.

    Auf dem Client kann ich keine - für mich, bzw. das Problem- relevante Fehlermeldung erkennen.

    Schöen Dank nochmals fürs Mitdenken
    Dieter
    Donnerstag, 11. Februar 2010 17:42
  • Hallo Nochmal,
    es lööööft, es lag an einem ganz absurden Fehler meinerseits, der nichts mit dem ursprünglich geschilderten Problem zu tun hatte.

    Tut mir leid, dass ich Euch herausgefordert habe.

    Vielen Dank nochmals
    Dieter
    Donnerstag, 11. Februar 2010 18:06
  • Hi,

    Am 11.02.2010 17:02, schrieb Tobias Redelberger:
    > Nebenbei bemerkt: Wieso die Freigabe "netlogon"? Ich würde kein
    > Systemordner für sowas verwenden..

    Logisch, was sonst? Ist DFS, tuts immer und die beste Stelle für
    sowas. Server tausch stressfrei, wenn man direkt den DFS Stamm
    namen verwendet hat. Kein extra Veraltungsaufwand für Replikation
    etc. Super Platz für sowas. Definitiv.


    Tschö
    Mark
    --
    Mark Heitbrink - MVP Windows Server - Group Policy

    Homepage: www.gruppenrichtlinien.de - deutsch
    Discuss : www.freelists.org/list/gpupdate
    Donnerstag, 11. Februar 2010 19:07
  • Hi Mark,

    >> Nebenbei bemerkt: Wieso die Freigabe "netlogon"? Ich würde kein
    >> Systemordner für sowas verwenden..
    >
    > Logisch, was sonst? Ist DFS, tuts immer und die beste Stelle für
    > sowas. Server tausch stressfrei, wenn man direkt den DFS Stamm
    > namen verwendet hat. Kein extra Veraltungsaufwand für Replikation
    > etc. Super Platz für sowas. Definitiv.

    ok, wenn der Guru das sagt.. ;)

    Ich dachte eben wegen dem Replikations(mehr)aufwand für ggf. große
    Installationsdateien in größeren AD-Strukturen und den Anpassungen der
    Sicherheitsrechte (z.B. für Domänen-Computer) plazier man besser eine
    dedizierte "Software-Verteilungs"-Struktur, getrennt und nach eigenen
    Vorgaben, ggf. ebenso mit DFS usw..

    Gab es noch nie Probleme in der Hinsicht, dass durch ein Service-Pack,
    Schema- und oder Versionsupgrade (z.B. Wechsel von FRS auf DFSR) in solchen
    Strukturen mit ggf. angepassten Rechten und/oder Unterordnern es zu
    unvorhersehbaren Verhalten kam?

    --
    Tobias Redelberger
    StarNET Services (HomeOffice)
    Frankfurter Allee 193
    D-10365 Berlin
    Tel: +49 (30) 86 87 02 678
    Mobil: +49 (163) 84 74 421
    Email: T.Redelberger@starnet-services.net
    Web: http://www.starnet-services.net


    Freitag, 12. Februar 2010 08:14
  • Hi Dieter,

    > es lööööft, es lag an einem ganz absurden Fehler meinerseits,
    > der nichts mit dem ursprünglich geschilderten Problem zu tun hatte.

    für's Archiv: Was genau war denn der Fehler? Evtl. laufen ja auch andere
    ebenso gegen diese "Wand".. ;)


    > Tut mir leid, dass ich Euch herausgefordert habe.

    Das Leben ist eine einzige Herausfoderung.. ;)

    --
    Tobias Redelberger
    StarNET Services (HomeOffice)
    Frankfurter Allee 193
    D-10365 Berlin
    Tel: +49 (30) 86 87 02 678
    Mobil: +49 (163) 84 74 421
    Email: T.Redelberger@starnet-services.net
    Web: http://www.starnet-services.net


    Freitag, 12. Februar 2010 08:16
  • Moin

    Am 12.02.2010 09:14, schrieb Tobias Redelberger:
    > Ich dachte eben wegen dem Replikations(mehr)aufwand für ggf. große
    > Installationsdateien in größeren AD-Strukturen und den Anpassungen der
    > Sicherheitsrechte (z.B. für Domänen-Computer) plazier man besser eine
    > dedizierte "Software-Verteilungs"-Struktur, getrennt und nach eigenen
    > Vorgaben, ggf. ebenso mit DFS usw..

    Absolut. Da gebe ich dir gerne Recht, aber ich gehe immer davon aus,
    das Softwaredeployment in "großen" Strukturen auch mit einer
    "erwachsenen" Software organisiert wird.

    Für den Hausgebrauch, und mehr ist da die GPSI nicht, finde ich die
    Lösung über das NETLOGON sehr charmant, da es keinen Mehraufwand
    bedeutet.

    Die Rechte musst du auch nicht anpassen, denn "lesen" reicht und das
    darf der Computer dort.

    > Gab es noch nie Probleme in der Hinsicht, dass durch ein Service-Pack,
    > Schema- und oder Versionsupgrade (z.B. Wechsel von FRS auf DFSR) in solchen
    > Strukturen mit ggf. angepassten Rechten und/oder Unterordnern es zu
    > unvorhersehbaren Verhalten kam?

    Nur, daß die FileReplikation ansich immer wieder ärger macht.
    MS kann astrein AD replizieren, Datenbank beherrschen sie, aber
    Filesystem ist unterirdisch im Vergleich dazu.

    Aber die Fehler, die ich bislang hatte, waren nie abhängig von der
    Datei die dort liegt.

    Tschö
    Mark
    --
    Mark Heitbrink - MVP Windows Server - Group Policy

    Homepage: www.gruppenrichtlinien.de - deutsch
    Discuss : www.freelists.org/list/gpupdate
    Freitag, 12. Februar 2010 09:02
  • Hallo Leute,

    diese Lösung ist auf jeden Fall elegant. Habe bisher Flash und Shockwave Player immer per Installationsskript installiert / "upgedatet". Ich nehme an du hast dir das MSI für den Flash Player selber gebaut? Bei Adobe finde ich für den Flash Player kein MSI sonder nur eine EXE, für den Shockwave gibt es bei Adobe mittlerweile ein MSI zum Download.

          Wie hast du die AutoUpdate Funktion vom Flash Player deaktiviert?

    Den RegKey zum Deaktivieren des AutoUpdates des Shockwave Players werde ich in Zukunft  direkt im MSI hinterlegen (HKEY_LOCAL_MACHINE\SOFTWARE\Adobe\Shockwave 11\AutoUpdate\).

    lg. Florian
    Freitag, 12. Februar 2010 11:31
  • Hi Tobias,

    >> es lööööft, es lag an einem ganz absurden Fehler meinerseits,
    >> der nichts mit dem ursprünglich geschilderten Problem zu tun hatte.

    > für's Archiv: Was genau war denn der Fehler? Evtl. laufen ja auch andere
    > ebenso gegen diese "Wand".. ;)

    Nun, in meiner "spielumgebung" hier hatte der Client - den ich lange nicht angepackt hatte- eine andere IP  :-(((

    @ Florian

    nein, es war keine selbstgestrickte MSI, den dwonload gibts hier:
    http://www.adobe.com/products/flashplayer/fp_distribution3.html

    Schönen Gruß
    Dieter
    Freitag, 12. Februar 2010 16:17
  • ngawa schrieb:

    > Vielen Dank für die Antwort; weiß leider nicht was ein " RSOP" ist. Werde weiter suchen. Vielen Dank nochmals. Vielleicht hilfts ja. server 2008.

    Start > Ausführen > RSOP.MSC [ENTER]. Hier siehst Du welche
    Einstellungen von welchen GPOs ankommen. Fehlt hier etwas oder hast
    Dzu rote Kreuze ist das Eventlog die nächste Anlaufstelle.

    Servus
    Winfried
    --
    Connect2WSUS: http://www.grurili.de/tools/Connect2WSUS.exe
    GPO's: www.gruppenrichtlinien.de
    Gruppenrichtlinien Mailingliste "gpupdate":
    http://frickelsoft.net/cms/index.php?page=mailingliste
    Freitag, 12. Februar 2010 20:55
  • Tausend Dank, Winfried, hatte es mittlerweile auch schon gefunden.
    Tschüss
    Dieter
    Samstag, 13. Februar 2010 09:32
  • Hallo,
    ich weiß das Thema ist schon vor langem diskutiert worden, aber ich muss das Thema nochmals aufgreifen, da ich bei verteilen auch ein Problem habe. 

    Ich habe die GPO erstellt
    OU per Computerkonfiguration --> Richtlinien -->Softwareeinstellungen --> Softwareinstalltion das MSI-Paket in einer Windows-Freigabe ( \\Servername\freigabename\ ) 

    Auf die Freigabe haben sowohl Domain User als auch Domain Computer Lese-Recht

    Wenn ich RSOP.MSC ausführe bekomme ich einen Fehler angezeigt

    Im EVENT Viewer unter Application ist folgende Fehlermeldung:
    The assignment of application Adobe Flash Player 11 ActiveX from policy Test failed.  The error was : The system cannot find the file specified. 

    Komisch, den wenn ich mich als User anmelde und auf den Pfad der Datei öffne funktioniert alles bestens.

    Hat jemand noch eine Idee?

    LG
    Carsten


    Mittwoch, 15. August 2012 10:00
  • Am 15.08.2012 schrieb CScholl:

    Ich habe die GPO erstellt
    OU per Computerkonfiguration --> Richtlinien -->Softwareeinstellungen --> Softwareinstalltion das MSI-Paket in einer Windows-Freigabe ( \\Servername\freigabename\ ) 

    Auf die Freigabe haben sowohl Domain User als auch Domain Computer Lese-Recht

    Und sind die NTFS Berechtigungen? Auf der Freigabe kannst Du ruhig
    Jeder eintragen, im Reiter Sicherheit trägst Du die Authentifizierten
    Benutzer mit Leserechten ein, die Authentifizierten Benutzer
    beinhalten auch die Computer.

    Wenn ich RSOP.MSC ausführe bekomme ich einen Fehler angezeigt

    Im EVENT Viewer unter Application ist folgende Fehlermeldung:
    The assignment of application Adobe Flash Player 11 ActiveX from policy Test failed.  The error was : The system cannot find the file specified. 

    Komisch, den wenn ich mich als User anmelde und auf den Pfad der Datei öffne funktioniert alles bestens.

    Der User ist aber nicht der Computer, verstehst Du? Das sind zwei
    völlig verschiedene Konten. Was der eine darf, muss der andere noch
    lange nicht dürfen.

    Hat jemand noch eine Idee?

    Ja, setze die NTFS-Berechtigungen korrekt.
    Servus
    Winfried


    Connect2WSUS: http://www.grurili.de/tools/Connect2WSUS.exe
    GPO's: http://www.gruppenrichtlinien.de
    Community Forums NNTP Bridge: http://communitybridge.codeplex.com/

    Mittwoch, 15. August 2012 14:45
  • Hallo Winfried,

    also folgende Berechtigungen sind gesetzt:

    Share: Everyone und DomainComputers - Full Access

    Security: Authenticated Users, Domain User und Domain Computers: Modify

    Eigentlich sollte das genügen.

    Ich habe das ganze jetzt auch mit "Chrome.msi" versucht und habe das selbe Problem.

    In der GPO habe ich auf die IP Adresse verwiesen.

    Gruß

    Carsten


    • Bearbeitet CScholl Donnerstag, 16. August 2012 13:54
    Donnerstag, 16. August 2012 13:25
  • Am 16.08.2012 schrieb CScholl:

    Share: Everyone und DomainComputers - Full Access

    Security: Authenticated Users, Domain User und Domain Computers: Modify



    Eigentlich sollte das genügen.

    Jepp. Das kannst Du mit einem Computerstartupscript recht schnell
    selbst testen. Einfach in der Freigabe über eine Batchdatei eine
    %computername%.txt erstellen lassen.

    Ich habe das ganze jetzt auch mit "Chrome.msi" versucht und habe das selbe Problem.

    In der GPO habe ich auf die IP Adresse verwiesen.

    Weshalb das? Setz den DNS bzw. den NETBios Namen ein. Das muss
    funktionieren.

    Habt ihr beide Einstellungen aus der GPO FAQ No. 36 gesetzt?
    http://www.gruppenrichtlinien.de/Grundlagen/faq.htm

    Servus
    Winfried


    Connect2WSUS: http://www.grurili.de/tools/Connect2WSUS.exe
    GPO's: http://www.gruppenrichtlinien.de
    Community Forums NNTP Bridge: http://communitybridge.codeplex.com/
    Reg2xml:  http://www.reg2xml.com - Registry Export File Converter

    Donnerstag, 16. August 2012 18:01
  • Guten Morgen,

    also das ganze ist wie verhext. Gestern ging gar nichts und ich hatte ständig diese Fehler. Heute Morgen habe ich wieder angefangen zu testen und die GPO lief ohne Fehler und Probleme durch. Ohne Worte. 

    Was ich mir vorstellen kann, das es vtl. etwas mit der Synczeit zwischen den DC´s (einer in USA einer in Deutschland) zu tun haben könnte...... wer weiß.....

    Aber was meinst du mit dem Computerstartupscript?

    Gruß
    Carsten

    Freitag, 17. August 2012 07:32
  • Am 17.08.2012 schrieb CScholl:

    also das ganze ist wie verhext. Gestern ging gar nichts und ich hatte ständig diese Fehler. Heute Morgen habe ich wieder angefangen zu testen und die GPO lief ohne Fehler und Probleme durch. Ohne Worte. 

    Was ich mir vorstellen kann, das es vtl. etwas mit der Synczeit zwischen den DC´s (einer in USA einer in Deutschland) zu tun haben könnte...... wer weiß.....

    Da sollte man Fehler im Eventlog finden. Konfiguriere das per GPO,
    schon solltest Du keine Zeitsync probleme mehr haben.
    http://www.gruppenrichtlinien.de/HowTo/Zeitserver_per_GPO.htm

    Aber was meinst du mit dem Computerstartupscript?

    Das wäre etwas zum testen gewesen. Einfach eine Batchdatei als Computerstartupscript ausführen lassen.

    REM Textdatei auf einer Freigabe erstellen.
    
    if exist \\Server\Freigabe\%computername%.txt goto ENDE
    set datum=%date%
    echo %datum%
    set Zeit=%time%
    echo %time%
    
    echo %computername% %datum% %time% > \\server\freigabe\%COMPUTERNAME%.TXT
    goto ENDE
    
    :ENDE
    exit

    Wird die Textdatei erstellt, hat der ausführende Computer genügend
    NTFS Berechtigungen auf der Freigabe.

    Servus
    Winfried


    Connect2WSUS: http://www.grurili.de/tools/Connect2WSUS.exe
    GPO's: http://www.gruppenrichtlinien.de
    Community Forums NNTP Bridge: http://communitybridge.codeplex.com/
    Reg2xml:  http://www.reg2xml.com - Registry Export File Converter

    Freitag, 17. August 2012 16:39