none
Problem mit Fehlermeldung "Update is not applicable for this Computer" RRS feed

  • Frage

  • Hallo zusammen,

    Ursprünglich war mein Problem das ich einen SQL 2008 R2 Developer Server auf meinem neu installierten Windows Server 2008 R2 Enterprise Edition SP 1 installieren wollte. Das unterfangen brach immer während der Installation der Support Dateien ab. Nach googln des Error Codes den ich in der SQLSetup im %Temp% Ordner gefunden hatte (0x84BC0003), fand ich nicht allzu viele Hinweise ausser das es ein Sprach Problem sein könnte ( SQL Server Deutsch, Windows Server Englisch). Da ich aber in Region and Language alles auf German gestellt habe (musste Neustart machen um die Settings zu übernehmen)müsste es eigentlich funktionieren. Auch die Installation des MUI für WS 2008 R2 bricht mittendrin ab. der Event Viewer sagt mir dazu

    CBS failed to install the language pack for de-DE. Returned CBS error code 0x80092004.

    Ich hab daraufhin die CBS mal genauer angeschaut und da gesehen das der Computer ständig versucht eien Vorgang einzuleiten aber nicht vorwärts kommt.

    2011-08-17 10:43:52, Info                  CBS    Session: 30170297_3403322775 initialized by client RMT.
    2011-08-17 10:43:52, Info                  CBS    Session: 30170297_3403322775 finalized. Reboot required: no [HRESULT = 0x00000000 - S_OK]

    diese Meldung kommt alle 2 Minuten.

    nach googln dieses Fehlers hab ich die Ursache als ein Problem der Windows Update Funktion identifiziert und mir den Patch Windows6.1-KB947821-v12-x64 heruntergeladen. Als ich versucht habe diesen zu installieren kam dann die Fehlermeldung "Update is not applicable for this Computer". Diese Meldung hatte ich auch schon ein paar mal als ich die IIS und Application Server Rollen eingerichtet habe und Patches installieren wollte weil ich Fehlermeldungen bekam. Die Patches waren alle eindeutig für den WS 2008 R2, ich hab die Kategorie immer auf der msdn Seite ausgesucht weshalb die Fehlermeldung keinen Sinn macht.

    Desweiteren wunderte es mich auch schon von Anfang an das ich keine Updates bekomme obwohl ich automatische Updates an habe. Ich dachte erst es gibt keine da das Service Pack relativ neu ist, aber wenn ich manuell zu updaten versuche checkt er überhaupt nicht nach updates, das einzige was man sieht ist dass das Datum der letzten Überprüfung geändert wird aber er überprüft augenscheinlich nicht wirklich.

    Summary: Ich wollte mal die ganze Kette hinschreiben das man die Fehler die ich gemacht habe besser verfolgen und identifizieren kann, aber hauptsächlich bräuchte ich Hilfe den Fehler mit den Updates zu korrigieren. Ich hab den leisen Verdacht das sich alle anderen Probleme in Luft auflösen sobald ich die nötigen Updates habe.

    ich bin schon etwas verzweifelt hier und würde mich sehr verbunden fühlen wenn mir jemand mit diesem Problem helfen könnte.

    mfg Jörg

    Mittwoch, 17. August 2011 09:18

Antworten

  • Hallo Raul,

     

    vielen Danke für die Mühe,ich bin jetzt auf HPC umgestiegen. Ist zwar ärgerlich wenn ich die Lizenz für den Enterprise habe aber es funktioniert wenigstens und ich brauche den Server im Moment auch nur für den TFS.

     

    Gruss Jörg

     

    Dienstag, 23. August 2011 08:49

Alle Antworten

  • Ok peinlich soweit ich das gerade geshen habe,

    2011-08-17 10:43:52, Info CBS Session: 30170297_3403322775 initialized by client RMT.
    2011-08-17 10:43:52, Info CBS Session: 30170297_3403322775 finalized. Reboot required: no [HRESULT = 0x00000000 - S_OK]

    hat nicht wirklich was mit der Sache zu tun sondern ist ein standard Windows output. Aber das Problem das ich keinerlei Patches installieren kann obwohl sie für die Computer Version betimmt sind bleibt. Und ich kann trotz googln immer noch nicht sagen ob es jetzt Updates gibt für WS 2008 R2 SP 1. Was ich vorhin vergessen habe meine Architektur ist x64 und der WS 2008 R2 läuft in VMWare Workstation und ist Microsoft aktiviert. Ich bin nicht ganz versiert mit der Einrichtung eines Servers und benehme mich daher noch etwas Laienhaft dafür bitte ich um Nachsicht. Ich verlange auch nicht das jemand die Arbeit für mich macht, nur ein paar Hinweise wo ich noch graben muss um den Fehler zu finden.

    mfg Jörg

    Mittwoch, 17. August 2011 09:50
  • Hi Jörg,

    Ursprünglich war mein Problem das ich einen SQL 2008 R2 Developer Server auf meinem neu installierten Windows Server 2008 R2 Enterprise Edition SP 1 installieren wollte. Das unterfangen brach immer während der Installation der Support Dateien ab. Nach googln des Error Codes den ich in der SQLSetup im %Temp% Ordner gefunden hatte (0x84BC0003), fand ich nicht allzu viele Hinweise ausser das es ein Sprach Problem sein könnte ( SQL Server Deutsch, Windows Server Englisch). Da ich aber in Region and Language alles auf German gestellt habe (musste Neustart machen um die Settings zu übernehmen)müsste es eigentlich funktionieren. Auch die Installation des MUI für WS 2008 R2 bricht mittendrin ab. der Event Viewer sagt mir dazu

    German oder deutsch - ist das jetzt ein englischer oder deutscher Server?

    Sollte immer der Reboot angekreidet werden, schau mal was bei PendingFileRenameOperations hinterlegt ist:
    http://support.microsoft.com/kb/312444/de

    Schlüssel: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager Wert: PendingFileRenameOperations


    __________________
    Viele Grüße
    Christian

    Mittwoch, 17. August 2011 10:58
  • Hallo und danke für die Antwort,

    es ist ein Englisher Server aber man kann German(local) als region und Sprache einstellen.

    ich hab keinen Key PendingFileRenameOperations aber FileRenameOperations un dessen Wert ist nicht gesetzt.

     

    Gruß Jörg

    Mittwoch, 17. August 2011 11:08
  • Hi Jörg,

    es ist ein Englisher Server aber man kann German(local) als region und Sprache einstellen.

    ...und hast du den deutschen oder englischen Patch versucht zu installieren?


    __________________
    Viele Grüße
    Christian

    Mittwoch, 17. August 2011 11:19
  • Oha verdammt danke für den Hinweis Christian, es war der Deutsche ich hab grad nochmal im Event Viewer nachgeschaut

    "The language pack for de-DE is not applicable for this system. Please download the appropriate language pack that targets your system's architecture and SKU."

    ok ich lad schnell das Englische runter und meld mich dann nochmal.

     

    Gruß Jörg

     

    Mittwoch, 17. August 2011 11:27
  • Hi Jörg,

    am besten postest du im SQL-Forum, denn auf die schnelle habe ich nichts dazu gefunden:
    http://social.technet.microsoft.com/Forums/de-DE/sqlserver/threads


    __________________
    Viele Grüße
    Christian

    Mittwoch, 17. August 2011 13:47
  • Ich hab gerade versucht meinen Sharepoint Server zu installieren was genauso wenig funktioniert da er bereits bei den Prerequesits aus der Installation rausspringt. Als ich versucht habe die Komponenten manuell zu installieren kam wieder "Update is not applicable for this Computer". Ich hab mit der Windows Identity Foundation angefangen und beide diese Dateien verwendet :

    Windows6.0-KB974405-x64

    Windows6.1-KB974405-x64

    keine von beiden hat funktioniert. Dieses Problem wird solangsam lästig, ich werde nochmal eine Neuinstallation probieren vll gabs da ja schon Komplikationen.

     

    Gruß Jörg

    Mittwoch, 17. August 2011 13:55
  • Der SQL Server Thread hat mich sehr weitergebracht Christian vielen Dank, das Problem mit dem SQL Server wurde hier identifiziert:

    http://social.technet.microsoft.com/Forums/de-DE/sqlserver/thread/0d1aeb9b-697a-4f35-bf0e-6fd2a8343fbf

    es ist ein Problem mit der Sprach Einstellung, der Fehler sollte eigentlich nach der Installation des Mui LP behoben sein ist er aber nicht.

    Die Neuinstallation des WS 2008 R2 hat leider nichts gebracht ich habe immer noch die gleiche Probleme mit den Updates und ich kann keine einzige msu Datei auf dem Server ausführen. Ich habe mehrere msu Dateien runtergeladen und ausprobiert, alle für den ws 2008 R2 aber bei jeder kommt die Fehlermeldung "The Update is not applicable to your computer".

    Mit dieser Sache sollte ich eigentlich im richtigen Thread sein wenn noch jemand eine Idee hätte wäre das Klasse weil ich mit Google hier einfach nicht mehr weiterkomme.

     

    Gruß Jörg

    • Bearbeitet Jörg Ette Donnerstag, 18. August 2011 10:08 Schreibfehler
    Donnerstag, 18. August 2011 09:59
  • Hallo Jörg,

    ich habe auch etwas recherchiert, leider ohne viel Erfolg. Es sind Probleme mit spezifische Updates, aber nicht wie bei Dir, mit allen.

    Am besten in diesen Fall wäre ein Support Case bei Microsoft zu eröffnen, da auch die Neuinstallation von WS nichts gebracht hat.

    Gruss,
    Raul

    Montag, 22. August 2011 09:22
    Moderator
  • Hallo Raul,

     

    vielen Danke für die Mühe,ich bin jetzt auf HPC umgestiegen. Ist zwar ärgerlich wenn ich die Lizenz für den Enterprise habe aber es funktioniert wenigstens und ich brauche den Server im Moment auch nur für den TFS.

     

    Gruss Jörg

     

    Dienstag, 23. August 2011 08:49