none
Empfangsconnector Log / Übertragung korrekt? RRS feed

  • Frage

  • Hallo zusammen,

    ich habe das Problem dass zumindest in dem Fall von einer externen E-Mail Adresse die E-Mail in den lokalen Postfächern nicht ankommt.

    Ich habe mir zuerst einmal die Log vom Empfangsconnector angeguckt:

    2009-04-29T11:42:53.151Z,blaEXCHANGE\Default blaEXCHANGE,08CB92F2DC821741,0,192.168.2.10:25,65.54.246.110:8002,+,,
    2009-04-29T11:42:53.151Z,blaEXCHANGE\Default blaEXCHANGE,08CB92F2DC821741,1,192.168.2.10:25,65.54.246.110:8002,*,SMTPSubmit SMTPAcceptAnySender SMTPAcceptAuthoritativeDomainSender AcceptRoutingHeaders,Set Session Permissions
    2009-04-29T11:42:53.151Z,blaEXCHANGE\Default blaEXCHANGE,08CB92F2DC821741,2,192.168.2.10:25,65.54.246.110:8002,>,"220 blaexchange.bla.local Microsoft ESMTP MAIL Service ready at Wed, 29 Apr 2009 13:42:52 +0200",
    2009-04-29T11:42:53.323Z,blaEXCHANGE\Default blaEXCHANGE,08CB92F2DC821741,3,192.168.2.10:25,65.54.246.110:8002,<,EHLO bay0-omc1-s38.bay0.hotmail.com,
    2009-04-29T11:42:53.323Z,blaEXCHANGE\Default blaEXCHANGE,08CB92F2DC821741,4,192.168.2.10:25,65.54.246.110:8002,>,250-blaexchange.bla.local Hello [65.54.246.110],
    2009-04-29T11:42:53.323Z,blaEXCHANGE\Default blaEXCHANGE,08CB92F2DC821741,5,192.168.2.10:25,65.54.246.110:8002,>,250-SIZE,
    2009-04-29T11:42:53.323Z,blaEXCHANGE\Default blaEXCHANGE,08CB92F2DC821741,6,192.168.2.10:25,65.54.246.110:8002,>,250-PIPELINING,
    2009-04-29T11:42:53.323Z,blaEXCHANGE\Default blaEXCHANGE,08CB92F2DC821741,7,192.168.2.10:25,65.54.246.110:8002,>,250-DSN,
    2009-04-29T11:42:53.323Z,blaEXCHANGE\Default blaEXCHANGE,08CB92F2DC821741,8,192.168.2.10:25,65.54.246.110:8002,>,250-ENHANCEDSTATUSCODES,
    2009-04-29T11:42:53.323Z,blaEXCHANGE\Default blaEXCHANGE,08CB92F2DC821741,9,192.168.2.10:25,65.54.246.110:8002,>,250-STARTTLS,
    2009-04-29T11:42:53.323Z,blaEXCHANGE\Default blaEXCHANGE,08CB92F2DC821741,10,192.168.2.10:25,65.54.246.110:8002,>,250-X-ANONYMOUSTLS,
    2009-04-29T11:42:53.323Z,blaEXCHANGE\Default blaEXCHANGE,08CB92F2DC821741,11,192.168.2.10:25,65.54.246.110:8002,>,250-AUTH NTLM,
    2009-04-29T11:42:53.323Z,blaEXCHANGE\Default blaEXCHANGE,08CB92F2DC821741,12,192.168.2.10:25,65.54.246.110:8002,>,250-X-EXPS GSSAPI NTLM,
    2009-04-29T11:42:53.323Z,blaEXCHANGE\Default blaEXCHANGE,08CB92F2DC821741,13,192.168.2.10:25,65.54.246.110:8002,>,250-8BITMIME,
    2009-04-29T11:42:53.323Z,blaEXCHANGE\Default blaEXCHANGE,08CB92F2DC821741,14,192.168.2.10:25,65.54.246.110:8002,>,250-BINARYMIME,
    2009-04-29T11:42:53.323Z,blaEXCHANGE\Default blaEXCHANGE,08CB92F2DC821741,15,192.168.2.10:25,65.54.246.110:8002,>,250-CHUNKING,
    2009-04-29T11:42:53.323Z,blaEXCHANGE\Default blaEXCHANGE,08CB92F2DC821741,16,192.168.2.10:25,65.54.246.110:8002,>,250-XEXCH50,
    2009-04-29T11:42:53.323Z,blaEXCHANGE\Default blaEXCHANGE,08CB92F2DC821741,17,192.168.2.10:25,65.54.246.110:8002,>,250 XRDST,
    2009-04-29T11:42:53.511Z,blaEXCHANGE\Default blaEXCHANGE,08CB92F2DC821741,18,192.168.2.10:25,65.54.246.110:8002,<,MAIL FROM:<absender@hotmail.de>,
    2009-04-29T11:42:53.511Z,blaEXCHANGE\Default blaEXCHANGE,08CB92F2DC821741,19,192.168.2.10:25,65.54.246.110:8002,*,08CB92F2DC821741;2009-04-29T11:42:53.151Z;1,receiving message
    2009-04-29T11:42:53.511Z,blaEXCHANGE\Default blaEXCHANGE,08CB92F2DC821741,20,192.168.2.10:25,65.54.246.110:8002,>,250 2.1.0 Sender OK,
    2009-04-29T11:42:53.682Z,blaEXCHANGE\Default blaEXCHANGE,08CB92F2DC821741,21,192.168.2.10:25,65.54.246.110:8002,<,RCPT TO:<empfänger1@bla.de>,
    2009-04-29T11:42:53.682Z,blaEXCHANGE\Default blaEXCHANGE,08CB92F2DC821741,22,192.168.2.10:25,65.54.246.110:8002,>,250 2.1.5 Recipient OK,
    2009-04-29T11:42:53.854Z,blaEXCHANGE\Default blaEXCHANGE,08CB92F2DC821741,23,192.168.2.10:25,65.54.246.110:8002,<,RCPT TO:<empfänger2@bla.de>,
    2009-04-29T11:42:53.854Z,blaEXCHANGE\Default blaEXCHANGE,08CB92F2DC821741,24,192.168.2.10:25,65.54.246.110:8002,>,250 2.1.5 Recipient OK,

    Etwas später habe ich dann noch zu der externen IP folgendes gefunden:


    2009-04-29T11:44:58.247Z,blaEXCHANGE\Default blaEXCHANGE,08CB92F2DC821741,25,192.168.2.10:25,65.54.246.110:8002,<,BDAT 1048626,
    2009-04-29T11:45:03.935Z,blaEXCHANGE\Default blaEXCHANGE,08CB92F2DC821741,26,192.168.2.10:25,65.54.246.110:8002,>,"250 2.6.0 CHUNK received OK, 1048626 octets",
    
    2009-04-29T11:47:04.828Z,blaEXCHANGE\Default blaEXCHANGE,08CB92F2DC821741,27,192.168.2.10:25,65.54.246.110:8002,<,BDAT 1048632,
    2009-04-29T11:47:10.531Z,blaEXCHANGE\Default blaEXCHANGE,08CB92F2DC821741,28,192.168.2.10:25,65.54.246.110:8002,>,"250 2.6.0 CHUNK received OK, 1048632 octets",
    
    2009-04-29T11:49:11.158Z,blaEXCHANGE\Default blaEXCHANGE,08CB92F2DC821741,29,192.168.2.10:25,65.54.246.110:8002,<,BDAT 1048632,
    2009-04-29T11:49:16.659Z,blaEXCHANGE\Default blaEXCHANGE,08CB92F2DC821741,30,192.168.2.10:25,65.54.246.110:8002,>,"250 2.6.0 CHUNK received OK, 1048632 octets",
    2009-04-29T11:49:16.659Z,blaEXCHANGE\Default blaEXCHANGE,08CB92F2DC821741,31,192.168.2.10:25,65.54.246.110:8002,-,,Remote


    Ich weiss leider nicht ob das auch noch zur Übertragung gehört und ob diese jetzt erfolgreich war?! In der Nachrichtenverfolgungslog an dem Tag finde ich zumindest keine entsprechenden Einträge. Es wurde wohl auch keine Rückmeldung erhalten wegen Unzustellbarkeit oder ähnlichem...Kann mir da vielleicht jemand weiterhelfen?

    Müssten in der Empfangconnectorlog auch Einträge drin stehe, wenn eine Übertragung der E-Mail z.B. wegen "exceeded storage allocation" nicht stattgefunden hat?

    mfg
    mauii

    Mittwoch, 6. Mai 2009 09:00

Antworten

  • Hallo mauii,

    es scheint, als ob der Empfangsconnector und der sendende Server mit den EHLO Schlüsselwörtern Chunking/BinaryMIME nicht zurechtkommen. Versuche doch mal beide EHLO-Befehle am Connector zu deaktivieren.

    Set-ReceiveConnector -Identity <Connectorname> -BinaryMimeEnabled:$false
    Set-ReceiveConnector -Identity <Connectorname> -Chunking:$false

    Und ja, sämtliche SMTP Codes sollten dann im Log stehen - auch z.B. "exceeded storage allocation"

    Grüße
    Sascha
    Mittwoch, 6. Mai 2009 21:56

Alle Antworten

  • Hallo mauii,

    es scheint, als ob der Empfangsconnector und der sendende Server mit den EHLO Schlüsselwörtern Chunking/BinaryMIME nicht zurechtkommen. Versuche doch mal beide EHLO-Befehle am Connector zu deaktivieren.

    Set-ReceiveConnector -Identity <Connectorname> -BinaryMimeEnabled:$false
    Set-ReceiveConnector -Identity <Connectorname> -Chunking:$false

    Und ja, sämtliche SMTP Codes sollten dann im Log stehen - auch z.B. "exceeded storage allocation"

    Grüße
    Sascha
    Mittwoch, 6. Mai 2009 21:56
  • Danke für deine Antwort !

    Kannst du mir auch vielleicht sagen woran du das ausmachst? :)

    Können mir da durch irgendwelche Nachteile entstehen wenn ich das deaktiviere??


     

    BDAT, CHUNKING

     

    Eine Alternative zum Befehl DATA, der zwei Argumente annimmt. Wenn ein virtueller SMTP-Server auf das Schlüsselwort EHLO mit CHUNKING antwortet, zeigt der SMTP-Server an, dass er den Befehl BDAT unterstützt und Nachrichten in Abschnitten entgegennimmt.

    Das erste Argument gibt die Länge des binären Datenpakets an, sodass der SMTP-Host nicht ständig nach dem Ende der Daten suchen muss. Der empfangende Server zählt die Bytes in der Nachricht und geht bei Erreichen der vom Befehl BDAT gesendeten Nachrichtengröße davon aus, dass alle Nachrichtendaten empfangen wurden. Das zweite Argument gibt an, ob es sich bei dem Datenpaket um das letzte Paket der aktuellen Übertragung handelt. Das zweite Argument ist optional.

     

    BINARYMIME

     

    Gibt an, dass der virtuelle SMTP-Server Nachrichten entgegennimmt, die binäre Daten ohne Transportcodierung enthalten. Dazu wird beim Befehl MAIL der Parameter BODY mit dem Wert "BINARYMIME" verwendet. Wenn der SMTP-Server einen MAIL-Befehl mit dem Wert BINARYMIME für den Parameter BODY akzeptiert, gibt der Server an, dass alle Bits in jedem mit dem Befehl BDAT übergebenen Oktett erhalten bleiben. Die SMTP-Erweiterung BINARYMIME kann nur zusammen mit CHUNKING verwendet werden.


    Das heißt für mich das er für die Verarbeitung der E-Mail ggf. einfach nur länger braucht oder kann es noch zu anderen Komplikationen führen?

    Ich kenn mich da leider noch fast gar nicht aus, wäre also super wenn du da ein bisschen Licht ins Dunkel bringen könntest :)


    mfg
    maui

    Donnerstag, 7. Mai 2009 06:32
  • Moin maui,

    ist eine reine Vermutung, da die Zustellung der email mindestens 3x versucht wurde (BDAT 1048632) aber anscheinend nicht durchkam. Wenn du das Chunking abstellst wird einfach das standard DATA Kommando gesendet. Die Verarbeitung der email sollte sich dadurch aber nicht verzögern.
    Wenn du das Chunking deaktiviert muss auch BinaryMIME deaktiviert sein ;)
    Donnerstag, 7. Mai 2009 07:00
  • Moin :)

    Ok, ich versuchs jetzt gleich "einfach mal" aus und geb dann noch eine Rückmeldung.

    Donnerstag, 7. Mai 2009 07:15
  • Ja, cool hat direkt geklappt =)



    2009-05-07T07:17:33.757Z,blaEXCHANGE\Default blaEXCHANGE,08CB92F2DC824AAA,0,192.168.2.10:25,65.54.246.87:20947,+,,
    2009-05-07T07:17:33.757Z,blaEXCHANGE\Default blaEXCHANGE,08CB92F2DC824AAA,1,192.168.2.10:25,65.54.246.87:20947,*,SMTPSubmit SMTPAcceptAnySender SMTPAcceptAuthoritativeDomainSender AcceptRoutingHeaders,Set Session Permissions
    2009-05-07T07:17:33.757Z,blaEXCHANGE\Default blaEXCHANGE,08CB92F2DC824AAA,2,192.168.2.10:25,65.54.246.87:20947,>,"220 blaexchange.bla.local Microsoft ESMTP MAIL Service ready at Thu, 7 May 2009 09:17:33 +0200",
    2009-05-07T07:17:33.944Z,blaEXCHANGE\Default blaEXCHANGE,08CB92F2DC824AAA,3,192.168.2.10:25,65.54.246.87:20947,<,EHLO bay0-omc1-s15.bay0.hotmail.com,
    2009-05-07T07:17:33.944Z,blaEXCHANGE\Default blaEXCHANGE,08CB92F2DC824AAA,4,192.168.2.10:25,65.54.246.87:20947,>,250-blaexchange.bla.local Hello [65.54.246.87],
    2009-05-07T07:17:33.944Z,blaEXCHANGE\Default blaEXCHANGE,08CB92F2DC824AAA,5,192.168.2.10:25,65.54.246.87:20947,>,250-SIZE,
    2009-05-07T07:17:33.944Z,blaEXCHANGE\Default blaEXCHANGE,08CB92F2DC824AAA,6,192.168.2.10:25,65.54.246.87:20947,>,250-PIPELINING,
    2009-05-07T07:17:33.944Z,blaEXCHANGE\Default blaEXCHANGE,08CB92F2DC824AAA,7,192.168.2.10:25,65.54.246.87:20947,>,250-DSN,
    2009-05-07T07:17:33.944Z,blaEXCHANGE\Default blaEXCHANGE,08CB92F2DC824AAA,8,192.168.2.10:25,65.54.246.87:20947,>,250-ENHANCEDSTATUSCODES,
    2009-05-07T07:17:33.944Z,blaEXCHANGE\Default blaEXCHANGE,08CB92F2DC824AAA,9,192.168.2.10:25,65.54.246.87:20947,>,250-STARTTLS,
    2009-05-07T07:17:33.944Z,blaEXCHANGE\Default blaEXCHANGE,08CB92F2DC824AAA,10,192.168.2.10:25,65.54.246.87:20947,>,250-X-ANONYMOUSTLS,
    2009-05-07T07:17:33.944Z,blaEXCHANGE\Default blaEXCHANGE,08CB92F2DC824AAA,11,192.168.2.10:25,65.54.246.87:20947,>,250-AUTH NTLM,
    2009-05-07T07:17:33.944Z,blaEXCHANGE\Default blaEXCHANGE,08CB92F2DC824AAA,12,192.168.2.10:25,65.54.246.87:20947,>,250-X-EXPS GSSAPI NTLM,
    2009-05-07T07:17:33.944Z,blaEXCHANGE\Default blaEXCHANGE,08CB92F2DC824AAA,13,192.168.2.10:25,65.54.246.87:20947,>,250-8BITMIME,
    2009-05-07T07:17:33.944Z,blaEXCHANGE\Default blaEXCHANGE,08CB92F2DC824AAA,14,192.168.2.10:25,65.54.246.87:20947,>,250-XEXCH50,
    2009-05-07T07:17:33.944Z,blaEXCHANGE\Default blaEXCHANGE,08CB92F2DC824AAA,15,192.168.2.10:25,65.54.246.87:20947,>,250 XRDST,
    2009-05-07T07:17:34.132Z,blaEXCHANGE\Default blaEXCHANGE,08CB92F2DC824AAA,16,192.168.2.10:25,65.54.246.87:20947,<,MAIL FROM:<absender@hotmail.de>,
    2009-05-07T07:17:34.132Z,blaEXCHANGE\Default blaEXCHANGE,08CB92F2DC824AAA,17,192.168.2.10:25,65.54.246.87:20947,*,08CB92F2DC824AAA;2009-05-07T07:17:33.757Z;1,receiving message
    2009-05-07T07:17:34.132Z,blaEXCHANGE\Default blaEXCHANGE,08CB92F2DC824AAA,18,192.168.2.10:25,65.54.246.87:20947,>,250 2.1.0 Sender OK,
    2009-05-07T07:17:34.335Z,blaEXCHANGE\Default blaEXCHANGE,08CB92F2DC824AAA,19,192.168.2.10:25,65.54.246.87:20947,<,RCPT TO:<empfänger@bla.de>,
    2009-05-07T07:17:34.335Z,blaEXCHANGE\Default blaEXCHANGE,08CB92F2DC824AAA,20,192.168.2.10:25,65.54.246.87:20947,>,250 2.1.5 Recipient OK,
    2009-05-07T07:17:34.522Z,blaEXCHANGE\Default blaEXCHANGE,08CB92F2DC824AAA,21,192.168.2.10:25,65.54.246.87:20947,<,DATA,
    2009-05-07T07:17:34.522Z,blaEXCHANGE\Default blaEXCHANGE,08CB92F2DC824AAA,22,192.168.2.10:25,65.54.246.87:20947,>,354 Start mail input; end with <CRLF>.<CRLF>,
    2009-05-07T07:17:35.069Z,blaEXCHANGE\Default blaEXCHANGE,08CB92F2DC824AAA,23,192.168.2.10:25,65.54.246.87:20947,>,250 2.6.0 <BAY117-W321ABFC33DAC9371DB5DB3A3670@phx.gbl> Queued mail for delivery,
    2009-05-07T07:17:35.257Z,blaEXCHANGE\Default blaEXCHANGE,08CB92F2DC824AAA,24,192.168.2.10:25,65.54.246.87:20947,<,QUIT,
    2009-05-07T07:17:35.257Z,blaEXCHANGE\Default blaEXCHANGE,08CB92F2DC824AAA,25,192.168.2.10:25,65.54.246.87:20947,>,221 2.0.0 Service closing transmission channel,
    2009-05-07T07:17:35.257Z,blaEXCHANGE\Default blaEXCHANGE,08CB92F2DC824AAA,26,192.168.2.10:25,65.54.246.87:20947,-,,Local

    Du weisst aber auch nicht genau wie es zu den Problemen kommen kann oder? Besonders weil es bisher zumindest scheinbar nur Probleme bei Hotmail gab...Ich werde es einfach mal im Auge behalten :P

    Danke dir nochmal vielmals !!! =)

    mfg
    maui


    ps: ich hab hier dauernt probleme mit den dem codeblock wenn ich eine nachricht nochmal bearbeiten möchte ...!
    Donnerstag, 7. Mai 2009 07:26