none
Infopath in Seitenvorlage: Problem mit der Datenverbindung RRS feed

  • Frage

  • Hallo,

    ich habe eine InfoPath-Formularbibliothek auf einer Seite (unterhalb des Root-Webs), welche als Vorlage verwendet wird.
    In dem InfoPath Formular verwende ich Datenverbindungen die immer auf Listen des Root-Webs verweisen. Dies funktioniert auch auf der Seite, aus welcher ich die Vorlagen erstelle.

    Wenn ich nun aus der Vorlage eine neue Seite unterhalb des Root-Webs anlegen (gleiche Ebene wie die Seite die Basis für die Vorlage ist) wird die URL von allen Datenverbindungen auf die neue Seite umgelegt. Dort gibt es natürlich die Listen nicht.

    Beispiel:

    http://unserSharePoint/ Hier gibt es eine Liste mit Stammdaten welche abgerufen werden. Die URL ist so als Datenverbindung eingestellt.

    In dem InfoPath-Formular der neuen Seite welche von der Vorlage erstellt wurde. Ist die URL auf http://unserSharePoint/Unterwebseite/ angepasst.

    In anderen InfoPath-Formularen die in der gleichen Vorlage liegen passiert dies nicht. Wir haben keinen Unterschied bei den Einstellungen finden können.

    Hat jemand eine Idee woran das liegen könnte?

    Gruß

     

     

    Donnerstag, 24. März 2011 12:31

Antworten

  • Hallo,

    hat sich erledigt.
    Das Problem war, dass das InfoPath Formular in einer anderen Struktur designt wurde. D.h. das InfoPath-Formular wurde ursprünglich auf oberster Ebene designed und erst dann auf unterer Ebene hochgeladen. Wenn dann das Formular in einer Vorlage verwendet wurde, kommt InfoPath durcheinander.

    Also für die Datenverbindungen ist es enorm wichtig (auch wenn diese nicht relativ sind), dass das Formular in der gleichen Struktur designed wird, wie es auch später verwendet wird.

     

     

    • Als Antwort markiert ShareMino Donnerstag, 24. März 2011 13:02
    Donnerstag, 24. März 2011 13:02