none
Office 365 Integration auf Server 2016 Essentials schlägt fehl RRS feed

  • Frage

  • Hallo zusammen,

    ich betreibe einen WSE2016 mit ein paar Windows 10-Clients in einer Domäne und habe für die User entsprechende Office 365 Business Premium Accounts gebucht. Auf unserem bisherigen WSE2012R2 hat die Office 365-Integration nach etwas Gefummel auch funktioniert. Im Server-Dashboard des neu aufgesetzten hat die Integration bisher auch funktioniert. Der Wizard fragt im Laufe der Einrichtung, wie die lokalen Konten und die Cloud-Konten verknüpft werden sollen.

    Nach meinem Urlaub sehe ich im Dashboard plötzlich, das als Office 365-Status bei allen Usern unbekannt steht. Beim Anklicken des Kartenreiters Microsoft Cloud-Konto erscheint eine Fehlermeldung "Bitte prüfen Sie Ihre Internet-Verbindung". Ich habe dann die bestehende Office 365 Integration über den Assistenten entfernt, was auch problemlos funktionierte.

    Nun schlägt die erneute Integration fehl mit der Meldung:

    Der angegebene Account ist in Office 365 aber definitiv Globaler Administrator. Ich habe in Office 365 einen 2. globalen Admin angelegt, bei dem das gleiche Problem auftritt. Ich habe außerdem einen Testaccount mit dem gleichen O365-Plan angelegt. Auch bei diesem tritt das Problem auf.

    Alle Dienste auf dem WSE2016 laufen sauber hoch. Im Eventlog tauchen folgende Fehler auf:

    Quelle: Server Essentials Fehler: 1281

    Warnung: MSOGroupMembershipSyncFailed wurde um SERVER01 aufgerufen. <Title> Die Mitgliedschaft kann nicht mit Microsoft Cloud Services synchronisiert werden.. <Description> Mitgliedschaften können nicht mit Microsoft Cloud Services synchronisiert werden.. <AdditionalInfo> .

    Der Versuch, die Integration per PS anzustoßen, liefert das:

    S C:\Windows\system32> Enable-O365Integration

    Cmdlet Enable-O365Integration an der Befehlspipelineposition 1
    Geben Sie Werte für die folgenden Parameter an:
    O365AccountUPN: aministrator@mydomain.com
    Password: **************
    Enable-O365Integration : Failed to call Graph service with status code 403 and error: {
      "error": {
        "code": "Authorization_RequestDenied",
        "message": "Insufficient privileges to complete the operation.",
        "innerError": {
          "request-id": "696c0471-db8f-4e26-94b0-38b744c385c7",
          "date": "2018-05-08T09:11:38"
        }
      }
    }
    In Zeile:1 Zeichen:1
    + Enable-O365Integration
    + ~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : InvalidOperation: (:) [Enable-O365Integration], O365ConfigureException
        + FullyQualifiedErrorId : InvalidInvoke,Microsoft.WindowsServerSolutions.O365Integration.EnableO365IntegrationPSCmdlet

    Das ConfigWizard.log meldet folgendes:

    [13716] 180508.164931.1750: General: Initializing...C:\Windows\System32\Essentials\ConfigWizard.exe
    [14260] 180508.164931.8782: PfBinding: Information: [0] : Adding service dns identity [SERVER01] in proxy endpoint.
    [5404] 180508.164932.0188: PfBinding: Information: [0] : Adding service dns identity [SERVER01] in proxy endpoint.
    [13228] 180508.164932.4841: CloudServiceEnvironment: Failed to download cloud service environment file.
    [9288] 180508.164933.5892: PfBinding: Information: [0] : Adding service dns identity [SERVER01] in proxy endpoint.
    [4716] 180508.164957.1608: GettingStartedWizard: Start O365 service
    [14676] 180508.165002.5942: O365Manager: TResult : Boolean, args : Microsoft.WindowsServerSolutions.Common.ProviderFramework.OperationInvokeEventArgs`1[System.Boolean]
    [14676] 180508.165002.5942: O365Manager: actualArgs : Microsoft.WindowsServerSolutions.Common.ProviderFramework.OperationInvokeEventArgs`1[System.Boolean]
    [13484] 180508.165002.5962: GettingStartedWizard: Stop O365 service
    [13484] 180508.165003.1367: GettingStartedWizard: Activate O365 with Error AccessDenied returned.
    [13484] 180508.165003.1367: GettingStartedWizard: Activate O365 with Error AccessDenied returned.
    [13716] 180508.165005.9666: GettingStartedWizard: RebootOrRestartDashboardIfNecessary with restart flag is False

    Ich habe schon alle möglichen Tipps versucht und bin langsam am Verzweifeln.

    Gruß Arno

    Dienstag, 8. Mai 2018 15:07

Antworten

  • Nachtrag:

    Ich konnte das Problem selbst lösen. Sieht wie folgt aus:

    1. Im Essentials Dashboard -> Startseite -> Erste Schritte -> Setup den Assistenten für "Zugriff überall" starten.

    Voraussetzung:

    Subdomain mit entsprechenden DNS-Einträgen im Internet eingerichtet, z.B. remote.contoso.com

    Portforwarding und Firewallregel für eingehende Verbindungen im Router angelegt.

    Gültiges Zertifikat für die Subdomain vorhanden (kein self-signed)

    2. Assistent für "Zugriff überall" durchlaufen lassen.

    3. Im Essentials Dashboard -> Startseite -> Erste Schritte -> Services den Assistenten für "Office 365" starten.

    Im Assistenten die Option "Ich habe einen Office 365-Account" auswählen und im nächsten Schritt die Credentials des Office 365-Kontos angeben. Der Benutzer muss Globaler Administrator in Office 365 sein.

    Der Assistent sollte dann durchlaufen. Anschließend das Dashboard schließen und wieder öffnen. Nun sollte im Dashboard die zusätzliche Registerkarte "Office 365" angezeigt werden. Darin sind dann Angaben zu den O365-Usern, zur Firma und den verwendeten Lizenzen enthalten.

    Gruß Arno

    • Als Antwort markiert Arno Fink Freitag, 11. Mai 2018 07:29
    Freitag, 11. Mai 2018 07:29