none
Server 2003 SP2 Zugriff auf entfernten Server über VPN funktioniert nicht RRS feed

  • Allgemeine Diskussion

  • Hallo,

    ich greife von der Arbeit aus von einem Server 2003 SP2 über eine VPN Verbindung und dann mit RDP auf einen entfernten Server zu. Dyndns ist richtig konfiguriert und der Zugriff klappt auch wunderbar.

     Nun das Problem: In der Domäne auf der Arbeit ist der Server 2003 SP2 DC und auch dns Server. Dieser DNS server Speichert die alte IP Adresse, die er von Dyndns erhält über viele Stunden hinweg, sodass ich in dieser Zeit nicht auf den entfernten Server zugreifen, ohne mich bei Dyndns anzumelden und die aktuelle IP einzutragen. Welche Einstellung muss ich im Server 2003 vornehmen, damit die alte IP Adresse gelöscht und schnell durch die neue ersetzt werden kann? Ich hoffe, mich verständlich ausgedrückt zu haben.

     

    Danke und Gruß

    Mittwoch, 19. Oktober 2011 14:01

Alle Antworten

  • > Zeit nicht auf den entfernten Server zugreifen, ohne mich bei Dyndns
    > anzumelden und die aktuelle IP einzutragen. Welche Einstellung muss ich
     
    "Wessen" aktuelle IP - die des entfernten Servers? "ipconfig /flushdns"
    Oder hat der entfernte Server bei dyndns noch die falsche IP stehen?
    Bing/Google - "dyndns client for windows".
     
    mfg Martin
     

    A bissle "Experience", a bissle GMV...
    Mittwoch, 19. Oktober 2011 15:22
  • Hallo,

    danke für die Antwort.

    o.k. Im Router vor dem entfernten Server stimmt die dort eingetragene ip adresse mit der auf dyndns überein. das dyndns update habe ich direkt im router eingetragen.

    ipconfig /flushdns bringt keine Besserung. Komisch nur:

    Pinge ich die dyndns adresse vom server 2003 aus an, erhalte ich antwort. und zwar nicht mit der aktuellen ip adresse, sondern mit der alten (ich hatte die verbindung zwischenzeitlich getrennt, um eine neue ip zu erhalten).

    vielleicht habe ich mich jetzt klarer ausgedrückt;)

     

    gruß

     

    Mittwoch, 19. Oktober 2011 19:37
  • Nicht wirklich... Du hockst an einem Computer und pingst einen Router
    an, der eine DynDns-IP hat? Und die Antwort kommt dann mit der "alten"
    IP als Absender? Wie trennst Du die Verbindung? Machst Du da ein Port
    Forwarding oder Exposed Host oder wie oder was? Wie kommt der VPN-Tunnel
    zustande? Ich versteh's noch nicht.
     
    mfg Martin
     

    A bissle "Experience", a bissle GMV...
    Donnerstag, 20. Oktober 2011 15:19
  • Hi,

    ich bin auf der Arbeit. Ich versuche meinen Router daheim zu erreichen.  Auf dem Server auf der Arbeit wird nicht die aktuelle, auch bei dyndns hinterlegte IP adresse des routers angezeigt, sondern diejenige, welche vor der obligatorischen 24h trennung im router eingetragen war. ich führe ipconfig /flushdns auf dem server auf der arbeit aus- kein erfolg. immer noch die alte ip adresse eingetragen. die aufräumfunktion veralteter dns einträge habe ich auch auf alle 2 stunden gestellt. kein erfolg.

    die vpn verbindung stelle ich über den server 2003 immanenten netzwerkverbindungsassistenten her. hier muss man ja seine dyndns adresse eintragen.

    jetzt besser;)?

    gruß

    Donnerstag, 20. Oktober 2011 18:54
  • Ah ok. Und was sagt - auf der Commandline Deines 2003 Servers - ein
    nslookup auf den DynDNS-Namen? Welcher Nameserver löst den Namen auf und
    welche Adresse liefert er dafür zurück?
     
    mfg Martin
     

    A bissle "Experience", a bissle GMV...
    Freitag, 21. Oktober 2011 08:29
  • Hallo,

    gestern gings wieder mal, mit der Erreichbarkeit des Routers. Um 22.30 wurde dann die IP wieder gewechselt. Heute früh gings wieder nicht.

    Ein nslookup auf die ***.dyndns.org adresse liefert folgende Werte:

    Server: localhost

    Adress: 127.0.0.1

    Nicht autorisierende Antwort:

    Name: ***.dyndns.org

    Adress: 84.149.71.99

    Diese Adresse ist genau diejenige, die ich gestern, vor der "Trennung" hatte.

    Ein ping auf ***.dyndns.org liefert eine Antwort mit der gleichen IP Adresse.

    Danke und Gruß

    Samstag, 22. Oktober 2011 04:45
  • Hm - stimmt irgendwas mit Deinen Forwardern möglicherweise nicht? Und
    speichert Dein W2K3-DNS die IP tatsächlich selber ab, oder holt er die
    von woanders?
     
    mfg Martin
     

    A bissle "Experience", a bissle GMV...
    Montag, 24. Oktober 2011 08:11
  • Hallo,

    sorry für die verspätete Rückmeldung. Ich habe nachgeschaut und bei Weiterleitungen im DNS Server ist die IP des Routers eingetragen. Ich meine aber, das müsste gar nicht sein.? Vielleicht versursacht dies ja die Probleme. Noch was: Wenn ich vom server aus unsere Dyndns Adresse anpinge funktioniert es und ich erhalte eine Antwort. Von außen kann ich den Router über Dyndns nicht anpingen.

     

    Danke und Gruß

     


    Freitag, 28. Oktober 2011 04:17