none
Remote Desktop SBS2008 RRS feed

  • Frage

  • Hallo,

    ich administriere ein SBS2K8 Netzwerk, häufig auch aus der Ferne. Hierzu bin ich über ein VPN mit dem Netz verbunden. Unter Eigenschaften des SBS Servers ist RemoteDesktopSteuerung erlauben aktiviert. Trotzdem gelingt es mir nicht, diesen Server per Remote Desktop Verbindung anzusprechen. Bei SBS 2K3 NEtzwerken funktioniert das einwandfrei. Was mache ich falsch?

     

    Danke für Tips

     

    Peter

    Donnerstag, 22. September 2011 11:41

Antworten

  • Hi Peter,
     
    >> Bitte zugehörige Fehlermeldungen direkt vom RDP-Client, aus dessen
    >> Ereignisanzeige und auch aus der Ergeignisanzeige des SBS..
    [..]
    > Client: Da bin ich noch am Suchen - in der Ereignisanzeige des Clients
    > steht nichts (bzw. ich weiß nicht wo ich da suchen soll...
    [..]
    > Server: dito..
    > .. Die Fehlermeldung bei Aufruf lautet:
    > --------------------
    > "Der Remotedesktop kann aus einem der folgenden Gründe keine Verbindung
    > mit dem Remotecomputer herstellen: 1) Der Remotezugriff auf dem Server
    > ist nicht aktiviert 2) Der Remotecomputer ist ausgeschaltet 3) Der
    > Remotecomputer ist im Netzwerk nicht verfügbar Stellen Sie sicher, dass
    > der Remotecomputer eingeschaltet und mit dem Netzwerk verbunden und dass
    > der Remotezugriff aktiviert ist "
    > --------------------
    [..]
    > Das SBS eigene Zertifikat wird (bislang) nicht benutzt. Über
    > RemoteWebWorkplace kann eine Verbindung hergestellt werden, hier wird
    > ein StartSSL Zertifikat für die externe Adresse (remote.meineSite.de)
    > verwendet.
    >
    > Sollte ich das SBS eigene Zertifikat (für die IPAdresse?) verwenden oder
    > zerschieß ich mir dann den RemoteWebWorkplace ??
     
    Verwende weiterhin das "StartSSL Zertifikat".
     
    Was gibst Du im RDP-Client als "Computer" und unter
    "Advanced->Settings...->RDP Gateway server settings" ein?
     
    Der DNS-Name unter "Computer" bzw. "RDP Gateway server settings" muss vom
    RDP-Client auflösbar sein (TCP/IP-Einstellungen->DNS-Server->SBS-IP oder
    evtl. manuelle Einträge in die HOST-Daei des aufrufenden RDP-Clients)
     
    Des Weiteren muss der "RDP Gateway server settings"-Eintrag mit dem Namen
    im StartSSL Zertifikat übereinstimmen.
     
    Poste uns einmal den Inhalt der in ein RDP-File gespeicherte
    Session-Information (RDP-Client->General->Save As...->SBS.rdp->Open SBS.rdp
    in e.g. Notepad->Post content)
     
    --
    Tobias Redelberger
    StarNET Services (HomeOffice)
    Frankfurter Allee 193
    D-10365 Berlin
    Tel: +49 (30) 86 87 02 678
    Mobil: +49 (163) 84 74 421
    Email: T.Redelberger@starnet-services.net
     
    • Als Antwort markiert Peter Mang Montag, 26. September 2011 12:12
    Montag, 26. September 2011 11:19
    Moderator

Alle Antworten

  • VPN über einen Router oder über SBS Mittel.

    Kannst du den Server per Namen oder IP Pingen?

    Donnerstag, 22. September 2011 12:04
  • Hallo Patrik

    VPN über einen Router (Router zu Router VPN Netgear <-> Astaro). Ich kann mit IP pingen, über Name nicht (müsste den SBS bei mir in die Hosts nehmen). Zur Info: Der SBS 2K8 wurde ausschließlich mit den Assistenten eingerichtet.

     

    Gruß

     

    Peter

    Donnerstag, 22. September 2011 13:02
  • Kommst du per IP und RDP auf den Server?
    Donnerstag, 22. September 2011 13:05
  • Hallo Patrick

     

    RDP klappt nur aus dem internen Netz des SBS. Wenn ich von extern über VPN auf das SBS Netz zugreife ist RDP auf die IP Adresse nicht möglich. Ich habe kein Erklärung

    Gruß

     

    Peter

    Donnerstag, 22. September 2011 19:33
  • Hi Peter,
     
    > RDP klappt nur aus dem internen Netz des SBS. Wenn ich von extern über
    > VPN auf das SBS Netz zugreife ist RDP auf die IP Adresse nicht möglich.
    > Ich habe kein Erklärung
     
    Bitte zugehörige Fehlermeldungen direkt vom RDP-Client, aus dessen
    Ereignisanzeige und auch aus der Ergeignisanzeige des SBS. Und wenn du dort
    nicht findest, dann such noch mal, es wird zugehörige Fehlermeldungen
    geben.
     
     
    P.S.: Wird das SBS-eigene Zertifikat benutzt, und wenn ja, wurde das
    Stammzertifikat der SBS-CA ("\\sites\public\Downloads\Install Certificate
    Package.zip") auf den externen, nicht Domänen-Mitglieder installiert und
    wird das RDS-Gateway Zertifikat (vorher ggf. als CER-Datei exportieren bzw.
    abspeichern) auf diesen externen Client mittels:
     
    certutil -verify -urlfetch <RDS-Gateway.cer> > C:\temp\certutil_verify.txt
     
    als gültig eingestuft?
     
    --
    Tobias Redelberger
    StarNET Services (HomeOffice)
    Frankfurter Allee 193
    D-10365 Berlin
    Tel: +49 (30) 86 87 02 678
    Mobil: +49 (163) 84 74 421
    Email: T.Redelberger@starnet-services.net
     
    Montag, 26. September 2011 07:40
    Moderator
  • Hallo Tobias,

    > Bitte zugehörige Fehlermeldungen direkt vom RDP-Client, aus dessen
    > Ereignisanzeige und auch aus der Ergeignisanzeige des SBS..
    Client: Da bin ich noch am Suchen - in der Ereignisanzeige des Clients steht nichts (bzw. ich weiß nicht wo ich da suchen soll...
    :(
    Server: dito..
    .. Die Fehlermeldung bei Aufruf lautet:
    --------------------
    "Der Remotedesktop kann aus einem der folgenden Gründe keine Verbindung mit dem Remotecomputer herstellen:
    1) Der Remotezugriff auf dem Server ist nicht aktiviert
    2) Der Remotecomputer ist ausgeschaltet
    3) Der Remotecomputer ist im Netzwerk nicht verfügbar
    Stellen Sie sicher, dass der Remotecomputer eingeschaltet und mit dem Netzwerk verbunden und dass der Remotezugriff aktiviert ist "
    --------------------
    Das SBS eigene Zertifikat wird (bislang) nicht benutzt. Über RemoteWebWorkplace kann eine Verbindung hergestellt werden, hier wird ein StartSSL Zertifikat für die externe Adresse (remote.meineSite.de) verwendet.
    Sollte ich das SBS eigene Zertifikat (für die IPAdresse?) verwenden oder zerschieß ich mir dann den RemoteWebWorkplace ??
    Gruß und Danke für Deine Antwort
    Peter
    Montag, 26. September 2011 09:07
  • Hi Peter,
     
    >> Bitte zugehörige Fehlermeldungen direkt vom RDP-Client, aus dessen
    >> Ereignisanzeige und auch aus der Ergeignisanzeige des SBS..
    [..]
    > Client: Da bin ich noch am Suchen - in der Ereignisanzeige des Clients
    > steht nichts (bzw. ich weiß nicht wo ich da suchen soll...
    [..]
    > Server: dito..
    > .. Die Fehlermeldung bei Aufruf lautet:
    > --------------------
    > "Der Remotedesktop kann aus einem der folgenden Gründe keine Verbindung
    > mit dem Remotecomputer herstellen: 1) Der Remotezugriff auf dem Server
    > ist nicht aktiviert 2) Der Remotecomputer ist ausgeschaltet 3) Der
    > Remotecomputer ist im Netzwerk nicht verfügbar Stellen Sie sicher, dass
    > der Remotecomputer eingeschaltet und mit dem Netzwerk verbunden und dass
    > der Remotezugriff aktiviert ist "
    > --------------------
    [..]
    > Das SBS eigene Zertifikat wird (bislang) nicht benutzt. Über
    > RemoteWebWorkplace kann eine Verbindung hergestellt werden, hier wird
    > ein StartSSL Zertifikat für die externe Adresse (remote.meineSite.de)
    > verwendet.
    >
    > Sollte ich das SBS eigene Zertifikat (für die IPAdresse?) verwenden oder
    > zerschieß ich mir dann den RemoteWebWorkplace ??
     
    Verwende weiterhin das "StartSSL Zertifikat".
     
    Was gibst Du im RDP-Client als "Computer" und unter
    "Advanced->Settings...->RDP Gateway server settings" ein?
     
    Der DNS-Name unter "Computer" bzw. "RDP Gateway server settings" muss vom
    RDP-Client auflösbar sein (TCP/IP-Einstellungen->DNS-Server->SBS-IP oder
    evtl. manuelle Einträge in die HOST-Daei des aufrufenden RDP-Clients)
     
    Des Weiteren muss der "RDP Gateway server settings"-Eintrag mit dem Namen
    im StartSSL Zertifikat übereinstimmen.
     
    Poste uns einmal den Inhalt der in ein RDP-File gespeicherte
    Session-Information (RDP-Client->General->Save As...->SBS.rdp->Open SBS.rdp
    in e.g. Notepad->Post content)
     
    --
    Tobias Redelberger
    StarNET Services (HomeOffice)
    Frankfurter Allee 193
    D-10365 Berlin
    Tel: +49 (30) 86 87 02 678
    Mobil: +49 (163) 84 74 421
    Email: T.Redelberger@starnet-services.net
     
    • Als Antwort markiert Peter Mang Montag, 26. September 2011 12:12
    Montag, 26. September 2011 11:19
    Moderator
  • Hallo Tobias,

     

    vielen Dank für die Anwort - sie hat mein Problem gelöst:

    Ich hatte keine Einträge für das TS Gateway (war mir bislang nicht bekannt das man sowas braucht...). Ausserdem habe ich bis jetzt versucht die RDP Verbindung über die IP herzustellen.

     

    TS - Gateway eingetragen, den RemoteNamen in die hosts und

    Schwupps - alles klappt.

     

    Danke nochmal

     

    Peter

    Montag, 26. September 2011 12:12