none
.NET 3.5 installation - Fehlercode 0x800f081f RRS feed

  • Frage

  • Gute Tag

    Ich versuche gerdade - erfolglos - .Net 3.5 (benötigt für SQL 2008) auf einem Win 2012 R2 zu installieren.

    Die Featureinstallation über den Server-Manager schlägt ohne bestimmte Fehlermeldung fehl. Ich habe eine alternative Installationsquelle angegeben.

    Eine Installation über

    DISM /Online /Enable-Feature /FeatureName:NetFx3 /All /LimitAccess /Source:z:\Windows2012R2CD\sources\sxs

    ergibt folgendes:

    Tool zur Imageverwaltung für die Bereitstellung
    Version: 6.3.9600.17031
    Abbildversion: 6.3.9600.17031
    Features werden aktiviert
    [===========================66.4%======                    ]
    Fehler: 0x800f081f
    Die Quelldateien wurden nicht gefunden.
    Geben Sie mit der Option "Quelle" den Ort der Dateien an, die zum Wiederherst
    en des Features erforderlich sind. Weitere Informationen zum Angeben eines Qu
    orts finden Sie unter "[Im Textkörper dürfen keine Bilder oder Links enthalten sein, bis Ihr Konto von uns geprüft werden kann.]".
    Die DISM-Protokolldatei befindet sich unter "C:\Windows\Logs\DISM\dism.log".

    im DISM Log

    finde ich dann u.a. folgende Zeilen:

    2014-10-02 08:09:02, Info                  DISM   DISM Package Manager: PID=3132 TID=1968 Encountered the option "source" with value "z:\Windows2012R2CD\sources\sxs"
     - CPackageManagerCLIHandler::Private_GetPackagesFromCommandLine
    2014-10-02 08:09:02, Info                  DISM   DISM Package Manager: PID=3132 TID=1968 Encountered an unknown option "source" with value "z:\Windows2012R2CD\sources\sxs"
     - CPackageManagerCLIHandler::Private_GetPackagesFromCommandLine
    
    2014-10-02 08:10:19, Info                  DISM   DISM Package Manager: PID=3132 TID=3584  Error in operation: source for package or file not found, ResolveSource()
     unsuccessful. (CBS HRESULT=0x800f081f) - CCbsConUIHandler::Error

    Anmerkungen:

    Ich habe bereits mehrere Quellen angegeben. Zunächst hatte ich eine auf einem netzlaufwerk, die ich früher schon für die Installation von .net benutzt habe. Dann habe ich das installationsmedium von der der Server nur wenige Stunden zuvor installiert wurde eingelegt und dieses als Quelle angeben. und zu guter letzt habe ich dann auch noch den SxS ordner von der DVD auf c: kopiert und auch dies versucht. Es schlägt leider immer fehl.

    In der Meldung die DSIM wirft heißt es: "Geben Sie mit der Option "Quelle" den Ort der Dateien an, die zum Wiederherst
    en des Features erforderlich sind." Die Option "Quelle" gibt es allerdings nicht. Sie heißt Source. Könnte das Teil des Problems sein?

    Auf dem Server ist bisher gar nichts geschehen außer Aufnahme in Domäne und Windows Update.

    Es wurden keine Programme installiert und keine Rollen oder Features aktiviert.

    Bitte sagt mir wie ich zu .NET komme, es ist für den SQL unabdingbar.

    Gruß, Sascha





    • Bearbeitet Sascha Loth Donnerstag, 2. Oktober 2014 07:06
    Donnerstag, 2. Oktober 2014 07:01

Antworten

  • Hi Sascha,

    schau mal unter den installierten Updates, ob da eines der Updates KB2966826-828 installiert ist. Wenn ja, dann musst Du diese(s) erst entfernen, dann dürfte die Installation klappen (unter Angabe des Originalmediums als Installationsquelle, also z.B. D:\sources\sxs).


    Gruß

    Ben

    MCITP Windows 7

    Wenn Dir meine Antwort hilft, markiere sie bitte entsprechend als Antwort! Danke! :-)

    Hinweis: Meine Posts werden "wie besehen" ohne jedwede Gewähr bereitgestellt, da menschliche, technische und andere Fehler nicht ausgeschlossen werden können.

    • Als Antwort markiert Sascha Loth Donnerstag, 2. Oktober 2014 07:42
    Donnerstag, 2. Oktober 2014 07:30
  • Hi Sascha,

    schau mal unter den installierten Updates, ob da eines der Updates KB2966826-828 installiert ist. Wenn ja, dann musst Du diese(s) erst entfernen, dann dürfte die Installation klappen (unter Angabe des Originalmediums als Installationsquelle, also z.B. D:\sources\sxs).


    Gruß

    Ben

    MCITP Windows 7

    Wenn Dir meine Antwort hilft, markiere sie bitte entsprechend als Antwort! Danke! :-)

    Hinweis: Meine Posts werden "wie besehen" ohne jedwede Gewähr bereitgestellt, da menschliche, technische und andere Fehler nicht ausgeschlossen werden können.

    Vielen Dank.

    Die Deinstalltion des "Sicherheitsupdates für Microsoft Windows (KB2966828)" führte zum Erfolg. 826 und 827 waren nicht installiert.

    Danach hat die Installation vom Netzwerkpfad funktioniert.

    Besten Dank an alle

    • Als Antwort markiert Sascha Loth Donnerstag, 2. Oktober 2014 07:42
    Donnerstag, 2. Oktober 2014 07:42

Alle Antworten

  • Hi Sascha,

    schau mal unter den installierten Updates, ob da eines der Updates KB2966826-828 installiert ist. Wenn ja, dann musst Du diese(s) erst entfernen, dann dürfte die Installation klappen (unter Angabe des Originalmediums als Installationsquelle, also z.B. D:\sources\sxs).


    Gruß

    Ben

    MCITP Windows 7

    Wenn Dir meine Antwort hilft, markiere sie bitte entsprechend als Antwort! Danke! :-)

    Hinweis: Meine Posts werden "wie besehen" ohne jedwede Gewähr bereitgestellt, da menschliche, technische und andere Fehler nicht ausgeschlossen werden können.

    • Als Antwort markiert Sascha Loth Donnerstag, 2. Oktober 2014 07:42
    Donnerstag, 2. Oktober 2014 07:30
  •  
    > Auf dem Server ist bisher gar nichts geschehen außer Aufnahme in Domäne
    > und Windows Update.
     
    Windows Update war wohl der Fehler. Ich habe gehört, daß es 2 .NET 3.5
    Updates gibt, die sich auch installieren, wenn noch gar kein .NET 3.5
    vorhanden ist. Die müssen wieder runter...
     

    Martin

    Mal ein GUTES Buch über GPOs lesen?

    NO THEY ARE NOT EVIL, if you know what you are doing: Good or bad GPOs?
    And if IT bothers me - coke bottle design refreshment :))
    Donnerstag, 2. Oktober 2014 07:31
  • Hi Sascha,

    schau mal unter den installierten Updates, ob da eines der Updates KB2966826-828 installiert ist. Wenn ja, dann musst Du diese(s) erst entfernen, dann dürfte die Installation klappen (unter Angabe des Originalmediums als Installationsquelle, also z.B. D:\sources\sxs).


    Gruß

    Ben

    MCITP Windows 7

    Wenn Dir meine Antwort hilft, markiere sie bitte entsprechend als Antwort! Danke! :-)

    Hinweis: Meine Posts werden "wie besehen" ohne jedwede Gewähr bereitgestellt, da menschliche, technische und andere Fehler nicht ausgeschlossen werden können.

    Vielen Dank.

    Die Deinstalltion des "Sicherheitsupdates für Microsoft Windows (KB2966828)" führte zum Erfolg. 826 und 827 waren nicht installiert.

    Danach hat die Installation vom Netzwerkpfad funktioniert.

    Besten Dank an alle

    • Als Antwort markiert Sascha Loth Donnerstag, 2. Oktober 2014 07:42
    Donnerstag, 2. Oktober 2014 07:42