none
RPC Server nicht erreichbar RRS feed

  • Allgemeine Diskussion

  • Hallo zusammen,

    wir haben vor ca. 3 Wochen eine Windows 2003r2 Domäne auf Windows 2012r2 migriert. Es gibt jetzt nur noch einen DC mit Windows 2012r2. Unter den Vertrauenseinstellungen wurde alles auf Win2012r2 hochgestuft.

    Es läuft alles sehr gut bis auf ein Problem, dass ich leider nicht lösen kann. Der Server wird jeden Tag neugestartet. In den 3 Wochen war zweimal nach dem Neustart kein Anmelden von WinXP und Win2003 möglich. Am Client kam die Meldung  "RPC Server nicht erreichbar". Win7 funktioniert.

    In den Event Logs sieht alles wie bei jedem Neustart aus. Auch alle Dienste laufen

    Ein Eintrag kommt bei jedem Neustart:

    Quelle lphlpsvc
    Die IP-Adresse für die lsatap-Schnittstelle isatap wurde nicht aktualisiert

    Starte ich den Server neu. Funktioniert es sofort wieder.

    Ich habe den Server am Abend 15 mal neu gestartet und hatte diesen Fehler nicht. Aber heute früh war es wieder so weit.

    DCdiag meldet keine Fehler.

    Der Win2012r2 Server läuft momentan als VM unter einem Windows 2008r2 HyperV. Könnte das vielleicht ein Problem sein, im Event Log sieht man dass er  Hyper-V-Netvsc mit 5.0 und 4.0 nicht verwenden kann, sondern er nimmt dann 3.2.

    Momentan läuft NTLM-Auth. Er meldet immer, dass man diese Auth. nicht verwenden solle. Könnte das vielleicht mein Problem sein? Wenn ich es hochstelle, können dann die WinXP und Win2003 überhaupt noch mit dem Server eine Verbindung aufbauen.

      

    Habt Ihr vielleicht noch eine Idee?

    Danke im Voraus.

    Heinz



    Dienstag, 4. Februar 2014 07:52

Alle Antworten

  • sieht so aus, als ob nicht der reboot das Problem wäre, sondern irgendwas, was nachts passiert.

    guck mal in den taskplaner was da so alles nachts läuft

    Dienstag, 4. Februar 2014 14:28
  • Danke für Deine Anwort.

    Der Reboot läuft um 05:00 Uhr Früh. Der Server startet vor Arbeitsbeginn. Die gesamten Backups sind durchgelaufen.

    Danke

    Dienstag, 4. Februar 2014 18:11
  • Hallo nochmal,

    ich bin leider noch immer nicht weitergekommen. Allerdings hatte ich heute den gleichen Fall umgekehrt gehabt.

    Die WinXP/Win2003 Rechner liefen heute ohne Probleme. Alle Win7/Win2008r2 Rechner konnten nicht mehr auf den DC zugreifen.

    Am Windows 2012r2 Server konnte ich mich sogar nicht mehr anmelden. Erst nach einem Neustart konnte ich mich wieder anmelden.

    Am Windows 2008r2 Server kam folgende Meldungen wenn ich über \\Servername\ darauf zugreifen wollte:

    Zielkontenname ist ungültig.

    Unter Win2003 konnte ich ohne Probleme auf \\Servername zugreifen.

    Es kann doch dann fast kein DNS Problem sein?

    Ich habe bei der Migration von Win2003 folgendes durchgeführt (Kurzform):

    Ich habe in die Domäne einen Win2012r2 Server als Memberserver hinzufügt und dann die Domäne auf diesen Server repliziert

    Dann habe ich die Domäne vom Win2003 (Servername: ADSRV) mit dcpromo entfernt und den Server im AD gelöscht. Danach habe ich die Domäne am Win2012r2 Server hochgestuft.

    Dann habe ich einen Win2012r2 Server mit dem gleichen Namen von Win2003Server (ADSRV) als Memberserver hinzugefügt und darauf wieder die Domäne repliziert.

    Danach habe ich den ersten Win2012r2 wieder heruntergestuft. 

    Damit habe ich erreicht, dass ich den gleichen Servername wie bei Windows 2003 Zeiten habe und ich bei keinem Client etwas ändern musste.

    Aber vielleicht ist das auch mein Problem

    Ich habe einiges gelesen, dass der gleiche Servername und andere Mac Adresse zu Problemen führen kann.

    Könnte das vielleicht meine Lösung sein:

    Registry unter LANMAN--> Parameters einen Wert "DisableStrictNameChecking" auf 1 setzen.

    Danke im Voraus.

    Heinz

    Montag, 17. Februar 2014 12:29
  • Moin,

    wie ist denn die Namensauflösung konfiguriert?

    Zeigen die Clients in ihrer Netzwerkkonfiguration auf den richtigen DNS-Server (also den Neuen, und nichts anderes)?

    \\Servername ist (in der Regel) nicht DNS! \\servername.domäne.xxx wäre es.

    Hast Du das Feature Server auf dem Server aktiviert und weiß das auch die Netzwerkkarte des Servers? Kann gerade mit älteren Clients sehr hilfreich sein, WINS zu nutzen und zu konfigurieren.

    Hat der Server nur ein Netzwerkinterface aktiv und sind die Stromsparmechanismen dafür im Gerätemanager abgeschaltet?

    Die Clients erhalten ihre IP-Adressen über DHCP - vom Server, vom Router - oder sind die manuell eingegeben?

    Poste mal die Ausgabe von ipconfig /all vom Server und einem der betroffenen Clients.

    Der isatap-Adapter wird auf meinen Servern generell als Nicht verbunden gelistet und hat daher natürlich auch keine IP-Adresse.

    Die Uhrzeit weicht nicht außergewöhnlich ab?

    Viele Grüße
    Olaf

    Montag, 17. Februar 2014 13:46
  • Hallo Olaf,

    danke für deine Nachricht.

    Der DNS Server läuft auf dem Win2012r2 Server. Es gibt auch nur einen DNS Server und einen AD Server.

    Bei den Clients und auch bei allen Server ist auch nur diese eine Server bei DNS eingetragen.

    Die Server haben feste IPs. Die Clients holen sich die IPs vom DHCP Server. Dieser läuft auch auf dem Windows 2012r2 Server

    Der Server hat nur eine Netzwerkkarte. Die Energieeinstellungen sind alle deaktiviert.

    Die Uhrzeiten sind syncron.

    Das ist die IPCONFIG vom Server:

    Windows-IP-Konfiguration

       Hostname  . . . . . . . . . . . . : ADSRV
       Prim„res DNS-Suffix . . . . . . . : pgad.lokal
       Knotentyp . . . . . . . . . . . . : Hybrid
       IP-Routing aktiviert  . . . . . . : Nein
       WINS-Proxy aktiviert  . . . . . . : Nein
       DNS-Suffixsuchliste . . . . . . . : pgad.lokal

    Ethernet-Adapter Ethernet:

       Verbindungsspezifisches DNS-Suffix: 
       Beschreibung. . . . . . . . . . . : Microsoft Hyper-V-Netzwerkadapter
       Physische Adresse . . . . . . . . : 00-15-5E-05-A6-1A
       DHCP aktiviert. . . . . . . . . . : Nein
       Autokonfiguration aktiviert . . . : Ja
       Verbindungslokale IPv6-Adresse  . : fe80::79dd:3397:e9d4:4aa0%12(Bevorzugt) 
       IPv4-Adresse  . . . . . . . . . . : 192.168.1.1(Bevorzugt) 
       Subnetzmaske  . . . . . . . . . . : 255.255.252.0
       Standardgateway . . . . . . . . . : 192.168.1.100
       DHCPv6-IAID . . . . . . . . . . . : 201332061
       DHCPv6-Client-DUID. . . . . . . . : 00-01-00-01-1A-5B-D0-6A-01-15-5D-05-A5-2A
       DNS-Server  . . . . . . . . . . . : ::1
                                           192.168.1.1
       NetBIOS ber TCP/IP . . . . . . . : Aktiviert

    Tunneladapter isatap.{33A01DE5-C533-4698-AA16-415B0E85AFBB}:

       Medienstatus. . . . . . . . . . . : Medium getrennt
       Verbindungsspezifisches DNS-Suffix: 
       Beschreibung. . . . . . . . . . . : Microsoft-ISATAP-Adapter
       Physische Adresse . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP aktiviert. . . . . . . . . . : Nein
       Autokonfiguration aktiviert . . . : Ja

    Tunneladapter Teredo Tunneling Pseudo-Interface:

       Medienstatus. . . . . . . . . . . : Medium getrennt
       Verbindungsspezifisches DNS-Suffix: 
       Beschreibung. . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
       Physische Adresse . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP aktiviert. . . . . . . . . . : Nein
       Autokonfiguration aktiviert . . . : Ja

    Das ist die IPConfig von einem Terminalserver (Win2003)



    Windows-IP-Konfiguration


       Hostname  . . . . . . . . . . . . : term04

       Primäres DNS-Suffix . . . . . . . : pgad.lokal

       Knotentyp . . . . . . . . . . . . : Unbekannt

       IP-Routing aktiviert  . . . . . . : Nein

       WINS-Proxy aktiviert  . . . . . . : Nein

       DNS-Suffixsuchliste . . . . . . . : pgad.lokal



    Ethernet-Adapter Extern:



       Verbindungsspezifisches DNS-Suffix: 

       Beschreibung  . . . . . . . . . . : Broadcom NetXtreme Gigabit Ethernet

       Physikalische Adresse . . . . . . : 00-eE-4F-3E-3C-54

       DHCP aktiviert  . . . . . . . . . : Nein

       IP-Adresse. . . . . . . . . . . . : 192.168.1.6

       Subnetzmaske  . . . . . . . . . . : 255.255.252.0

       Standardgateway . . . . . . . . . : 192.168.1.100

       DNS-Server  . . . . . . . . . . . : 192.168.1.1

    Es läuft zwei Wochen gut und dann geht es wieder nicht mehr. Nach einem Serverneustart geht es wieder.

    Der Server wird jeden Tag gegen ca. 05:00 Uhr neugestartet.

    Danke im Voraus.

    Heinz

    Montag, 17. Februar 2014 19:13
  • Hallo zusammen,

    ich bin ein kleinen Stück weitergekommen. Ich habe gerade den Fall gehabt, dass kein XP und Windows 2003 auf den Windows 2012r2 Server zugreifen konnte.

    Nachdem ich den Server Dienst (LanmanSERVER) neugestartet habe, hat der Zugriff sofort wieder funktioniert.

    Wahrscheinlich gibt es manchmal das Problem, dass der Server nach dem Neustart das SMB1 Protokoll nicht aktiviert. 

    Habt Ihr vielleicht eine weitere Idee was ich jetzt am besten tun sollte.

    Soll ich den Dienst nach dem Serverneustart immer noch einmal etwas später neu starten lassen.

    Kann ich den SMB1 Zugriff überwachen.

    Ich wäre für jede Idee dankbar.

    Gibt es vielleicht ein Tool, dass man auf einen Win2003 Server installiert und dieses Tool überwacht den Zugriff auf den Win2012r2. Sobald dieser nicht mehr geht, wird der Dienst Lanmanserver neugestartet?

    Danke

    Heinz

    Dienstag, 18. Februar 2014 20:23
  • Moin,

    klingt für mich merkwürdig, aber ich habe so alte Kisten auch nicht mehr in Betrieb. Ich würde dafür sorgen, dass als DNS-Server nicht die ::1 in Erscheinung tritt (und schon gar nicht an erster Stelle), und zudem WINS einrichten, damit die Namensauflösung zuverlässig gewährleistet ist.

    Die Frage bei der von Dir angedachten Lösung ist, wie denn der nicht mehr erreichbare Server zur Kenntnis nimmt, dass er nicht mehr erreichbar ist, um den Dienst neu zu starten.

    Sicher könnte man das mit einem PowerShell-Script erschlagen, welches dann als geplante Aufgabe alle x Minuten ausgeführt wird. So in der Art:

    $targetPC = "ADSRV"
    $online = Test-Path "\\$targetPC\c$"
    if ( $online -eq $false ) {
        write-host "System $targetPC is unreachable!"
        #mach irgendwas
        exit
        }

    Statt c$ eine real freigegebene Datei auf Existenz prüfen.

    "Mach irgendwas" könnte zum Beispiel eine Logdatei an einer Stelle erzeugen, auf deren Vorhandensein ein weiteres Script auf dem betroffenen Server prüfen kann. Ist die Datei da, löscht das Script sie und startet den Dienst neu.

    Viele Grüße
    Olaf

    Mittwoch, 19. Februar 2014 10:05
  • Hallo Olaf,

    herzlichen Dank für deine Nachricht.

    Aber der DNS und ADServer ist die 1. Was siehst Du für ein Problem wenn der DNS und der ADServer die IP 192.168.1.1 haben?

    Danke für das Script. Das ist eine sehr gute Idee. Ich werde es heute Abend mal testen.

    Danke.

    Schöne Grüße,

    Heinz

    Mittwoch, 19. Februar 2014 11:29
  • > Aber der DNS und ADServer ist die 1. Was siehst Du für ein Problem wenn
    > der DNS und der ADServer die IP 192.168.1.1 haben?
     
    Wenn der DNS ein Problem hat, startet auch AD nicht mehr... Wenn möglich
    hast Du ohnehin 2 DCs, dann machst Du den jeweils anderen zum primären DNS.
     

    Martin

    Mal ein GUTES Buch über GPOs lesen?

    NO THEY ARE NOT EVIL, if you know what you are doing: Good or bad GPOs?
    And if IT bothers me - coke bottle design refreshment :))
    Mittwoch, 19. Februar 2014 11:56
  • Ich meine die IPv6-Adresse. Die andere ist ok.

    Vielleicht mal nur DNS Server über IPv4  anbieten.

    Viele Grüße
    Olaf

    Donnerstag, 20. Februar 2014 14:37