none
Windows 10 Gruppenrichtlinien erst bei Neustart, nicht bei Herunterfahren und Start RRS feed

  • Frage

  • Hallo,

    nach der Umstellung der PCs auf Windows 10 (egal welche Version) werden die Gruppenrichtlinien immer nur bei einem Neustart des PCs gezogen. Das Problem gab es nicht unter Windows 7 und hat bei Windows 8 angefangen. Mit Umstellung auf SSDs wurde das Problem noch schlimmer, da der Rechner noch schneller startet.

    Bsp: Ich hinterlege ein neues MSI-Paket (Server 2008R2). Wenn der Nutzer nun seinen PC am Abend herunterfährt und am nächsten morgen wieder startet, wird das Paket nicht installiert. Auch nach mehreren Tagen und Wochen passiert nichts, wenn der User immer Abends den Rechner herunterfährt und am nächsten Morgen wieder startet. Macht der User aber einen Neustart an irgend einem Tag oder sobald das neue MSI-Paket hinterlegt wurde, werden beim Hochfahren sämtliche Gruppenrichtlinien gezogen und die gesamte hinterlegte Software installiert.

    An den Clients und GPOs haben wir schon wo es möglich war in den Netzwerkverbindungen eingestellt, das wir auf das Netzwerk warten. Es ist aber teilweise zu erkennen, das die LAN-Verbindung noch nicht aktiv ist, wenn die Anmeldemaske erscheint.

    Woran könnte dies liegen?

    Donnerstag, 12. Januar 2017 08:52

Antworten

  • Hallo,

    habt ihr mal den Windows 10 Schnellstart deaktiviert. Dann gibt es weniger Probleme mit den GPOs.

    Gruß Benjamin


    Benjamin Hoch
    MCSE: Data Platform & Data Management and Analytics
    MCSA: SQL Server 2012/2014 & 2016 DB Administration
    MCSA: Windows Server 2012

    • Als Antwort markiert agria Montag, 16. Januar 2017 07:31
    Donnerstag, 12. Januar 2017 09:06

Alle Antworten

  • Hallo,

    habt ihr mal den Windows 10 Schnellstart deaktiviert. Dann gibt es weniger Probleme mit den GPOs.

    Gruß Benjamin


    Benjamin Hoch
    MCSE: Data Platform & Data Management and Analytics
    MCSA: SQL Server 2012/2014 & 2016 DB Administration
    MCSA: Windows Server 2012

    • Als Antwort markiert agria Montag, 16. Januar 2017 07:31
    Donnerstag, 12. Januar 2017 09:06
  • Hallo agria,

    Es ist aber teilweise zu erkennen, das die LAN-Verbindung noch nicht aktiv ist, wenn die Anmeldemaske erscheint.

    Woran könnte dies liegen?

    das klingt doch schon genau nach der Beschreibung deines Problems:
    das Client-OS wartet mit dem Booten nicht auf das Netzwerk.

    Setz mal per GPO:

    Computerconfiguration -> Administrative Vorlagen -> System/Anmelden -> Richtlinie "Beim Neustart des Computers und bei der Anmeldung immer auf das Netzwerk warten"

    und

    Computerconfiguration -> Administrative Vorlagen -> System/Skripts -> Richtlinie "Anmeldeskripts gleichzeitig ausführen" Aktiviert


    Gruß TechnikSC885

    PS: und zusätzlich, wie von Benjamin vorgeschlagen - Schnellstart deaktivieren
    • Bearbeitet TechnikSC885 Donnerstag, 12. Januar 2017 09:18 PS:
    Donnerstag, 12. Januar 2017 09:14
  • Hi,
     
    Am 12.01.2017 um 09:52 schrieb agria:
    > [Windows 10] werden die Gruppenrichtlinien immer nur bei einem
    > Neustart des PCs gezogen.
     
    Ein kleine Erweiterung zu Benjamin und TechnikSC885.
     
    Ich selber bin bei dem Thema ein wenig vom Saulus zum Paulus
    konvertiert. Ich habe jahrelang die beiden genannten Richtlinien als
    unbedingt zwingend notwendig propagiert.
     
    Heute mache ich da ein klares Jein draus. :-)
     
    Die beiden Richtlinien werden nur benötigt, wenn Start/Anmelde Scripte
    zum Einsatz kommen. Hat man keine Scripte, dann braucht man sie nicht.
     
    Warum?
    Es gibt CSEs, die in der GPO nur im Vordergrund übergeben werden können,
    dazu gehören u.A. Skripte, FolderRedirection und Softwarenstallation als
    meistgenutzte.
     
    Skripte sind für MS immer eine Sonderlocke und verhalten sich anders als
    andere, aber Softwarezuweisung und FolderRedir sind 100% GP konform.
     
    Bei einem gpupdate oder normalen Hintergrund Prozess im laufenden
    Betrieb sagen die bei einer neuen Software zum Client:
    "Hey,  hier ist ein Job, der ist neu und der funktioniert nur im
    Vordergrund. Merk dir das!"
     
    Der Client wird nun für den nächsten Neustart, sein Startverhalten von
    asynchron (nicht auf Netzwerk warten) auf synchron (immer auf das
    Netzwerk warten) stellen, aber nur das eine Mal, wo es gebraucht wird.
    Danach ist der Schalter weg und der Start wieder asynchron und damit
    schneller.
     
    gleiches Verhalten kann man mit "gpupdate /sync" manuell auslösen.
     
    Das doofe ist: Fastboot ist kein Neustart :-( Da liegt der Hund begraben.
     
    MS präferiert Performance und sagt, es gibt sowieso kein JETZT im
    Netzwerk, also kann es ruhig eine Zeit X dauern, bis es geht.
     
    Die GPSI ist ziemlicher Mist und MS geht davon aus, daß jemand der
    enrsthaft Software verteilen möchte auch eine "richtige" Software dafür
    verwendet, statt der Richtlinien. Ich persönlich würde die
    Softwareverteilung umstellen auf WSUS mit WPP, dann kommt die Software
    auch im Hintergrund per BITS.
     
    Zu synchronem oder asynchronem Start habe ich zur Zeit keine feste
    Meinung. Ich mag schnellen Start, möchte aber auch ein verlässliches
    System. Ich erkaufe mir das eine mit Zeit und das andere mit
    Verlässlichkeit.
     
    Tschö
    Mark
     
    P.S.: Ich glaube, das ist mal wieder einen Artikel wert :-)
    --
    Mark Heitbrink - MVP Group Policy - Cloud and Datacenter Management
     
    Homepage:  http://www.gruppenrichtlinien.de - deutsch
     
    Donnerstag, 12. Januar 2017 10:28
  • > Bsp: Ich hinterlege ein neues MSI-Paket (Server 2008R2). Wenn der Nutzer nun seinen PC am Abend herunterfährt und am nächsten morgen wieder startet,
     
    Problem: Er fährt ihn gar nicht herunter. Er wird nur abgemeldet, und dann geht der PC in Hibernation... Schalte den Schnellstart ab :)
     
    Donnerstag, 12. Januar 2017 15:34
    Beantworter
  • Am 12.01.2017 schrieb agria:

    Bsp: Ich hinterlege ein neues MSI-Paket (Server 2008R2). Wenn der Nutzer nun seinen PC am Abend herunterfährt und am nächsten morgen wieder startet, wird das Paket nicht installiert. Auch nach mehreren Tagen und Wochen passiert

    WSUS und WPP wurden ja schon genannt. Hier findest Du mehr HowTos zu
    dem Thema: http://wsus.de/wpp + http://wsus.de/lup Der letzte Link
    zeigt nur weitere Vorgehensweisen, der LUP wird nicht
    weiterentwickelt, du solltest den WPP einsetzen.

    Servus
    Winfried


    WSUS Package Publisher: http://wsuspackagepublisher.codeplex.com/
    HowTos zum WSUS Package Publisher http://www.wsus.de/wpp
    GPO's: http://www.gruppenrichtlinien.de
    NNTP-Bridge für MS-Foren: http://communitybridge.codeplex.com/

    Freitag, 13. Januar 2017 05:49