none
Windows 2008 Terminal Server, Audio Ausgabe über RPD ist nicht allen Benutzern möglich RRS feed

  • Frage

  • Ich habe einen Windows 2008 TS, daruf u.a. Adobe Professional. Sound ist aktiviert. Die Remote-Anwendungen werden per MSI auf den Clients als Verknüpfung abgelegt.
    Allerdings kann nur ein einziges Benutzerkonto des Netzes, (zufällig?) das, welches beim Einrichten des Servers verwendet wurde, auch Adio höhren. Alle anderen Benutzer höhren nichts.

    An welcher Stelle kann ich hier suchen?
    Mittwoch, 5. August 2009 13:09

Antworten

  • Ah, ich habe weitere Tests unternommen.

    Bislang habe ich den WTS nur als Anwendungsserver über RDP verwendet. Die einzige Anwendung, die Audio verwendete, war die Vorleseversion von Adobe.

    Ich habe jetzt verschiedene Testkonten, die eine RDP Verbindung mit dem Desktop aufbauen. Siehe da, Windows 2008 liefert Sound. Starte ich dann Adobe Pro - nichts.

    Ich ziehe die Frage erst einmal wieder zurück, wahrscheinlich suche ich ander falschen Stelle, und in Wirklichkeit ist Adobe der Üble.

    Das Konto mit Adobe/Audio ist nicht lokaler Admin, war es aber zu dem Zeitpunkt der Installation.

    Donnerstag, 6. August 2009 13:31
  • Und genaus so ist es. VLC spielt jedem was vor.
    Blöd, dass ich zuerst mit dem Adobe testen wollte - der die Sprachausgabe einfach nur für eine Person startet.

    Danke allen Beteiligten für die Zeit und Interesse.
    • Als Antwort markiert Moo-Crumpus Montag, 10. August 2009 13:54
    Montag, 10. August 2009 13:54

Alle Antworten

  • dann klicke mit der rechten MT auf eine RDP Verknüpfung, gehe auf bearbeiten und schaue unter "Lokalen Ressourcen" was bei "Sounds auf dem Remotecomputer" eingestellt ist.
    Mittwoch, 5. August 2009 14:21
  • Die RDP-Verknüpfungen der Applikationen werden per Software-Verteilung bei Verwendung der MSI-Sourcen installiert, die ich auf WTS 2008 erzeugt habe, und sind alle identisch. Ich kann an eine beliebige Maschine gehen, dort die MSI-Installationan anstossen, und halte stets das gleiche Ergebnis. Benutzer A kann, alle anderen nicht.

    Der eine Benutzer bekommt die gleichen RDPs, wie alle anderen. In diesen RDPs gibt es Rechtsklick, Bearbeiten, aber dann nur Anmeldeeinstellungen, einzige Option "Immer Anmeldeinformationen anfordern".

    Für RemoteApps auf dem WTS habe ich die Benutzerdefinierte RDP-Einstellung audiomode:i:0 verwendet, denn Audio steht in Geräten / Ressourcen nicht zur Verfügung.
    Mittwoch, 5. August 2009 14:51
  • Also kann der Administrator Sound hören, der Rest jedoch nicht, oder wie? Du hast den Server ja sicherlich mit dem Admin Account eingerichtet,oder? Womöglich wird es dann durch eine GPO verhindert?

    Mittwoch, 5. August 2009 16:05
  • Test dochmal mit dem RDP-Client (6.1) gegen TSWeb, ob Du die gleichen Probleme hast.

    Hast Du evtl eine TS-Farm im Hintergrund ?
    Gruß Ralph Andreas Altermann
    Mittwoch, 5. August 2009 19:43
  • Ah, ich habe weitere Tests unternommen.

    Bislang habe ich den WTS nur als Anwendungsserver über RDP verwendet. Die einzige Anwendung, die Audio verwendete, war die Vorleseversion von Adobe.

    Ich habe jetzt verschiedene Testkonten, die eine RDP Verbindung mit dem Desktop aufbauen. Siehe da, Windows 2008 liefert Sound. Starte ich dann Adobe Pro - nichts.

    Ich ziehe die Frage erst einmal wieder zurück, wahrscheinlich suche ich ander falschen Stelle, und in Wirklichkeit ist Adobe der Üble.

    Das Konto mit Adobe/Audio ist nicht lokaler Admin, war es aber zu dem Zeitpunkt der Installation.

    Donnerstag, 6. August 2009 13:31
  • Hi Moo,

    kannst ja noch einen Gegentest machen in dem Du einen Medienplayer nimmst und daraus ein MSI/RDP-Paket schnürst.
    Mal sehen ob Dein Lieblingssong dann auch die User hören können.

    Gib uns alsbald mal ein Feedback 
    Gruß Ralph Andreas Altermann
    Donnerstag, 6. August 2009 16:42
  • Und genaus so ist es. VLC spielt jedem was vor.
    Blöd, dass ich zuerst mit dem Adobe testen wollte - der die Sprachausgabe einfach nur für eine Person startet.

    Danke allen Beteiligten für die Zeit und Interesse.
    • Als Antwort markiert Moo-Crumpus Montag, 10. August 2009 13:54
    Montag, 10. August 2009 13:54