none
Remote Desktop 2016 Server, Programmstart Installation eines anderen Programmes wird gestartet RRS feed

  • Frage

  • hallo zusammen,

    wenn ein neuer Benutzer auf unserem Server 2016 mit *.rdp app oder direkt (mstsc) ein Programm XYZ startet wird ein anderes Setup/Installation eines AutoCAD Viewers durchgeführt? Könnte das sein, weil beim Setup des Viewers vergessen wurde "change user /install" auszuführen? Oder liegt das an verdrehten *.dll Registrierungen


    Chris

    Dienstag, 19. Juni 2018 19:25

Antworten

  • [solved]

    ich möchte die Ursache und Teillösung für andere noch einmal festhalten.

    wir nutzen am Terminal Server eine zweite Platte für Applikationen. Per default ist bei einer neuen Platte die Gruppe User lesend aktiviert. Damit kein User auf andere Programme und Daten zugreifen kann haben wir "Users" entfernt.

    Da manche - nicht sauber programmierte - Programme gemeinsame Ressourcen zb. *.ocx, dlls nutzen und sich unter den Regkey Eintragungen InProcess machen wird beim starten einer Anwendung die auch diese gemeinsamen Ressourcen nutzen nachgesehen ob es zugriff auf diese Eintragungen gibt. Da die Anwendung X nicht auf Y zugriff hat passiert ein SelfRepair der Machine, was bei MSIs dazu führt das ein Install ausgeführt wird. Auf lokalen PCs merkt man diese Seiteneffekte kaum. Bei TS Server mit sauber Security kommt es zu diesem Fehlverhalten.

    Bei AutoCad View verhält es sich ähnlich. Hier wird noch bestimmten Ordnen im UserProfil gesucht und dann ein Install angestossen.

    Wir haben als Lösung "Everyone" List Folder and Subfolder auf alle Ordner auf D: ergänzt.


    Chris

    • Als Antwort markiert -- Chris -- Samstag, 23. Juni 2018 18:39
    Samstag, 23. Juni 2018 18:38

Alle Antworten

  • Moin,

    die Vermutung mit dem unterlassenen change user /install drängt sich schon extrem auf.


    Evgenij Smirnov

    I work @ msg services ag, Berlin -> http://www.msg-services.de
    I blog (in German) @ http://it-pro-berlin.de
    my stuff in PSGallery --> https://www.powershellgallery.com/profiles/it-pro-berlin.de/
    Exchange User Group, Berlin -> https://exusg.de
    Windows Server User Group, Berlin -> http://www.winsvr-berlin.de
    Mark Minasi Technical Forum, reloaded -> http://newforum.minasi.com


    In theory, there is no difference between theory and practice. In practice, there is.

    Dienstag, 19. Juni 2018 20:43
  • [solved]

    ich möchte die Ursache und Teillösung für andere noch einmal festhalten.

    wir nutzen am Terminal Server eine zweite Platte für Applikationen. Per default ist bei einer neuen Platte die Gruppe User lesend aktiviert. Damit kein User auf andere Programme und Daten zugreifen kann haben wir "Users" entfernt.

    Da manche - nicht sauber programmierte - Programme gemeinsame Ressourcen zb. *.ocx, dlls nutzen und sich unter den Regkey Eintragungen InProcess machen wird beim starten einer Anwendung die auch diese gemeinsamen Ressourcen nutzen nachgesehen ob es zugriff auf diese Eintragungen gibt. Da die Anwendung X nicht auf Y zugriff hat passiert ein SelfRepair der Machine, was bei MSIs dazu führt das ein Install ausgeführt wird. Auf lokalen PCs merkt man diese Seiteneffekte kaum. Bei TS Server mit sauber Security kommt es zu diesem Fehlverhalten.

    Bei AutoCad View verhält es sich ähnlich. Hier wird noch bestimmten Ordnen im UserProfil gesucht und dann ein Install angestossen.

    Wir haben als Lösung "Everyone" List Folder and Subfolder auf alle Ordner auf D: ergänzt.


    Chris

    • Als Antwort markiert -- Chris -- Samstag, 23. Juni 2018 18:39
    Samstag, 23. Juni 2018 18:38