none
Ordnerumleitung wieder rückgängig machen RRS feed

  • Frage

  • Hallo,
    ich habe "Eigene Dateien" auf ein Netzlaufwerk via GPO umgeleitet.
    Soweit so gut. Geht auch.
    In den Eigenschaften des Ordners "Eigene Dateien" sehe ich dann auch den Netzwerkpfad und wenn ich Dateien erstelle werden diese dort abgelegt.

    Jetzt würde ich das gerne bei einigen Usern rückgängig machen.
    Die "Eigene Dateien" sollen wieder in den Default Profilordner landen.
    Dazu habe ich in der GPO die Option "Ordner nach Entfernen der Richtlinie am neuen Ort belassen" ausgewählt und den Sicherheitsfilter der GPO entfernt.

    RSOP.msc bringt dann folgenden Fehler:

    Mittwoch, 25. April 2012 11:53:52

    Folder Redirection ist aufgrund des unten aufgeführten Fehlers fehlgeschlagen.

    Das System kann die angegebene Datei nicht finden.

    Zusätzliche Informationen:

    Die Umleitung des Ordners Eigene Dateien konnte nicht ausgeführt werden.

    Die Dateien für den umgeleiteten Ordner konnten nicht an den neuen Ort verschoben werden.

    Der Ordner soll konfigurationsgemäß nach <%USERPROFILE%\Eigene Dateien> umgeleitet werden. Dateien wurden von <\\IP\User\test\Eigene Dateien> nach <C:\Dokumente und Einstellungen\test.SSISHOP\Eigene Dateien> verschoben.

    Der folgende Fehler ist beim Kopieren von <\\IP\User\test\Eigene Dateien\haschke.txt> nach <C:\Dokumente und Einstellungen\test.SSISHOP\Eigene Dateien\haschke.txt> aufgetreten:

    Das System kann die angegebene Datei nicht finden.

    Auch wenn ich in der GPO "Ordner nach Entfernen der Richtlinie zurück an den Ort des lok. Benutzerprofils umleiten setzen" aktiviere kommt dieser Fehler.

    Das Symbol "Eigene Dateien" hat dann so zwei Sync Pfeile und der Pfad in den Eigenschaften steht immer noch auf dem Netzlaufwerk.
    Auch wenn ich Dateien dort speicher landen Sie auf dem Netzlaufwerk.

    Wie bekomme ich das so Rüchgängig gemacht, dass er wieder lokal unter Eigene Dateien speichert und auch nichts mehr Synct/Umleitet?

    Danke und Gruß
    Dennis



    • Bearbeitet HaschkeD Mittwoch, 25. April 2012 10:02
    Mittwoch, 25. April 2012 10:01

Antworten

  • Hi Dennis,

    so einfach ist das nat. nicht ;). Das was du versucht hast wäre das logischste, hat bei mir bis jetzt aber auch noch nie funktioniert.

    Du musst für die User eine neue GPO erstellen in der du die Ordner explizit, auch wieder per GPO, umleiten dann klappts. Wenn du nun sicher bist das es bei allen "zurück umgeleitet" wurde kannst du die GPO wieder löschen.

    • Als Antwort markiert HaschkeD Donnerstag, 26. April 2012 10:39
    Mittwoch, 25. April 2012 11:19
  • Hi,

    sieht fast so aus als wäre die Datei gelockt, grundsätzlich muss er ja was verschoben/ muss es funktioniert haben. Ist in den Eigenen Dateien nur 1 Datei drin?

    • Als Antwort markiert HaschkeD Donnerstag, 26. April 2012 10:39
    Donnerstag, 26. April 2012 10:29

Alle Antworten

  • Hi Dennis,

    so einfach ist das nat. nicht ;). Das was du versucht hast wäre das logischste, hat bei mir bis jetzt aber auch noch nie funktioniert.

    Du musst für die User eine neue GPO erstellen in der du die Ordner explizit, auch wieder per GPO, umleiten dann klappts. Wenn du nun sicher bist das es bei allen "zurück umgeleitet" wurde kannst du die GPO wieder löschen.

    • Als Antwort markiert HaschkeD Donnerstag, 26. April 2012 10:39
    Mittwoch, 25. April 2012 11:19
  • Habe das umgesetzt.
    Jetzt folgendes:

    Donnerstag, 26. April 2012 10:45:24

    Folder Redirection ist aufgrund des unten aufgeführten Fehlers fehlgeschlagen.

    Das System kann die angegebene Datei nicht finden.

    Zusätzliche Informationen:

    Die Umleitung des Ordners Eigene Dateien konnte nicht ausgeführt werden.

    Die Dateien für den umgeleiteten Ordner konnten nicht an den neuen Ort verschoben werden.

    Der Ordner soll konfigurationsgemäß nach <%USERPROFILE%\Eigene Dateien> umgeleitet werden. Dateien wurden von <\\10.25.217.2\User\Test\Eigene Dateien> nach <C:\Dokumente und Einstellungen\test.SSISHOP\Eigene Dateien> verschoben.

    Der folgende Fehler ist beim Kopieren von <\\10.25.217.2\User\Test\Eigene Dateien\cfvndhnbydfhb> nach <C:\Dokumente und Einstellungen\test.SSISHOP\Eigene Dateien\cfvndhnbydfhb> aufgetreten:

    Das System kann die angegebene Datei nicht finden.

    Donnerstag, 26. April 2012 08:50
  • Hi,

    sieht fast so aus als wäre die Datei gelockt, grundsätzlich muss er ja was verschoben/ muss es funktioniert haben. Ist in den Eigenen Dateien nur 1 Datei drin?

    • Als Antwort markiert HaschkeD Donnerstag, 26. April 2012 10:39
    Donnerstag, 26. April 2012 10:29
  • Habe jetzt mal auf dem Server den Ordner Eigene Dateien geleert.

    Dann neu angemeldet und jetzt hat er mir den Pfad von Eigene Dateien wieder auf den Default Pfad gesetzt.
    Scheint also wirklich was blockiert gewesen zu sein.

    Was ich dann nicht ganz verstehe.
    Welchen Sinn hat dann die Option?
    "Ordner nach Entfernen der Richtlinie zurück an den Ort des lok. Benutzerprofils umleiten setzen"
    "Ordner nach Entfernen der Richtlinie am neuen Ort belassen"  ???

    Ich habe jetzt nachdem der Pfad wieder auf Default steht die GPO entfernt bzw. den Benutzer aus dem Sicherheitsfilter genommen.
    Es kommt immer noch das:

    Donnerstag, 26. April 2012 13:42:15

    Folder Redirection ist aufgrund des unten aufgeführten Fehlers fehlgeschlagen.

    Der Verzeichnisname ist ungültig.

    Zusätzliche Informationen:

    Die Umleitung des Ordners Eigene Bilder konnte nicht durchgeführt werden.

    Konfigurationsgemäß wird der Ordner von <\\10.25.217.2\User\Test\Eigene Dateien\Eigene Bilder> nach <C:\Dokumente und Einstellungen\test.SSISHOP\Eigene Dateien\Eigene Bilder> umgeleitet.

    Der folgende Fehler ist aufgetreten:

    Der Verzeichnisname ist ungültig.


    Normal sollte doch jetzt gar nichts mehr erscheinen.
    • Bearbeitet HaschkeD Donnerstag, 26. April 2012 11:48
    Donnerstag, 26. April 2012 10:42
  • "Ordner nach Entfernen der Richtlinie zurück an den Ort des lok. Benutzerprofils umleiten setzen"
    "Ordner nach Entfernen der Richtlinie am neuen Ort belassen"  ???

    Keine Ahnung das wissen nur dir Programmierer, kann auch schlecht lokalsiert sein, wie gesagt, das hat bei mir noch nier hingehauen.

    Ich denke du hast nen Loop oder nen Denkfehler, Eigene Bilder wird ja immer automatisch erstellt, somit dann schon vorhanden und kann evtl. nicht überschrieben werden. Das is aber nur ne Vermutung. Ich prüf das heute abend mal ab.

    Donnerstag, 26. April 2012 12:53
  • OK.
    Kannst ja das Ergebnis deiner Prüfung berichten.
    Donnerstag, 26. April 2012 12:55
  • Am 25.04.2012 12:01, schrieb HaschkeD:
    > Dazu habe ich in der GPO die Option "Ordner nach Entfernen der
    > Richtlinie am neuen Ort belassen" ausgewählt und den Sicherheitsfilter
    > der GPO entfernt.
     
    Ja. Und jetzt macht der Client GENAU das, was du sagst. Du entfernst die
    GPO durch den Filter und die Dateien bleiben wo sie sind: Im Netzwerk.
    Also: Flasch Konfiguriert.
     
    -> "Ordner nach Entfernen der Richtlinie zurück an den Ort des lok.
    Benutzerprofils umleiten"
     
    Tschö
    Mark
    --
    Mark Heitbrink - MVP Windows Server - Group Policy
     
    Homepage:       www.gruppenrichtlinien.de - deutsch
    GPO Tool:       www.reg2xml.com - Registry Export File Converter
    NetworkTrayTool www.gruppenrichtlinien.de/tools/Networktraytool.htm
     
    Freitag, 27. April 2012 18:26
  • Ja. Wenn ich sage an dem Ort belassen ist das ja ok.

    Aber....... danach sollte rsop.msc doch nicht mehr immer wieder versuchen noch einen redirect zu machen, oder?

    Wenn ich sage "Ordner nach Entfernen der Richtlinie zurück an den Ort des lok. Benutzerprofils umleiten" dann sollte er mir das auch wieder in den Default Pfad leiten und die bestehden Dateien /Ordner dahin kopieren/verschieben. Versucht er ja auch. Aber in den Eigenschaften von "Eigenen Dateien" steht immer noch der Netzwerkpfad.
    dachte wenn ich diese Option setze ist alles wieder beim alten.


    • Bearbeitet HaschkeD Freitag, 27. April 2012 22:16
    Freitag, 27. April 2012 22:14
  • Am 28.04.2012 00:14, schrieb HaschkeD:
    > danach sollte rsop.msc doch nicht mehr immer wieder versuchen noch einen
    > redirect zu machen, oder?
     
    An welcher stelle hast du mit der Security Group gearbeitet:
    a) auf der GPO selbst
    oder
    b) innerhalb der CSE -> Umleitung nach Benutzergruppe?
     
    Mark
     
    --
    Mark Heitbrink - MVP Windows Server - Group Policy
     
    Homepage:       www.gruppenrichtlinien.de - deutsch
    GPO Tool:       www.reg2xml.com - Registry Export File Converter
    NetworkTrayTool www.gruppenrichtlinien.de/tools/Networktraytool.htm
     
    Sonntag, 29. April 2012 18:08
  • In der GPO selbst.
    Montag, 30. April 2012 08:25