none
Exchange 2010 SP3 U15 - externe OWA URL verrät die interne IP des Exchange Servers RRS feed

  • Frage

  • Hallo,

    ich habe ein Problem mit unserem OWA Zugriff. Und zwar wird nach dem Browseraufruf (von extern) unserer OWA URL (owa.externeadresse.de) die Adresse auf/in https://owa.externeadresse.de/owa/auth/logon.aspx?replaceCurrent=1&url=https%3a%2f%2f192.168.5.22%2fowa%2f

    umgeleitet/umgewandelt. Wie man aus dem Link ganz gut erkennen kann, wird die interne IP des Exchange-Servers dabei preisgegeben.

    Dieser Eintrag ist sicherheitsrelevant und sollte in der URL so nicht erscheinen.

    Was habe ich überprüft:

    - Die interne & externe URL sind je. passend gesetzt

    - Unter IIS ist keine Umleitung aktiv

    - inetpub\wwwroot\web.config enthält keine Umleitungen, lediglich einen customHeader

    - inetpub\wwwroot\iisstart.htm enthält eine Umleitung:

          <HEAD>
             <meta http-equiv="refresh" content="0; URL=https://owa.externeadresse.de/owa">
          </HEAD>

    Ideen, woran es liegen könnte?

    Beste Grüße

    Peter

    Freitag, 11. November 2016 12:25

Antworten

Alle Antworten

  • Moin,

    wie ist denn bei euch OWA nach extern veröffentlicht?


    Evgenij Smirnov

    I work @ msg services ag, Berlin -> http://www.msg-services.de
    I blog (in German) @ http://it-pro-berlin.de
    my stuff in PSGallery --> https://www.powershellgallery.com/profiles/it-pro-berlin.de/
    Exchange User Group, Berlin -> http://exusg.de
    Windows Server User Group, Berlin -> http://www.winsvr-berlin.de
    Mark Minasi Technical Forum, reloaded -> http://newforum.minasi.com

    Freitag, 11. November 2016 18:16
  • Guten Morgen Evgenij,

    unter owa (Default Web Site) ist die externe URL wie folgt gesetzt:

    https://owa.externeadresse.de/owa/

    Die interne:

    https ://servername-intern/

    Beim Provider ist ein DNS Eintrag auf unsere ext IP von "owa.externeadresse.de" mit einer Weiterleitung der Ports 443 & 80.

    Es geht zunächst über die Webserver-Protection (eine Art Webserver-Proxy) und wird auf die intern IP des Exchange-Servers umgeleitet.

    Der interne OWA-Eintrag beinhaltet nur den Hostnamen des Exchange-Servers, nicht die FQDN.

    Irgendetwas sagt mir, dass das Problem mit der Namensauflösung zu tun hat.

    Folgendes habe ich ausprobiert.

    ich habe die interne IP mit dem externen DNS Namen in der lokalen hosts-Datei (unter C:\windows\system32\drivers\etc\) zum testen wie folgt eingetragen:

    192.168.5.22  owa.externeadresse.de

    Das Ergebnis davon war:

    https ://owa.externeadresse.de/owa/auth/logon.aspx?replaceCurrent=1&url=https%3a%2f%2fowa.externeadresse.de%2fowa%2f

    D.h. die interne IP wurde durch den Namen aus der hosts-Datei ersetzt.

    Gruß

    Peter

    Montag, 14. November 2016 08:59
  • Moin,

    wenn in Deinem Reverse Proxy die Weiterleitung auf die IP des Exchange Servers gesetzt ist, dann kommt beim IIS ja auch ein Request mit dem Ziel <IP-Adresse> an. Und das baut OWA dann entsprechend in den URL ein.

    Du musst also am Proxy das Weiterleitungsziel so eintragen, dass es passt. Könnte lustig werden, je nachdem, was es für ein Proxy ist.


    Evgenij Smirnov

    I work @ msg services ag, Berlin -> http://www.msg-services.de
    I blog (in German) @ http://it-pro-berlin.de
    my stuff in PSGallery --> https://www.powershellgallery.com/profiles/it-pro-berlin.de/
    Exchange User Group, Berlin -> http://exusg.de
    Windows Server User Group, Berlin -> http://www.winsvr-berlin.de
    Mark Minasi Technical Forum, reloaded -> http://newforum.minasi.com

    Montag, 14. November 2016 10:05
  • Das war genau der richtige Tipp!

    Ich habe in der Reverse Proxy Konfiguration den Parameter "Host-Header durchreichen" aktiviert und siehe da, es funktioniert! Anstelle der internen IP wird jetzt erneut die externe URL angezeigt.

    Besten Dank! :-)

    Gruß

    Peter

    Montag, 14. November 2016 10:49