none
SharePoint 2013 Konfiguration bricht in Schritt 3 ab RRS feed

  • Frage

  • Guten Tag,

    die Konfiguration von SharePoint 2013 auf einer virtuellen Maschine mit Windows 2012 R2 bricht ständig im dritten Schritt ab. In der Ereignisanzeige findet man dann folgende Fehlermeldung:

    "
    Fehler beim Erstellen der Konfigurationsdatenbank.

    Eine Ausnahme vom Typ 'System.Runtime.InteropServices.COMException' wurde ausgelöst. Weitere Ausnahmeinformationen: Der Schlüsselsatz ist nicht vorhanden. (Ausnahme von HRESULT: 0x80090016)

    System.Runtime.InteropServices.COMException (0x80090016): Der Schlüsselsatz ist nicht vorhanden. (Ausnahme von HRESULT: 0x80090016)

       bei Microsoft.Web.Administration.Interop.AppHostWritableAdminManager.CommitChanges()

       bei Microsoft.Web.Administration.Configuration.CommitChanges()
       bei Microsoft.Web.Administration.ConfigurationManager.CommitChanges()
       bei Microsoft.Web.Administration.ServerManager.CommitChanges()
       bei Microsoft.SharePoint.Administration.SPIisServerManager.CommitChanges(ApplyChanges applyChanges)
       bei Microsoft.SharePoint.Administration.SPIisProvisioningAssistant.ProvisionApplicationPool(String name, SecurityIdentifier sid, String password, SPIisApplicationPoolSettings settings)
       bei Microsoft.SharePoint.Administration.SPIisManager.ProvisionApplicationPool(String name, SecurityIdentifier sid, SecureString password, SPIisApplicationPoolSettings settings)
       bei Microsoft.SharePoint.Administration.SPIisWebServiceApplicationPool.ProvisionLocal(SPIisWebServiceApplicationPoolProvisioningOptions options)
       bei Microsoft.SharePoint.Administration.SPIisWebServiceApplication.ProvisionApplicationInstance()
       bei Microsoft.SharePoint.Administration.Claims.SPSecurityTokenServiceApplication.ProvisionLocal(SPServiceInstance serviceInstance)
       bei Microsoft.SharePoint.Administration.SPIisWebServiceInstance.Provision()
       bei Microsoft.SharePoint.Administration.SPFarm.Join(Boolean skipRegisterAsDistributedCacheHost)
       bei Microsoft.SharePoint.PostSetupConfiguration.ConfigurationDatabaseTask.CreateOrConnectConfigDb()
       bei Microsoft.SharePoint.PostSetupConfiguration.ConfigurationDatabaseTask.Run()
       bei Microsoft.SharePoint.PostSetupConfiguration.TaskThread.ExecuteTask()
    "

    Kann mir da jemand weiterhelfen? Ich konnte im Internet leider nichts zu dieser Fehlermeldung im Zusammenhang mit SharePoint 2013 finden. Lassen Sie mich gerne wissen, falls Sie noch weitere Informationen benötigen sollten.

    Mit freundlichen Grüßen

    Mittwoch, 23. November 2016 09:05

Antworten

  • Hi Dirk,
    da das alles nichts zu bringen scheint, wiederhole ich in solchem Fall den gesamten Prozess:

    1. Deinstallation von SharePoint auf dem für SharePoint vorgesehenen Server.

    2. Installation der SharePoint Software mit einem Account, der lokaler Admin ist.

    3. Nach Updates suchen und diese installieren, ggf. mehrfach.

    4. Konto, mit welchem die SharePoint Konfiguration ausgeführt werden soll, der lokalen Admin-Gruppe hinzufügen und im SQL Server sysadmin-Rechte zuordnen.

    5. Wichtig: alle genutzten Konten (Installations-Konto, Farm-Konto) sollten einfache Domainkonten sein (keine lokalen Konten) und keine weiteren Rechte in der Domain haben (außer lokale Admins, kein Domain-Admin usw., lediglich Domain-User).


    --
    Viele Grüsse
    Peter Fleischer (MVP Reconnect, Partner)
    Meine Homepage mit Tipps und Tricks

    Donnerstag, 24. November 2016 07:11

Alle Antworten

  • Hi Dirk,
    ich gehe mal davon aus, dass Du eine neue Farm anlegen willst.

    Möglich wären fehlende Zugriffsrechte, s. dazu: Keyset does not exist” error while installing SharePoint.

    Hast Du mal überprüft, ob der Anwender, unter dessen Konto die Konfiguration ausgeführt wird, auch ausreichende Rechte auf dem SQL Server hat? Angeblich sollten createadmin reichen. Ich habe aber die Erfahrung gemacht, dass es damit Probleme gibt. Ich habe nicht detaillierter gesucht und habe dem Konto gleich sysadmin Rechte eingestellt.

    Außerdem kannst Du den IIS auf dem SharePoint Server prüfen. Ich schreibe dazu eine einfache html in das virtuelle Verzeichnis der Standard WebAnwendung und teste, ob sich diese Seite anzeigen lässt.


    --
    Viele Grüsse
    Peter Fleischer (MVP Reconnect, Partner)
    Meine Homepage mit Tipps und Tricks

    Mittwoch, 23. November 2016 09:19
  • Hallo Peter,

    danke für deine Antwort. Ich habe die Zugriffsrechte in dem angegeben Verzeichnis angepasst und habe dem Dienstkonto "sysadmin" Rechte in der Datenbank gegeben. Die Konfiguration ist dennoch am selben Problem erneut gescheitert.

    Ich kenne mich leider nicht sehr gut mit dem IIS aus, kannst du mir vielleicht genauer erklären wie du eine einfache html in ein virtuelles Verzeichnis schreibst?

    Gibt es vielleicht noch weitere Vorschläge, was gemacht werden kann um das Problem gelöst zu bekommen?

    Mittwoch, 23. November 2016 15:14
  • Hi Dirk,
    da das alles nichts zu bringen scheint, wiederhole ich in solchem Fall den gesamten Prozess:

    1. Deinstallation von SharePoint auf dem für SharePoint vorgesehenen Server.

    2. Installation der SharePoint Software mit einem Account, der lokaler Admin ist.

    3. Nach Updates suchen und diese installieren, ggf. mehrfach.

    4. Konto, mit welchem die SharePoint Konfiguration ausgeführt werden soll, der lokalen Admin-Gruppe hinzufügen und im SQL Server sysadmin-Rechte zuordnen.

    5. Wichtig: alle genutzten Konten (Installations-Konto, Farm-Konto) sollten einfache Domainkonten sein (keine lokalen Konten) und keine weiteren Rechte in der Domain haben (außer lokale Admins, kein Domain-Admin usw., lediglich Domain-User).


    --
    Viele Grüsse
    Peter Fleischer (MVP Reconnect, Partner)
    Meine Homepage mit Tipps und Tricks

    Donnerstag, 24. November 2016 07:11
  • Hallo Peter,

    wir haben die Installation noch mal komplett von Vorne begonnen, deine genannten Punkte befolgt und sichergestellt und alles hat einwandfrei funktioniert.

    Danke für deine Hilfe!

    Mit freundlichen Grüßen

    Mittwoch, 30. November 2016 12:01