none
Hyper-V startet nicht RRS feed

  • Frage

  • Hallo,

    ich habe auf einem HP DL 385 G5 mit zwei QuadCore Xeons den Win2k8 Server R2 installiert und versuche dort den Hyper-V zum Laufen zu kriegen.
    Die Rolle wurde problemlos installiert, ich kann auch eine VM mit StandardParametern anlegen, aber die läßt sich nicht starten.
    Es wird folgende Fehlermeldung ausgegeben:

    [Window Title]
    Hyper-V-Manager
    [Main Instruction]
    Fehler beim Versuch, die ausgewählten virtuellen Computer zu starten.
    [Content]
    "TestHv5": Fehler beim Initialisieren.
    Der virtuelle Computer konnte nicht gestartet werden, da der Hypervisor nicht ausgeführt wird.
    [Expanded Information]
    "TestHv5": Fehler beim Initialisieren (ID des virtuellen Computers: 2165305A-8C2C-4F3B-A506-BD0CA2CAF7ED).
    Der virtuelle Computer konnte nicht gestartet werden, da der Hypervisor nicht ausgeführt wird. Sie können das Problem möglicherweise mithilfe folgender Aktionen beheben:
    1) Stellen Sie sicher, dass die vom Prozessor des physischen Computers verwendete Version der hardwareunterstützten Virtualisierung unterstützt wird.
    2) Stellen Sie sicher, dass die hardwareunterstützte Virtualisierung und die hardwareunterstützte Datenausführungsverhinderung im BIOS des physischen Computers aktiviert sind. (Wenn Sie das BIOS bearbeiten, um eine der Einstellungen zu aktivieren, müssen Sie die Stromzufuhr zum physischen Computer ausschalten und dann wieder einschalten. Es reicht nicht aus, den physischen Computer zurückzusetzen.)
    3) Wenn Sie Änderungen am Startkonfigurationsdaten-Speicher vorgenommen haben, prüfen Sie diese Änderungen, um sicherzustellen, dass der Hypervisor für einen automatischen Start konfiguriert ist.

    Bei 1. bin ich absolut sicher dass es daran nicht liegt,
    bei 2. weiß ich, dass wir's im BIOS aktiviert haben
    und bei 3. verstehe ich absolut nicht, was da gemeint ist.

    Jedenfalls laufen die drei Hyper-V Dienste. Und als ich mal versuchte, die Hyper-V Rolle auf einer Maschine zu installieren, bei der der Prozessor keine Hardwarevirtualisierung beherrschte, schlug schon die Installation fehl.

    Für einen guten Tipp wäre ich wirklich sehr dankbar. Schon ein Hinweis darauf, wie man den Fehler weiter einkreisen könnte, wäre super.

    Gruß Alex

    Montag, 21. Juni 2010 14:43

Antworten

  • Hi,

    vielen Dank zunächst für die Vorschläge. Den Artikel von Viktor hatte ich bereits gefunden.

    Wirklich geholfen hat dann das hier :
    Hardware Data Execution Protection (DEP) must be available and be enabled in the BIOS.
    You must enable Intel XD bit (execute disable bit) or AMD NX bit (no execute bit).

    Gruß
    Alex

    • Als Antwort markiert webjagger Dienstag, 22. Juni 2010 07:00
    Dienstag, 22. Juni 2010 07:00
  • Hallo Alex, es gibt verschiedene Gründe, warum der Hyper-V Hypervisor in Windows 8 und 8.1 nicht ausgeführt wird (oder bei anderen der Windows Bootvorgang hängen bleibt/einfriert nachdem sie die "Hyper-V Plattform" in den Windows Komponenten nachinstalliert haben). DIe Lösungsansätze lauten

    - DEP aktivieren
    - USB 3.0 im Bios deaktivieren
    - Eingabeaufforderung mit Administratorrechten starten und "bcdedit /set hypervisorlaunchtype auto" eingeben
    - CPU Virtualisierungsoptionen im Bios aktivieren und anschließend einen echten Kaltstart durchführen
    - für AMD CPUs existiert auch ein Hotfix/Patch von Microsoft (http://support.microsoft.com/kb/2568088/de)
    - Systeme mit Bluetooth Adapter von Ralink (RT3290) werden von MS mit einem Virtualisierungs-inkompatiblen "Bluetooth Filter Driver" in Version 9.2.10.4 ausgeliefert (!); hier hilft ein Update auf Version 9.2.10.10 oder höher siehe http://h30434.www3.hp.com/t5/Desktop-Lockups-Freezes-Hangs/Cannot-boot-if-HP-ENVY-Bios-Virtualization-enabled-for-Win8/td-p/2006815/page/6

    Viel Glück und viel Spaß mit einer funktionierenden Virtualisierungsumgebung :)

    • Als Antwort vorgeschlagen julian.aberl Mittwoch, 21. Februar 2018 11:23
    • Als Antwort markiert webjagger Mittwoch, 21. Februar 2018 11:34
    Samstag, 26. Oktober 2013 12:10
  • Hi Webjagger,

    schaue ob etwas davon zutrifft.

    http://technet.microsoft.com/de-de/library/cc742454%28WS.10%29.aspx

     

    Gruß

    Viktor


    Wer aufgehört hat besser werden zu wollen, hat aufgehört gut zu sein...
    • Als Antwort markiert webjagger Dienstag, 22. Juni 2010 07:01
    Montag, 21. Juni 2010 17:06
  • Hi Alex,

    hast du das System mal komplett ausgeschaltet (power off für circa 10 sec)? Bei manchen Server (BIOS) Herstellern gibt hier Probleme mit dem aktivieren des hypervisors.

    Gruß

    Ramazan

    • Als Antwort markiert webjagger Dienstag, 22. Juni 2010 07:01
    Montag, 21. Juni 2010 19:01

Alle Antworten

  • Hi Webjagger,

    schaue ob etwas davon zutrifft.

    http://technet.microsoft.com/de-de/library/cc742454%28WS.10%29.aspx

     

    Gruß

    Viktor


    Wer aufgehört hat besser werden zu wollen, hat aufgehört gut zu sein...
    • Als Antwort markiert webjagger Dienstag, 22. Juni 2010 07:01
    Montag, 21. Juni 2010 17:06
  • Hi Alex,

    hast du das System mal komplett ausgeschaltet (power off für circa 10 sec)? Bei manchen Server (BIOS) Herstellern gibt hier Probleme mit dem aktivieren des hypervisors.

    Gruß

    Ramazan

    • Als Antwort markiert webjagger Dienstag, 22. Juni 2010 07:01
    Montag, 21. Juni 2010 19:01
  • Hi,

    vielen Dank zunächst für die Vorschläge. Den Artikel von Viktor hatte ich bereits gefunden.

    Wirklich geholfen hat dann das hier :
    Hardware Data Execution Protection (DEP) must be available and be enabled in the BIOS.
    You must enable Intel XD bit (execute disable bit) or AMD NX bit (no execute bit).

    Gruß
    Alex

    • Als Antwort markiert webjagger Dienstag, 22. Juni 2010 07:00
    Dienstag, 22. Juni 2010 07:00
  • Hallo Alex, es gibt verschiedene Gründe, warum der Hyper-V Hypervisor in Windows 8 und 8.1 nicht ausgeführt wird (oder bei anderen der Windows Bootvorgang hängen bleibt/einfriert nachdem sie die "Hyper-V Plattform" in den Windows Komponenten nachinstalliert haben). DIe Lösungsansätze lauten

    - DEP aktivieren
    - USB 3.0 im Bios deaktivieren
    - Eingabeaufforderung mit Administratorrechten starten und "bcdedit /set hypervisorlaunchtype auto" eingeben
    - CPU Virtualisierungsoptionen im Bios aktivieren und anschließend einen echten Kaltstart durchführen
    - für AMD CPUs existiert auch ein Hotfix/Patch von Microsoft (http://support.microsoft.com/kb/2568088/de)
    - Systeme mit Bluetooth Adapter von Ralink (RT3290) werden von MS mit einem Virtualisierungs-inkompatiblen "Bluetooth Filter Driver" in Version 9.2.10.4 ausgeliefert (!); hier hilft ein Update auf Version 9.2.10.10 oder höher siehe http://h30434.www3.hp.com/t5/Desktop-Lockups-Freezes-Hangs/Cannot-boot-if-HP-ENVY-Bios-Virtualization-enabled-for-Win8/td-p/2006815/page/6

    Viel Glück und viel Spaß mit einer funktionierenden Virtualisierungsumgebung :)

    • Als Antwort vorgeschlagen julian.aberl Mittwoch, 21. Februar 2018 11:23
    • Als Antwort markiert webjagger Mittwoch, 21. Februar 2018 11:34
    Samstag, 26. Oktober 2013 12:10