none
Progressbar weg in Excel 2003 nach Office 2010-Installation RRS feed

  • Frage

  • Hallo,

    seit ich parallel zu meinem vorhandenen Office 2003 BE die Office 2010 HaS installiert habe, funktioniert die Progressbar aus den zusätzlichen Steuerelementen in der Werkzeugsammlung nicht mehr. Weder in 2003, wo sie vorher einwandfrei funktioniert hat, noch in 2010. Woran kann das liegen?

    Ich verwende Windows 7 Pro 64-Bit.

    Gruß Herbert

    Montag, 5. Juli 2010 13:04

Antworten

  • Hallo Herbert Grom...

    ich habe bereits in einigen Installationen erlebt, dass die MSCOMCTL.OCX deregistriert wurde und nicht wieder registriert worden ist. Allerdings war's bei mir kein Windows 7 64 Bit, sondern 32 Bit. Deshalb bin ich mir nicht sicher, ob's bei Dir auch der Fall ist. Wenn die ProgressBar nicht funktioniert, könntest Du zum Testen mal eine ListView oder ein TreeView in einer Dummy UserForm nehmen. Die müssten dann auch nicht funktionieren. Für ein Windows 32 Bit System hatte ich dann (Admin Rechte) die Deregistrierung und Registrierung in einer Kommandozeile bzw. Ausführen-Fenster manuell vorgenommen...

    regsvr32 /u c:\windows\system32\mscomctl.ocx
    regsvr32 c:\windows\system32\mscomctl.ocx

    Ob sich das aber für ein 64 Bit System unterscheidet, kann ich jedoch nicht sagen. Und das Ganze natürlich jetzt ohne Gewähr.

    Gruß

    Mittwoch, 7. Juli 2010 09:49

Alle Antworten

  • Hallo Herbert Grom...

    ich habe bereits in einigen Installationen erlebt, dass die MSCOMCTL.OCX deregistriert wurde und nicht wieder registriert worden ist. Allerdings war's bei mir kein Windows 7 64 Bit, sondern 32 Bit. Deshalb bin ich mir nicht sicher, ob's bei Dir auch der Fall ist. Wenn die ProgressBar nicht funktioniert, könntest Du zum Testen mal eine ListView oder ein TreeView in einer Dummy UserForm nehmen. Die müssten dann auch nicht funktionieren. Für ein Windows 32 Bit System hatte ich dann (Admin Rechte) die Deregistrierung und Registrierung in einer Kommandozeile bzw. Ausführen-Fenster manuell vorgenommen...

    regsvr32 /u c:\windows\system32\mscomctl.ocx
    regsvr32 c:\windows\system32\mscomctl.ocx

    Ob sich das aber für ein 64 Bit System unterscheidet, kann ich jedoch nicht sagen. Und das Ganze natürlich jetzt ohne Gewähr.

    Gruß

    Mittwoch, 7. Juli 2010 09:49
  • Hallo,

    kann das Bestätigen,
    die manuelle Deregistrierung und Registrierung, wie von maninweb vorgenommen, hat auch bei mir funktioniert.

    Unter x64 liegt die mscomctl.ocx im Verzeichnis C:\Windows\SYSWOW64

    Gruß

    Freitag, 9. Juli 2010 13:07