none
Outlook 2010: mailto-Links führen zu ungültiger Adresse

    Frage

  • Hallo Leute,

    wenn ein Outlook 2010- Benutzer eine Mail weitergeleitet bekommt, dann sieht die Kopfzeile der Ursprungsmail in etwa folgendermaßen aus:

    From: forumsup@microsoft.com [mailto:forumsup@microsoft.com]
    Sent: Tuesday, August 09, 2011 12:33 PM

    Klick der Empfänger nun auf den mailto:-Link in der From-Zeile, öffnet sich ein neues Outlook Mailformular, das dann aber nicht erfolgreich verschickt werden kann. Im NDR findet man die Adresse dann folgendermaßen: 'forumsup@microsoft.com' Man beachte die ' ' - die sind nämlich die Ursache, dass die Mail nicht rausgeht.

    Kennt jemand das Verhalten, kann es nachstellen oder weiss eine Lösung dafür? Eine Lösung wäre natürlich, nicht auf den Mailto:-Link zu klicken - das verstehen die Benutzer aber nicht.....


    Viele Grüße Dirk
    • Typ geändert -Dirk- Mittwoch, 14. Dezember 2011 08:12 MS Bug
    Dienstag, 30. August 2011 14:19

Antworten

Alle Antworten

  • Hallo Dirk,

    ich habe keine Lösung, aber auch das Problem. Hast Du schon eine Lösung gefunden? Ich stelle fest, dass bei Outlook 2010 Nutzung
    über Terminal Server der Eintrag [mailto...] unverlinkt bleibt, während er beim lokal installierten Client vorhanden ist. Es müßte dann ja eine
    clientseitige Einstellung sein!?

     

    Gruß

    Stefan

    Mittwoch, 31. August 2011 10:23
  • keine Lösung / Idee im Augenblick. Mal sehen, ob jemand noch was weiss.
    Viele Grüße Dirk
    Mittwoch, 31. August 2011 12:10
  • Hallo Dirk,

    ich habe reproduzierbar das gleiche Problem.

    IMO tritt das aber erst seit dem SP1 von Office 2010 auf. Zumindest häufen sich seitdem die Tickets bei uns.

    @MVPs: Es wäre nett, wenn sich jemand dieses Problem ansehen kann

    Gruß Boris

    Montag, 12. September 2011 09:00
  • Ich habe festgestellt, dass Outlook die "Mail-to" Links ab und zu falsch behandelt und das senden einer Antwort behindert.

    Besorge Dir bitte einmal das Tool "nk2edit" und führe es auf deinem System aus nachdem Du Outlook beendet hast. Was Dir dann aufgelistet wird, sind die gecachten Informationen aus der Nk2-Datei von Outlook. Dieser Cache schlägt Dir auch bei der Eingabe von den ersten Buchstaben einer E-Mail Adresse in Outlook etwailige bekannte Adressen  vor (soweit Du schon mal die Adresse in Outlook eingegeben hattest).

    Nachdem Du nun das Tool ausgeführt hast, werden Dir alle bekannten E-Mail Adressen von Outlook angezeigt. Hier sollte nun auch die OMINÖSE E-Mail Adresse aufgelistet sein. Nun kannst Du diesen Eintrag bearbeiten und über "File" > "Save Current NK2 File" speichern. Sollte der Eintrag aber beim erneuten Aufruf von dem Tool unverändert sein, so hattest Du während des speichern noch ein Programm offen welches Mail-Funktionalitäten ausführt (dieses bitte schließen und nochmal von vorne).

    Du kannst auch ausprobieren den "Address Type" des betroffenen Eintrages in SMTP zu ändern.

     

    MfG Paul



    • Bearbeitet PabloX1978 Montag, 12. September 2011 14:46
    Montag, 12. September 2011 14:37
  • Hallo Paul,

    meiner Meinung nach hat das Ganze nichts mit den nk2-Adressen im Cache zu tun. Es tritt auch bei neuen Adressen, an die noch nie gesendet wurde, auf. Mehrere Benutzer isnd betroffen, jedoch immer nur bei click auf den mailto-Link.


    Viele Grüße Dirk
    Montag, 12. September 2011 14:46
  • Hallo Dirk,

    Doch im gewissen Maße hat es schon was mit dem Outlook Cache zu tun. Das problem ist das outlook bei mailto die Adresse falsch aufbaut.

    Outlook glaubt das mailto das Protokoll ist mit dem man versucht zu senden. Wenn also ein User auf einen mailtoLink geklickt hat dann speichert Outlook die Adresse falsch im Cache.

    Wenn Emailadressen (Die falsch im Cache liegen) richtig verwendet werden sollen dann geht das in der Form [smtp:user@exsample.de]

    Alternativ kann man in Outlook für bestimmte Adressen ein Protokoll zuweisen (bei  mail also smtp)

    Oder auch einfach den gesamten cache über oben genanntes tool abändern.

    Das alles ändert an der Ursache des Problems aber nichts. Ich bin mir fast sicher das irgendein Outlook Word oder Office update den Fehler verursacht. Wenn das so ist werde ich mich nochmal melden sobald ich herausgefunden habe welches.

     

     

     

     

    Dienstag, 20. September 2011 11:28
  • Hallo Zusammen,

    habe nochmal ein wenig nach Lösungen und ähnlichen Fällen gesucht. Dabei bin auf einen ewig langen Thread gestoßen bei dem das Problem erstmals in Outlook 2007 besprochen wird. Das ist schon eine Leidensgeschichte die die Leute da durchgehen.

    http://social.technet.microsoft.com/Forums/en-US/exchangesvradmin/thread/56b2d50d-6855-444b-abed-89aaa9176a9f/

    Nun ich würde euch empfehlen sich da mit zu unterhalten. Die letzten Einträge waren auch Sept. 2011

    Für Outlook 2007 ist ein Hotfix rausgekommen. Ansonsten sind da alle bekannten Workarounds gelistet. Für 2010 gibt es noch keine Richtige Lösung

     

    Dienstag, 20. September 2011 12:07
  • Hi "sniper369",

    danke für Deine Recherche.

    Dann müsste MS das ja auch bald auffallen und vielleicht bekommen wir dann einen Patch.


    Viele Grüße Dirk
    Dienstag, 20. September 2011 12:48
  • So,

    MSTF hat es bestätigt, eshandelt sich um einen Bug in Word 2010 als Email-Editor. Mit einem Hotfixist bis Ende des Jahres zu rechnen. Workarround: Nicht auf den mailto: -Link klicken - aber das wusste ich bisherauch schon ;-)

    Falls der Hotfix verfügbar ist und ich es zeitnah mitbekomme (leider gibt es noch kein "auto-hotfix-update" - wäre aber echt mal ne Idee für den WSUS), dann poste ich es hier.

     

    Ergänzung: es hat nichts mit nk2-Dateien zu tun, es ist ein Word-Bug!


    Viele Grüße Dirk
    • Bearbeitet -Dirk- Mittwoch, 12. Oktober 2011 08:10
    Mittwoch, 12. Oktober 2011 08:09
  • Am 12.10.2011 schrieb -Dirk-:

    Falls der Hotfix verfügbar ist und ich es zeitnah mitbekomme (leider gibt es noch kein "auto-hotfix-update" - wäre aber echt mal ne Idee für den WSUS), dann poste ich es hier.

    Du kannst ganz bestimmt den Hotfix automatisiert installieren. Ruf die
    Datei via Ausführen > Name_der_Datei.Endung /? auf. Evtl. kommst Du so
    an Parameter zur Silent Installation. Alternativ kannst Du auch fremde
    Updates über den Local Update Publisher dem WSUS anbieten. Nähere
    Infos gibts hier:
    http://www.wsus.de/cgi-bin/yabb/YaBB.pl?num=1264774783 Auf den letzten
    beiden Seiten sind die Infos zu finden.

    Servus
    Winfried


    Connect2WSUS: http://www.grurili.de/tools/Connect2WSUS.exe
    GPO's: http://www.gruppenrichtlinien.de
    Community Forums NNTP Bridge: http://communitybridge.codeplex.com/

    Mittwoch, 12. Oktober 2011 18:08
  • Hallo Zusammen,

    Also mir sind inzwischen viele Bugs in Outlook und office bekannt die auf den ersten Blick sehr gleich aussehen.

    Jetzt wüsste ich gerne von welchem im Detail wir hier sprechen. Wenn ihr auf einen Mailto Link klickt und dann mal den Curser über die Adresse

    im "An" Feld haltet geht ein kleines Menu auf. Einer der Buttons ist "weitere Optionen" wenn ihr das Dropdown Menu öffnet gibt es da "Outlook-Eigenschaften" Wenn ihr dort als "E-Mail-Typ" MAILTO stehen habt ist mir alles klar. Allerdings glaube ich kaum das dann ein hotfix für Word abhilfe verschaffen würde.

    Wenn nicht wäre ich dankbar wenn jemand mal eine NDR hier reinstellen kann.

     

    Grüße,

    sniper

    Donnerstag, 13. Oktober 2011 14:27
  • Also subjektiv gesehen nimmt diese Art von Fehler auch bei uns zu. Gerade erst heute hatte ein Kollege aus dem Support, dass sein Outlook diesen Fehler aufwies. Abhilfe konnte hier nochnicht mal das bearbeiten mit dem nk2editor schaffen. Die einzige Lösung war das leeren der "AutoVervollständigen-Liste" über Optionen > E-Mail.

    Langsam müsste  da mal MS in Zugzwang geraten denn dieser Fehler Behindert unseren Support und anderen Mitarbeiter (bei unseren Kunden) weil wir erst den Fehler immer manuell ausbügeln müssen, bevor wieder Mails erfolgreich versendet werden können.

     

    Mfg Pablo78


    • Bearbeitet PabloX1978 Freitag, 14. Oktober 2011 11:37
    Freitag, 14. Oktober 2011 11:37
  • Also mein Problem hier hat definitiv nichts mit nk2-Dateien zu tun.

    Leitet Euch mal eine von extern empfangene Mail an Euch selbst weiter. In dieser dann empfangenen Mail klickt Ihr auf den mailto:-link im Kopf der weitergleiteten Mail und senden diese neue Mail dann ab -> ergibt einen NDR wegen den ' ' in der Adresszeile, die Word als Editor falsch setzt; siehe auch Bild:

     

    Hier ein solcher NDR:

    Ihre Nachricht hat einige oder alle Empfänger nicht erreicht.

          Betreff:    test

          Gesendet am:      15.10.2011 11:30

    Folgende(r) Empfänger kann/können nicht erreicht werden:

          'a-dabrat@microsoft.com' am 15.10.2011 11:30

                Keines Ihrer E-Mail-Konten kann Nachrichten an diesen Empfänger senden.

    Viele Grüße Dirk

    • Bearbeitet -Dirk- Samstag, 15. Oktober 2011 09:32
    Samstag, 15. Oktober 2011 09:27
  • Hallo,

    Okay und wenn du jetzt so eine NDR bekommen hast und wieder versuchst an die Adresse zu schreiben (diesmal eingeben und nicht auf den link klicken) was passiert dann? geht es dann einfach oder wieder eine NDR?

    und was steht bei euch in diesem dialog?

    wenn ihr jetzt einmal auf einen falschen link geklickt habt und eine NDR bekommen habt und die Adresse manuel neu eingebt und die email eigenschaften öffnet dann steht da sehr wahrscheinlich Mailto. Und wenn das der fall ist hat euer Problem auch was mit Outlook cache zu tun. Denn der Uhrsprung liegt zwar im falsch aufgebauten mailto link aber der Falsche link wird von outlook gespeichert und wenn du den manuel eingibst korrigiert er automatisch auf den falschen.So wie Pablo es beschrieben hat.

    Und das ist es was ich meinte. Ein Hotfix für word würde zwar dafür sorgen das ihr in eurem Unternehmen solche Links mit Word nicht mehr Produziert. Aber es gibt auch automatische systeme die Fehlerhafte Links Produzieren oder ein anderes Unternehmen hat nicht alle updates aufgespielt oder verwendet gar kein msoffice etc.

     

    @ Pablo um nicht alle Autovervollständigungen zu löschen hättest du auch auf das im Bild Markierte X klicken können. Damit wäre nur der Fehlerhafte Eintrag gelöscht.

    Montag, 17. Oktober 2011 14:15
  • Du hast zu 100% recht mit dem, was Du schreibts. Als "nachgelagerter Fehler" kommen dann die nk2-Infos ins Spiel, so dass ein Patch zwar das ursprüngliche Editor-Problem beheben wird (hoffentlich), aber nicht die nk2-Einträge löscht.

    Prima.

     


    Viele Grüße Dirk
    Montag, 17. Oktober 2011 15:56
  • Folgende Info von MSFT:

    The hotfix for this issue is currently in testing, and will be a part of the Decemer 2011 Cumulative Update. The article Dirk referenced above is the correct article to watch for the earliest notice of the release of the hotfix. Once a KB article number is assigned to the CU, I will return here and post it for reference as well.

    Auf dieser Seite können die Hotfixe nachgeschaut werden:
    http://support.microsoft.com/kb/2625547

    Siehe auch
    http://social.technet.microsoft.com/Forums/en-US/exchangesvradmin/thread/56b2d50d-6855-444b-abed-89aaa9176a9f/


    Viele Grüße Dirk
    Mittwoch, 19. Oktober 2011 09:42
  • Am 19.10.2011 schrieb -Dirk-:

    Folgende Info von MSFT:

    Vielen Dank für die Info.
    Servus
    Winfried


    Connect2WSUS: http://www.grurili.de/tools/Connect2WSUS.exe
    GPO's: http://www.gruppenrichtlinien.de
    Community Forums NNTP Bridge: http://communitybridge.codeplex.com/

    Mittwoch, 19. Oktober 2011 18:36
  • Dieser Hotfix löst das Problem:

    http://support.microsoft.com/kb/2597052


    Viele Grüße Dirk
    • Bearbeitet -Dirk- Mittwoch, 14. Dezember 2011 08:11
    • Als Antwort markiert -Dirk- Mittwoch, 14. Dezember 2011 08:12
    Mittwoch, 14. Dezember 2011 08:11
  • Hi Dirk,

     

    the link shows a hotfix for Word 2010. This will correct this error for Outlook 2010?

     

    best regards borris


    Freitag, 30. Dezember 2011 12:02
  • Hi Boris,

    Yes, it will! Because Word is the email editor of outlook this will fix the outlook problem which is in fact a word problem :) MSFT support has confirmed in a call which I had opened that it is a Word problem, not an Outlook problem.

     

    Ja, da Word der E-Mail Editor von Outlook ist, löst der Fix das Outlook-Problem, das eigentlich ein Word-Problem ist. Der MSFT Support hat dies auch so in einem von mir geöffneten Call bestätigt.

     


    Viele Grüße Dirk
    Freitag, 30. Dezember 2011 17:25
  • Hallo,

    das Hotfix 2597052 ist bei uns installiert.

    Teilweise funktioniert auch die Umwandlung der MAILTO-Adressen korrekt, aber nicht bei allen.

    Die Autovervollständigen-Liste wurde geleert.


    Heute hat eine Kollegin eine weitergeleitete E-Mail erhalten, bei der trotz Hotfix das MAILTO-Problem immer noch besteht.

    ========================================

    In der Von-Zeile steht folgendes: [mailto:kontakt@domain.de]

    (diese E-Mail-Adresse funktioniert NICHT)


    In der Signatur steht die eMail-Adresse noch mal in der Form: kontakt@domain.de

    (diese E-Mail-Adresse funktioniert)

    ========================================

    Wenn man die E-Mail-Adresse herauskopiert erhält man folgendes:

    Aus der Von-Zeile:

    mailto:[mailto:kontakt@domain.de] -> Funktioniert NICHT

    Aus der Signatur:

    mailto:kontakt@domain.de -> Funktioniert

    Ich denke, dass die eckigen Klammern das Problem sein könnten.

    Gibt es dazu eine Lösung (weiteres Hotfix)?

    Oder hat jemand einen Tipp?

    Gruß

    Matthias


    Mittwoch, 4. Juli 2012 07:02
  • Ich habe das auch ab und an erlebt nach Aufspielen des Patches.

    Ich habe herausgefunden, dass der Benutzer zusätzlich zum Löschen der Autovervollständigungsliste auch noch alle vorhandenen Kontakte zu dieser Person aus allen Outlook-Adressbüchern löschen muss. Nach einem Outlook-Neustart tritt das Problem nun seit Wochen nicht mehr auf.

    Vielleicht kannst Du das verifizieren?


    Viele Grüße Dirk

    Mittwoch, 4. Juli 2012 07:06
  • Ich habe das auch ab und an erlebt nach Aufspielen des Patches.

    Ich habe herausgefunden, dass der Benutzer zusätzlich zum Löschen der Autovervollständigungsliste auch noch alle vorhandenen Kontakte zu dieser Person aus allen Outlook-Adressbüchern löschen muss. Nach einem Outlook-Neustart tritt das Problem nun seit Wochen nicht mehr auf.

    Vielleicht kannst Du das verifizieren?

    Hallo,

    danke für die Info.

    Ich habe das gerade geprüft.

    Aber die Problem-E-Mail-Adresse ist in keinem Kontakte-Ordner eingetragen, auch nicht im Ordner "Vorgeschlagene Kontakte".

    Hat noch jemand eine Idee?

    Gruß

    Matthias



    • Bearbeitet Ma Fi Donnerstag, 5. Juli 2012 06:18
    Donnerstag, 5. Juli 2012 06:16
  • Wenn es  nur um einzelne Emails geht machen wir immer folgendes:

    Neue Email schreiben.
    Besagte Email eintippen.
    Sobald die Email komplett erscheint, mit der Maustaste über dieselbe fahren.
    Es erscheint ein Fenster mit dem entsprechenden Kontakt.
    Dort gibt es rechts neben dem Telefon eine Symbol für ein Menü (Weitere Optionen).
    Das Symbol anklicken und im Menü „Outlook Eigenschaften“ auswählen.
    Es erschein ein kleines Fenster „E-Mail Eigenschaften“ wo es nur einen Knopf gibt: Internettyp
    Diesen klicken. Rechts bei E-Mail-Typ steht jetzt SMTP und es ist grau hinterlegt.
    Jetzt auf OK.

    Hat bisher geholfen, aber es nervt gewaltig. Eine endgültige Lösung wäre mir auch recht.
    Gruß
    Gonzalo

    Montag, 23. Juli 2012 15:16
  • Hallo,

    sorry, dass ich dieses Thema noch einmal hervor hole, aber ich habe ein kleines Problem mit dem Hotfix.

    Wir würden den Hotfix gerne über WSUS verteilen. Ein Hotfix über WSUS zu verteilen ist generell nicht möglich. Ich habe nur ein Update-Paket gefunden, welches diesen Hotfix enthält (KB2639884). Dieses Update finde ich jedoch nicht im Update-Katalog.

    Weiß jemand, in welchem Update-Paket dieser Hotfix enthalten ist?

    Vielen Dank!

    Viele Grüße, Arne

    Mittwoch, 24. Oktober 2012 09:34
  • Am 24.10.2012 schrieb Hoffman Eitle:

    Wir würden den Hotfix gerne über WSUS verteilen. Ein Hotfix über WSUS zu verteilen ist generell nicht möglich. Ich habe nur ein Update-Paket gefunden, welches diesen Hotfix enthält (KB2639884). Dieses Update finde ich jedoch nicht im Update-Katalog.

    Du kannst den Hotfix mit Hilfe des Local Update Publisher über den
    WSUS zur Verfügung stellen. http://localupdatepubl.sourceforge.net/
    http://infrablog.escde.net/2011/03/18/deployment-von-msp-updates-uber-wsus-teil-1-konfiguration/

    Servus
    Winfried


    Connect2WSUS: http://www.grurili.de/tools/Connect2WSUS.exe
    GPO's: http://www.gruppenrichtlinien.de
    Community Forums NNTP Bridge: http://communitybridge.codeplex.com/

    • Als Antwort vorgeschlagen Hoffman Eitle Donnerstag, 25. Oktober 2012 07:13
    • Nicht als Antwort vorgeschlagen Hoffman Eitle Donnerstag, 25. Oktober 2012 07:14
    • Als Antwort vorgeschlagen Hoffman Eitle Donnerstag, 25. Oktober 2012 07:14
    Mittwoch, 24. Oktober 2012 14:26
  • Hallo Winfried,

    Das hört sich echt interessant an. Wir werden den Hotfix nun erst einmal mit einigen Clients testen und dann wohl auf diesem Wege verteilen!

    vielen Dank!

    Viele Grüße, Arne

    Donnerstag, 25. Oktober 2012 07:13
  • Am 25.10.2012 schrieb Hoffman Eitle:

    Das hört sich echt interessant an. Wir werden den Hotfix nun erst einmal mit einigen Clients testen und dann wohl auf diesem Wege verteilen!

    Alternativ kannst Du den Hotfix auch mit Hilfe eines
    Computerstartupscriptes verteilen bzw. installieren lassen.

    vielen Dank!

    Bitte, gern geschehen. ;)

    Servus
    Winfried


    Connect2WSUS: http://www.grurili.de/tools/Connect2WSUS.exe
    GPO's: http://www.gruppenrichtlinien.de
    Community Forums NNTP Bridge: http://communitybridge.codeplex.com/

    Donnerstag, 25. Oktober 2012 16:58