none
XCOPY extrem langsam seit kurzer Zeit... RRS feed

  • Frage

  • Hallo!

    Seit einigen Wochen ist auf einem unserer Server (Windows 2008) ein kleiner Backup-Job *extrem* langsam geworden, so dass er faktisch kaum noch nutzbar ist.

    Der Backupjob kopiert wenige MB Daten von einer lokalen Platte ins Netz. Der Zielserver hat genug "Dampf".

    Die kopierten Dateien sind klein (wenige kB) und befinden sich auf einer (via Storage-System angebundenen) Disk, die vernünftige Performance leistet.

    Die Disk ist mit vielen Millionen Dateien gefüllt. Laut ntfsinfo gibt es wohl noch kein Problem mit der Anzahl der Files bzw. der Größe der MFT:

    C:\>ntfsinfo d:
    
    NtfsInfo v1.2 - NTFS Information Dump
    Copyright (C) 2005-2016 Mark Russinovich
    Sysinternals - www.sysinternals.com
    
    
    Volume Size
    -----------
    Volume size            : 1945598 MB
    Total sectors          : 3984585821
    Total clusters         : 498073227
    Free clusters          : 303981724
    Free space             : 1187428 MB (61% of drive)
    
    Allocation Size
    ----------------
    Bytes per sector       : 512
    Bytes per cluster      : 4096
    Bytes per MFT record   : 0
    Clusters per MFT record: 0
    
    MFT Information
    ---------------
    MFT size               : 9862 MB (0% of drive)
    MFT start cluster      : 786432
    MFT zone clusters      : 288323040 - 288344256
    MFT zone size          : 82 MB (0% of drive)
    MFT mirror start       : 249036613
    
    Meta-Data files
    ---------------
    
    Wenn man im Ressourcenmonitor die Antwortszeit in der rechten Spalte ansieht, dann sieht man das Problem:


    Die Probleme gibt es aber nicht nur beim XCOPY, sondern auch bei ROBOCOPY oder FASTCOPY und sogar auch bei einem einfachen "dir /s" in einem Ordner mit ca. 15.000 Dateien.

    Andere Dienste auf dem Server laufen ohne Probleme....es wird auch laut Storage-System mit ca. 50MB/s von der Disk gelesen - und der dafür zuständige Task läuft auch sauber...und dort sind die Antwortzeiten im RM bei wenigen ms.

    Das krasse ist, dass diese Probleme nicht so schlimm sind, wenn ich den Backup-Job manuell in der Eingabeaufforderung aufrufe. Extrem langsam ist er nur, wenn er über die Aufgabenplanung gestartet wird. Aber auch der lokale Explorer braucht tlw. >10 Sekunden, um in ein Verzeichnis zu wechseln und die Inhalte (ca. 10-15.000 Dateien) anzuzeigen. Ein Virenscanner ist nicht installiert.

    In der Ereignisanzeige ist nichts zu finden, was auf ein Problem hindeutet, Neustart des Servers bringt keine Besserung.

    Das ist ein total schwer zu greifendes Problem, bei dem man auch mit einer Google-Suche nur unsinnige Treffer findet.

    Von daher kann ich nur hoffen, dass jmd. einen goldenen Hinweis für mich hat, wie ich das Problem identifizieren und abstellen kann.

    Danke!

    Ove

    Freitag, 3. Februar 2017 09:57

Antworten

Alle Antworten

  • > Die Disk ist mit vielen Millionen Dateien gefüllt. Laut ntfsinfo gibt es wohl noch kein Problem mit der Anzahl der Files bzw. der Größe der MFT:
     
    Soso - woraus schließt Du denn "kein Problem"? Eine MFT von 10 GB finde ich nicht wirklich "kein Problem" :-)
     
    > Wenn man im Ressourcenmonitor die Antwortszeit in der rechten Spalte ansieht, dann sieht man das Problem:
     
    Seitenfehler haben ja nichts mit Platten zu tun, sondern mit Hauptspeicher... Wie viel RAM hat der Server drinne? Und wie sieht es denn so mit Fragmentierung aus? (defrag d: /a /v)
     
    Freitag, 3. Februar 2017 10:31
  • > Soso - woraus schließt Du denn "kein Problem"? Eine MFT von 10 GB finde ich nicht wirklich "kein Problem" :-)

    Habe das nur auf den genutzten Platz pro HDD (12.5%) bezogen... 

    >Seitenfehler haben ja nichts mit Platten zu tun, sondern mit Hauptspeicher... Wie viel RAM hat der Server drinne? Und wie sieht es denn so mit Fragmentierung aus? (defrag d: /a /v)

    4GB weil 32bit.

    Defrag läuft noch, wird aber wohl dauern wg. dieser Probleme..



     

    Mag gut sein, dass es mittlerweile einfach zu viele Files für die "Menge" an RAM sind...

    Freitag, 3. Februar 2017 11:08
  • >     4GB weil 32bit.
     
    Ojeh... Da geht Dir ziemlich sicher auch der Nonpaged Pool Speicher aus. Dauerhaft hilft da nur "Migrieren auf 64 Bit" und mehr RAM.
     
    Freitag, 3. Februar 2017 13:04
  • ja - das glaube ich auch...

    Danke für Deine Antworten!

    Gruß Ove

    Freitag, 3. Februar 2017 13:44