none
Autodiscover Exchange 2010/2013 Ko-Existenz RRS feed

  • Frage

  • Hallo zusammen,

    ich habe gerade ein sehr merkwürdiges Problem mit Autodiscover. Folgende Ausgangslage, Exchange 2010 veröffentlicht über Loadbalancer, per set-clientaccessserver -AutodiscoverInternaluri ..  die URL gesetzt. Wenn ich die URL im Browser aufrufe bekomme ich den ganz normalen 600er Error. 

    Exchange 2013 installiert, auch hier die URL per set-clientaccessserver gesetzt. Rufe ich dir URL auf, bekomme ich aber einen Http Error 500. Verschiebe ich den User auf den Exchange 2013, dann bekomme ich den erwarteten 600er Error.

    Ganz verrückt wird es, wenn ich den User wieder zurück auf die 2010er Umgebung verschiebe und mich einfach mal testweise gegen die Backend Webseite (also Port 444) verbinde, dann sieht der Autodiscover Request auch wieder in Ordnung aus. Also scheint doch irgendwie das "Proxying" nicht sauber zu funktionieren. 

    Wenn man mit Fiddler / Browser Debug Tools besteht eine Auffälligkeit im Header:

    1. Response Headersview source
    1. Cache-Control:
      private
    2. Content-Length:
      0
    3. Date:
      Fri, 17 Oct 2014 18:36:18 GMT
    4. Expires:
      Thu, 01 Dec 1994 16:00:00 GMT
    5. request-id:
      2f132900-a691-476f-b2bb-f39cbbaabc2f
    6. Server:
      Microsoft-IIS/8.5
    7. X-AspNet-Version:
      4.0.30319
    8. X-CasErrorCode:
      ServerNotFound
    9. X-FEServer: Servername...
    10. X-Powered-By:
      ASP.NET

    Bei einem funktionierenden Versuch sieht der Header folgendermaßen aus:

    1. Response Headersview source
      1. Cache-Control:
        private
      2. Content-Encoding:
        gzip
      3. Content-Length:
        351
      4. Content-Type:
        text/xml; charset=utf-8
      5. Date:
        Fri, 17 Oct 2014 19:07:25 GMT
      6. Expires:
        Thu, 01 Dec 1994 16:00:00 GMT
      7. request-id:
        2948def0-9a3b-4982-8d8b-c80ce8fb5121
      8. Server:
        Microsoft-IIS/8.5
      9. Set-Cookie:
        X-BackEndCookie=S-1-5-21-3584557775-756802339-790836741-12251=u56Lnp2ejJqBzpnOzpzHmZ3Syp3Hx9LLnJqb0sfImsbSnJ7ImcabyMzHnpnNgYHNz87L0s7O0s7Jq87Gxc/Ixc3K; expires=Sun, 16-Nov-2014 18:07:25 GMT; path=/autodiscover; secure; HttpOnly
      10. Vary:
        Accept-Encoding
      11. X-AspNet-Version:
        4.0.30319
      12. X-BEServer:
        servername
      13. X-CalculatedBETarget:
        fqdn
      14. X-DiagInfo:
        servername
      15. X-FEServer:
        servername
      16. X-OAuth-Enabled:
        False
      17. X-Powered-By:
        ASP.NET
      18. X-SOAP-Enabled:
        True
      19. X-WSSecurity-Enabled:
        True
      20. X-WSSecurity-For:
        None

    Irgendwelche Ideen?

    Grüße

    Jörg 

    Freitag, 17. Oktober 2014 19:12

Antworten

  • Moinsen,

    habe den Fehler selber gefunden. Es war ein falscher HTTP Redirect im Virtual Directory konfiguriert.

    Grüße

    Jörg

    Montag, 20. Oktober 2014 07:25

Alle Antworten

  • Moinsen,

    habe den Fehler selber gefunden. Es war ein falscher HTTP Redirect im Virtual Directory konfiguriert.

    Grüße

    Jörg

    Montag, 20. Oktober 2014 07:25
  • Hi Jörg,

    Moinsen,

    habe den Fehler selber gefunden. Es war ein falscher HTTP Redirect im Virtual Directory konfiguriert.

    Schön und danke für die Rückmeldung!


    Viele Grüße
    Christian

    Dienstag, 21. Oktober 2014 05:21
    Moderator