none
GPO Softwareinstallation wird nicht immer ausgeführt RRS feed

  • Allgemeine Diskussion

  • Hallo Leute,

    ich weise per GPO einige Softwareinstallationen zu, wie z. Bsp. Acrobat Reader, Flash und Java.

    Bei einigen XP-Clients erhalte ich die Fehlermeldung:

    "Die Zuweisung der Anwendung Java(TM) 6 Update 26 der Richtlinie Softwareinstallationen32bit ist fehlgeschlagen. Fehler: Das System kann die angegebene Datei nicht finden. "

    Andere Clients können diese GPO problemlos anziehen, somit stimmt der Pfad. Manche Clients ziehen sie nach 3-4 Neustartes an, andere erst nach 10x.
    "Immer auf das Netzwerk warten" ist aktiviert.

    Was könnte die Ursache sein?


    Viele Grüße Dirk
    Montag, 20. Juni 2011 13:21

Alle Antworten

  • Hallo,

    wo liegt die betreffende Datei?
    Liegt diese auf dem sysvol oder auf einem anderen Share?

    Sollte die Datei auf dem Sysvol liegen, ist dieses korrekt an allen DCs repliziert?

     

    Du kannst auch mittels Process Monitor einen Filter auf diese Datei setzen.
    (mittels Boot Loggin kannst du dann Mitschneiden, ob und warum nicht auf die Datei zugegriffen worden konnte)


    Montag, 20. Juni 2011 15:10
    Beantworter
  • Am 20.06.2011 schrieb -Dirk-:

    "Die Zuweisung der Anwendung Java(TM) 6 Update 26 der Richtlinie Softwareinstallationen32bit ist fehlgeschlagen. Fehler: Das System kann die angegebene Datei nicht finden. "

    Andere Clients können diese GPO problemlos anziehen, somit stimmt der Pfad. Manche Clients ziehen sie nach 3-4 Neustartes an, andere erst nach 10x.
    "Immer auf das Netzwerk warten" ist aktiviert.

    Und was ist mit der zweiten Einstellung aus der GPO-FAQ No. 36?
    http://www.gruppenrichtlinien.de/Grundlagen/faq.htm Ist die auch
    gesetzt? Kommen die Einstellungen am Client an? RSOP.MSC hilft dabei.

    Servus
    Winfried


    Connect2WSUS: http://www.grurili.de/tools/Connect2WSUS.exe
    GPO's: http://www.gruppenrichtlinien.de
    Community Forums NNTP Bridge: http://communitybridge.codeplex.com/
    Reg2xml:  http://www.reg2xml.com - Registry Export File Converter

    Montag, 20. Juni 2011 16:41
  • Um die korrekten Hinweise von Winfried zu ergänzen: Ich tippe schwer darauf, dass das MSI-Quellpaket entweder im Sysvol/Netlogon oder auf DFS liegt und dass Du ein Replikationsproblem hast. Das würde auch erklären, warum es irgendwann mal geht - der ausgewählte Domaincontroller (wenn es intrasite mehrere davon gibt) ist mehr oder weniger zufällig.

    Prüf mal die FRS-Logs Deiner DCs...

    mfg Martin


    Kein MVP, kein MCSE. Nur ein wenig Erfahrung.
    Montag, 20. Juni 2011 17:32
    Beantworter
  • Hallo zusammen,

     

    @Matthias: Die msi's liegen auf einem Share auf einen DC im LAN des Standorts, nicht im Sysvol/Netlogon.

    @Winfried: der 2. Punkt in FAQ 36 ist ebenfalls aktiviert. Die Einstellungen kommen am Clinet an, denn zum Einen befinden sich mehrere Softwareinstallationen in einer Richtlinie und manchmal wird nur eine von 4 installiert, die anderen nicht, manchmal 2, oder alle. Wenn nicht installiert wurde, sehe ich immer einen Fehelreintrag im Eventlog, also wurde die Richtlinie an sich gezogen.

    @Martin: liegt weder im Sysvol noch auf einem DFS. Ein ganz normaler Share mit "Jeder"->"Lesen" imLAN des Standorts.

    Ich habe noch eine Handvoll weitere Richtlinien, die eine andere Software installiert (eine Zuweisung pro Richtlinie) . Auch dort sehe ich, dass diese Richtlinie machnmal erst beim 2. Start funktioniert.

     

     


    Viele Grüße Dirk
    Dienstag, 21. Juni 2011 06:52
  • Konntest du den Hinweis mit Procmon weiter verfolgen?

    Prüfe bitte einmal mit GPLogView welche Fehler auftauchen:

    http://www.microsoft.com/download/en/details.aspx?id=11147

     

    Wenn du gar nicht weiter kommst, schau dir bitte addiag an:

    http://technet.microsoft.com/de-de/library/cc783993(WS.10).aspx

     

    Hiermit kannst du einige Optionen aktivieren (appmgmt.log, allerdings bin ich mir nicht sicher, ob dieses Tool ab Vista noch supportet wird)


    Dienstag, 21. Juni 2011 16:41
    Beantworter
  • Hatte leider keine Zeit heute und werde erst kommende Woche weiter schauen können.
    Viele Grüße Dirk
    Dienstag, 21. Juni 2011 16:59
  • Und, wie ist der Stand? ;)

     

    bye

    Norbert

    Dienstag, 26. Juli 2011 16:20
    Moderator