none
Exchange 2010 öffentliche Ordner - Inhalt leert sich immer wieder (Ordnerstruktur bleibt erhalten) Hilfe!!! RRS feed

  • Frage

  • Hallo zusammen.

    Habe ein Problem mit dem öffentlichen Ordnern.

    Die Inhalte werden immer wieder gelöscht! Die Ordner beleiben erhalten, jedoch der Inhalt verschwindert immer wieder. Es sind sehr, sehr viele mit Unterordner. Kann also nicht sein, das ein User mit STRG+A alles rauslöscht. Zudem habe ich die Rechte auf nicht löschen gesetzt. Verfallszeiten der Datenbank sind ebenfalls auf NUll Tage gesetzt. Ich weiss mir da keiner Rat mehr.

    Wehr weiß BEscheid bzw. hat da eine Idee.

    Gruß Wolle39


    Wolle39

    Montag, 27. August 2012 12:05

Antworten

  • Hi Wolle39,

    ist das ein spezieller User oder gibst du das Recht über ein Gruppe?
    Exchange cached Rechte für bis zu zwei Stunden - hattest du ausreichend gewartet?
    !!! 2h Exchange cache !!!
    Änderungen im Active Directory wie SendAs oder FullMailboxAddress müssen
    erst im AD repliziert werden und dann von Exchange neu eingelesen werden. Per Default puffert Exchange frühere Antworten aber für bis zu 2 Stunden. Dies kann durch den Wert von "Mailbox cache Age Limit" (siehe KB 326252 Exchange 2000 mailbox size limits are not enforced in a reasonable period of time; fix requires Exchange 2000 SP2" verändert werden.
    Exchange 2003: http://support.microsoft.com/kb/326252
    Exchange 2007: http://technet.microsoft.com/en-us/library/bb684892.aspx

    Es sollte definitiv ohne Standard klappen...


    Viele Grüße
    Christian

    Dienstag, 28. August 2012 07:25
    Moderator

Alle Antworten

  • Hi Wolle39,

    kannst du mal get-publicfolderdatabase|fl name, ItemRetentionPeriod
    posten...

    Steht er bei 0 oder ist er nicht gesetzt?


    Viele Grüße
    Christian

    Montag, 27. August 2012 12:30
    Moderator
  • Hallo Christian. Danke schon einmal für die schnelle Antwort.

    Bekam folgendes Ergebnis:

    ItemRetentionPeriod: unlimited

    Verfallszeit der Datenbank ist kein Hacken gesetzt!


    Wolle39


    • Bearbeitet Wolle39 Montag, 27. August 2012 12:40
    Montag, 27. August 2012 12:36
  • Hi Wolle39,

    ist SP2RU4 installiert und hattest du den Store neu gestartet?


    Viele Grüße
    Christian

    Montag, 27. August 2012 12:44
    Moderator
  • Den SP2RU4 habe ich heut schon mal geladen. Wollte ich heute Abend installieren.
    Warhscheinlich muss ich da ja auch den Server neustarten. Deswegen habe ich damit noch gewartet.

    Kennst Du ein solches Problem?


    Wolle39

    Montag, 27. August 2012 12:46
  • Hey Christian,

    AgeLimit paßt. Ich werde den Befehl setzen:


    Get-PublicFolder -Identity "\Öffentliche E-Mails\Kunden 2010" -Recurse | Set-PublicFolder -UseDatabaseAgeDefaults $true -UseDatabaseRetentionDefaults $true -Server "SERVER"

    Und heute Abend das SP2RU4 installieren.

    Eigentlich geht es doch darum, die Rechte komplett frisch zu setzen (keiner darf etwas löschen).

    Oder welchen Befehl würdest du mir empfehlen.
    Die öffentliche Datenbank heißt bei mir DB_Tourismus-AI und der Exchange Server08.

    Was hälst Du davon?


    Wolle39


    • Bearbeitet Wolle39 Montag, 27. August 2012 13:20
    Montag, 27. August 2012 13:13
  • Hi Wolle39,

    AgeLimit paßt. Ich werde den Befehl setzen:

    Get-PublicFolder -Identity "\Öffentliche E-Mails\Kunden 2010" -Recurse | Set-PublicFolder -UseDatabaseAgeDefaults $true -UseDatabaseRetentionDefaults $true -Server "SERVER"

    Und heute Abend das SP2RU4 installieren.

    Was hälst Du davon?

    Sieht gut aus...


    Viele Grüße
    Christian

    Montag, 27. August 2012 15:21
    Moderator
  • Guten Morgen Christian.

    SP2RU4 ist drauf und den Befehl gesetzt.

    Werde ich jetzt einmal beobachten ...

    Etwas anderes noch!
    Ich gebe in der öffentlichen Ordnerstruktur einem User Rechte auf einen Ordner.
    Er sieht den Ordner allerdings nur wenn der Standard auch Berechtigungen hat.

    Momentan ist Standard auf Berechtigungsstufe "Keine" und der User " Veröffentlichenender Autor".
    Der User sieht den Ordner nicht!!!

    Ich möchte aber verschiedene Ordner für bestimmte User nicht sichtbar haben.

    ?


    Wolle39


    • Bearbeitet Wolle39 Dienstag, 28. August 2012 06:55
    Dienstag, 28. August 2012 06:51
  • Hi Wolle39,

    ist das ein spezieller User oder gibst du das Recht über ein Gruppe?
    Exchange cached Rechte für bis zu zwei Stunden - hattest du ausreichend gewartet?
    !!! 2h Exchange cache !!!
    Änderungen im Active Directory wie SendAs oder FullMailboxAddress müssen
    erst im AD repliziert werden und dann von Exchange neu eingelesen werden. Per Default puffert Exchange frühere Antworten aber für bis zu 2 Stunden. Dies kann durch den Wert von "Mailbox cache Age Limit" (siehe KB 326252 Exchange 2000 mailbox size limits are not enforced in a reasonable period of time; fix requires Exchange 2000 SP2" verändert werden.
    Exchange 2003: http://support.microsoft.com/kb/326252
    Exchange 2007: http://technet.microsoft.com/en-us/library/bb684892.aspx

    Es sollte definitiv ohne Standard klappen...


    Viele Grüße
    Christian

    Dienstag, 28. August 2012 07:25
    Moderator
  • Hallo Christian.

    Sowohl als auch. Teste hier gerade mit einem User und einer Gruppe.

    Irgendwas ist hier faul... Wenn ich dem Standard User "Keine" gebe und mir selbst "Besitzer" sehe ich den Ordner nicht. Erst dann wenn der Standard User wieder ein Recht bekommt z.B "Mitwirkender" dann sehe ich selbst auch wieder den Ordner. Das alles in Echtzeit - muss gar nicht warten.

    Das gibt es doch nicht.

    Mir fällt gerade was ein. Wenn ich als User besondere Admin Rechte habe, kann es doch Probleme geben. Hatte ich damals auch beim OWA.
    Habe jetzt mal einen anderen User zum testen genommen und da geht es sowie gedacht.
    Also liegt es an meinen Rechten.


    Wolle39

    Dienstag, 28. August 2012 08:00
  • Hallo Christian.

    Also es liegt definitiv an meinen User Rechten. Bin noch auf der Suche welches "Recht" mir da ein Schnäppchen macht.
    Oder weißt Du das aus dem Stehgreif?


    Danke


    Wolle39

    Dienstag, 28. August 2012 08:41
  • Hi Wolle39,

    Hallo Christian.

    Also es liegt definitiv an meinen User Rechten. Bin noch auf der Suche welches "Recht" mir da ein Schnäppchen macht.
    Oder weißt Du das aus dem Stehgreif?

    Poste mal die Folder-Rechte: Get-PublicFolderClientPermission -Identity "\Ordner" | fl

    Bestehen die Probleme bei anderen Ordnern auch?

    Es kann auch ein Adminsholder-Seiteneffekt sein, wenn die Rechte nicht sauber geprüft werden können. Wie hast du das OWA-Problem beseitigt?
    http://www.msexchangefaq.de/konzepte/adminsdholder.htm

    Wäre mir aber neu, dass das beim Zugriff auftritt.


    Viele Grüße
    Christian

    Mittwoch, 29. August 2012 04:59
    Moderator
  • Hallo Christian,

    Get-PublicFolderClientPermission -Identity "\Ordner" | fl

    bekomme ich Standard darf lesen, Anonym Keine, Gruppe ist veröffentlichender Autor

    Wenn ich aber per ExFolders drauf schaue hat Stand None, Anonym None, Gruppe veröffentlichender Autor

    Was stimmt jetzt. Kann das an dem Cache liegen? Hab vor ca. 30 min. zum testen dem Standard lesen gegeben und wieder genommen.

    Gruß Wolfi


    Wolle39


    • Bearbeitet Wolle39 Mittwoch, 29. August 2012 06:36
    Mittwoch, 29. August 2012 06:35
  • Hi Wolle39,

    Was stimmt jetzt. Kann das an dem Cache liegen? Hab vor ca. 30 min. zum testen dem Standard lesen gegeben und wieder genommen.

    ist die Diskrepanz noch da? Mich wundert das etwas, denn es sollten dir IMHO die gleichen Daten angezeigt werden. Was Exchange noch im Hinterkopf hast, kannst du nicht auslesen...

    Wie sieht es bei einem neuen Ordner aus? Hast du Exfolder neu verbunden?


    Viele Grüße
    Christian

    Mittwoch, 29. August 2012 13:48
    Moderator
  • Hallo Christian.

    Die Rechte passen jetzt zueinander. Vielleicht wirklich am Cache gelegen.

    Habe einen Testordner erstellt. Im Office Client kann ich diesen nicht sehen im OWA allerdings schon.

    Großes Fragezeichen


    Wolle39

    Mittwoch, 29. August 2012 14:35