none
Probleme mit SQL Update RRS feed

  • Frage

  • Hallo zusammen,

    ich habe unter http://social.technet.microsoft.com/Forums/de-DE/windows_Serverde/thread/005b2595-bd55-443e-9cb5-6b6d34b0cf16/ ein Problem geschildert, dass den SQL 2005 betrifft. Winfried Sonntag (MVP) hat mich ans SQL-Forum verwiesen.

    Zusammengefasst:
    WSUS bietet meinem 2008 R2 x64 das Update "Windows Internal Database Service Pack 4 für x64 Edition (KB2463332)" an. Dieses schlägt fehl mit Fehler "Code 643 Unbekannter Fehler bei Windows Update".

    Das Ereignisprotokoll meint mit ID 10005:
    Product: Windows Internal Database -- Error 29528. The setup has encountered an unexpected error while Setting Internal Properties. The error is: Schwerwiegender Fehler bei der Installation.

    Und mit ID 20:
    Installationsfehler: Die Installation des folgenden Updates ist mit Fehler 0x80070643 fehlgeschlagen: Windows Internal Database Service Pack 4 für x64 Edition (KB2463332)

    Ich habe drauf hin das SP4 für manuell heruntergeladen und versucht zu installieren. Die x86-Version läuft fehlerfrei durch, die x64-Version sagt:

    **********************************************************************************
    Product Installation Status
    Product                   : Datenbankdienste (SQLEXPRESS)
    Product Version (Previous): 5000
    Product Version (Final)   :
    Status                    : NA
    Log File                  :
    SQL Express Features      :
    Error Description         : Setup kann Datenbankdienste x86 auf diesem Computer nicht aktualisieren. Um fortzufahren, führen Sie stattdessen das Service Pack-Installationsprogramm für die x86-Plattform aus.
    ----------------------------------------------------------------------------------
    Product                   : SQL Server Native Client
    Product Version (Previous): 5000
    Product Version (Final)   :
    Status                    : Fehler
    Log File                  : C:\Program Files\Microsoft SQL Server\90\Setup Bootstrap\LOG\Hotfix\Redist9_Hotfix_KB2463332_sqlncli.msi.log
    Error Number              : 1316
    Error Description         : MSP Error: 1316  Beim Versuch, die Datei C:\Program Files\Microsoft SQL Server\90\Setup Bootstrap\Cache\sqlncli_x64.msi zu lesen, ist ein Netzwerkfehler aufgetreten.
    ----------------------------------------------------------------------------------
    Product                   : Clientkomponenten
    Product Version (Previous): 3042
    Product Version (Final)   :
    Status                    : NA
    Log File                  :
    SQL Express Features      :
    Error Description         : Setup kann Clientkomponenten x86 auf diesem Computer nicht aktualisieren. Um fortzufahren, führen Sie stattdessen das Service Pack-Installationsprogramm für die x86-Plattform aus.
    ----------------------------------------------------------------------------------
    Product                   : Microsoft SQL Server VSS Writer
    Product Version (Previous): 5000
    Product Version (Final)   :
    Status                    : Fehler
    Log File                  : C:\Program Files\Microsoft SQL Server\90\Setup Bootstrap\LOG\Hotfix\Redist9_Hotfix_KB2463332_SqlWriter.msi.log
    Error Number              : 1316
    Error Description         : MSP Error: 1316  Beim Versuch, die Datei C:\Program Files\Microsoft SQL Server\90\Setup Bootstrap\Cache\sqlwriter_x64.msi zu lesen, ist ein Netzwerkfehler aufgetreten.
    ----------------------------------------------------------------------------------

    **********************************************************************************
    Summary
         One or more products failed to install, see above for details
         Exit Code Returned: 1316

     

    Punkt 2 und 4 beziehen sich auf x64, die x86 sind klar. Auf dem Server, der vor ca. 3 Monaten aufgesetzt und unter VMWare läuft, laufen 2 Datenbanken: 1x WSUS über Rollen installiert (dies sollte die x64-Variante sein) und einmal BackupExec 12 (sollte die x86-Variante sein). Ich sehe im Taskmanager, das die sglsrv.exe 2x läuft, einal als 64-bit und einmal als 32-bit.

    Hat jemand einen Tipp für mich, wie ich das SP4 installiert bekomme?

     

     


    Viele Grüße Dirk
    Donnerstag, 27. Januar 2011 14:48

Antworten