none
Probleme beim Verbinden von mehreren Outlook-Verbindungen mit dem gleichen Profil auf Exchange Server 2016

    Frage

  • Ich habe diverse Outlook Clients, welche mit dem gleichen Profil Verbindung zum Exchange 2016 aufbauen sollten. Drei Outlook Verbindungen mit dem selben Outlook Profil funktionieren problemlos. Sobald ich das vierte Outlook öffne, kommt permanent die Anmeldeaufforderung. Auch nach10 maligem Eingeben des Passworts kann sich das Outlook nicht verbinden. Die Anmeldeaufforderung kommt immer wieder, bis ich ein offenes Outlook schliesse. Danach kann ich wieder ein Outlook öffnen.

    Irgendwie muss da eine "max. Outlook Connection pro User" sein. Kennt jemand den entsprechenden Registry Key oder PowerShell Befehl?

    Gruss Domenico

    Montag, 28. Mai 2018 15:20

Antworten

  • Ich bin mir ziemlich sicher, dass nicht jede Art von Throttling Versuch im Eventlog geloggt wird. Zumindest nicht für MAPI.

    Ich hatte ein ähnliches Problem mal bei einem Kunden wo die GF ca. 10 shared Mailboxen verbunden hatte. Hatte dann auch die Regkeys gesetzt.

    anscheinend wird es nur in den dezidierten MapiHTTP Logs im Logging Folder geloggt, siehe auch: https://lanbugs.de/howtos/windows/outlook-2016-issues-with-many-mailboxes-and-many-folders/ 

    Das könntest du ja mal prüfen.

    • Als Antwort markiert DomenicoG Montag, 4. Juni 2018 12:36
    Samstag, 2. Juni 2018 10:08
  • es hat mit obigem Artikel perfekt funktioniert. Das Problem tritt nicht mehr auf.

    Die Lösung ist unter folgendem Link beschrieben:

    https://lanbugs.de/howtos/windows/outlook-2016-issues-with-many-mailboxes-and-many-folders/ 

    Ich musste lediglich den zweiten Befehl etwas anpassen:

    In ExchangeShell:

    1. New-ThrottlingPolicy -Name "New Throttling" -RCAMAXConcurrency Unlimited
    • 2. get-mailbox | set-mailbox -ThrottlingPolicy "New Throttling"
      New-ThrottlingPolicy -Name "New Throttling" -RCAMAXConcurrency Unlimited
        
      get-mailbox -name | set-mailbox -ThrottlingPolicy "New Throttling"

      Anpassungen in der Registry:

      Windows Registry Editor Version 5.00
      [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\MaxObjsPerMapiSession]
      "objtMessage"=dword:000005dc
      
      [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem]
      "Maximum Allowed Sessions Per User"=dword:00000080
      1. Windows Registry Editor Version 5.00
      2. [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\MaxObjsPerMapiSession]
      3. "objtMessage"=dword:000005dc
      4. [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem]
      5. "Maximum Allowed Sessions Per User"=dword:00000080

    • Als Antwort markiert DomenicoG Montag, 4. Juni 2018 12:36
    Montag, 4. Juni 2018 12:36

Alle Antworten

  • Moin, schauk mal ins Eventlog des Exchange Server. Die sollte zeitgleich protokollieren, welche Einstellung gedrosselt hat. Da gibt es mehrere, Throtteling Policy und DB Einstellungen.

    Gruesse aus Berlin schickt Robert - MVP Office Servers and Services (Exchange Server)

    Montag, 28. Mai 2018 18:15
  • Vielen Dank für den Hinweis. Leider gibt es keine Einträge im Eventlog des Exchange Server, wenn die Passwort-Abfrage kommt.
    Dienstag, 29. Mai 2018 05:18
  • Moin,

    ohne Fehlermeldung wird das schwer, da es mind. ein dutzend Einstellungen gibt und einige nur bei Neustart des IS wirksam werden.

    Welche Exchange-Version haben wir denn genau:

    http://blog-schulenburg.de/index.php/kategorie-als-blog/87-exchange-build-nummern

    Ist zwischen den Clients und dem Exchange Server noch ein Netzwerkgerät, dass da eingreifen könnte, z.B. ein Proxy oder Load Balancer?


    Gruesse aus Berlin schickt Robert - MVP Office Servers and Services (Exchange Server)

    Dienstag, 29. Mai 2018 11:05
  • Wir setzen Exchange 2016 Version 15.1 (Build 1415.2) ein. Der Exchange-Server wird gegen das WAN mittels einer Sonicwall Firewall geschützt. Die Anmeldeaufforderung kommt aber auch, wenn man das Outlook vom vom virtuellen Terminalserver oder physischen PC aus öffnet, welcher in der gleichen Zone bzw. im gleichen Netzwerk ist. In diesen Fällen geht der Traffic nicht über die Firewall.

    Wir haben noch den Trend Micro Messaging Security Agent installiert. Ich deinstalliere mal diesen Agent und versuche es dann nochmals.

    Gruss Domenico

    Dienstag, 29. Mai 2018 12:51
  • Wir haben noch den Trend Micro Messaging Security Agent installiert. Ich deinstalliere mal diesen Agent und versuche es dann nochmals.


    Virenscanner sind immer eine mögliche Quelle lustiger Fehler.

    Am besten testest Du das mal mit einem "nackten" Client, der möglichst wenig Einstellungen hat. OS-Installation, Domänen-Mitgliedschaft, Office-Installation, alle Updates und DANN testen.


    Gruesse aus Berlin schickt Robert - MVP Office Servers and Services (Exchange Server)

    Mittwoch, 30. Mai 2018 08:00
  • Inzwischen habe ich das Antivirus auf dem Exchange Server deinstalliert und alle Windows- und Exchangeupdates eingespielt. Auch nach dem Neustart treten immer noch das gleiche Problem auf. Pro Benutzer können gleichzeitig mit 3 verschiedenen Client eine Outlook Verbindung hergestellt werden. Wenn man dann mit einem zusätzlichen Client eine Outlook Verbindung herstellen möchte, kommen immer diese Anmeldeaufforderungen und das Outlook kann sich nicht verbinden, bis mindestens ein geöffnetes Outlook von diesem Benutzer geschlossen wird.

    Mittwoch, 30. Mai 2018 08:28
  • Moin,

    wenn Du keine entsprechenden Einträge im Eventlog des Exchange Servers findest, dann findet auch keine Drosselung bei Exchange statt. Exchange protokolliert das wie gesagt immer, da man sonst nicht weiß, wo man ändern muss.

    Dann wirst Du an anderen Stellen suchen müssen. Dein Netzwerk kennst nur Du, da wird eine Fernhilfe schwer.


    Gruesse aus Berlin schickt Robert - MVP Office Servers and Services (Exchange Server)

    • Als Antwort markiert DomenicoG Mittwoch, 30. Mai 2018 12:53
    • Tag als Antwort aufgehoben DomenicoG Montag, 4. Juni 2018 12:31
    Mittwoch, 30. Mai 2018 11:34
  • Danke trotzdem für die Unterstützung.

    Gruss Domenico

    Mittwoch, 30. Mai 2018 12:53
  • Ich bin mir ziemlich sicher, dass nicht jede Art von Throttling Versuch im Eventlog geloggt wird. Zumindest nicht für MAPI.

    Ich hatte ein ähnliches Problem mal bei einem Kunden wo die GF ca. 10 shared Mailboxen verbunden hatte. Hatte dann auch die Regkeys gesetzt.

    anscheinend wird es nur in den dezidierten MapiHTTP Logs im Logging Folder geloggt, siehe auch: https://lanbugs.de/howtos/windows/outlook-2016-issues-with-many-mailboxes-and-many-folders/ 

    Das könntest du ja mal prüfen.

    • Als Antwort markiert DomenicoG Montag, 4. Juni 2018 12:36
    Samstag, 2. Juni 2018 10:08
  • Vielen Dank für den Input, gerne werde ich dies in den nächsten Tagen testen. Anschliessend werde ich die Ergebnisse hier veröffentlichen.

    Montag, 4. Juni 2018 09:32
  • es hat mit obigem Artikel perfekt funktioniert. Das Problem tritt nicht mehr auf.

    Die Lösung ist unter folgendem Link beschrieben:

    https://lanbugs.de/howtos/windows/outlook-2016-issues-with-many-mailboxes-and-many-folders/ 

    Ich musste lediglich den zweiten Befehl etwas anpassen:

    In ExchangeShell:

    1. New-ThrottlingPolicy -Name "New Throttling" -RCAMAXConcurrency Unlimited
    • 2. get-mailbox | set-mailbox -ThrottlingPolicy "New Throttling"
      New-ThrottlingPolicy -Name "New Throttling" -RCAMAXConcurrency Unlimited
        
      get-mailbox -name | set-mailbox -ThrottlingPolicy "New Throttling"

      Anpassungen in der Registry:

      Windows Registry Editor Version 5.00
      [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\MaxObjsPerMapiSession]
      "objtMessage"=dword:000005dc
      
      [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem]
      "Maximum Allowed Sessions Per User"=dword:00000080
      1. Windows Registry Editor Version 5.00
      2. [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\MaxObjsPerMapiSession]
      3. "objtMessage"=dword:000005dc
      4. [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem]
      5. "Maximum Allowed Sessions Per User"=dword:00000080

    • Als Antwort markiert DomenicoG Montag, 4. Juni 2018 12:36
    Montag, 4. Juni 2018 12:36