none
Mit Powershell MTU size von Netzwerkadapter ändern

    Frage

  • Hi Leute

    Ich möchte gerne die MTU size aller Wireless Netzwerkadapter per Powershell auf eine bestimmte Zahl ändern.

    Mit vbscript habe ich dies wie folgt gemacht.

    Rcode = SetMTUSize("1300","Wireless")
    
    
    Function SetMTUSize(MTUSize,AdptName)
    
    Dim strDNSDomain, strComputer, strID, strKeyPath, strValueName, strDWValue
    Dim fRcode, oReg, objWMIService, colAdapters, objAdapter, sNetConnectionID
    
    Set WshShell = WScript.CreateObject("WScript.Shell")
    fRcode = 0
     
    HK = Chr(34)
     
    strComputer = "."
    Set oReg=GetObject("winmgmts:{impersonationLevel=impersonate}!\\" & _  
             strComputer & "\root\default:StdRegProv" )  
     
    set objWMIService = GetObject("winmgmts:{impersonationLevel=impersonate}!\\" & _  
             strComputer & "\root\cimv2" )
     
    Set colAdapters = objWMIService.ExecQuery _  
        ("SELECT * FROM Win32_NetworkAdapter WHERE NetConnectionID LIKE '%" & AdptName & "%'")
    
    For each objAdapter in colAdapters 
       WScript.Echo  objAdapter.NetConnectionID
       sNetConnectionID = objAdapter.NetConnectionID
       WshShell.Run "cmd /c netsh interface ipv4 set subinterface " & HK & sNetConnectionID & HK & " mtu=" & MTUSize & " store=persistent", 0, True	 
       If Err.Number <> 0 Then fRcode = -1
    Next 
      SetMTUSize = fRcode
    
    End Function

    Ich habe dies in Powershell noch nicht hinbekommen.

    Hat jemand Erfahrung und kann mir helfen?

    Vielen Dank und liebe Grüsse

    Freitag, 6. Oktober 2017 13:34

Antworten

  • Die NetconnectionID bezeichnet nichts anderes als den Namen. Ich weiss nicht, warum das in Windows 7 nicht so ist bzw. dass es dort funktioniert, unter Windows 10 wäre es aber folgendes: 

    Get-WmiObject Win32_NetworkAdapter | where {$_.Name -Like "*Wireless*"}

    Das ist schon die ganze Hexerei. 

    Ergänzung (Weiss nicht, ob dir das bereits bekannt ist): Das $_. referenziert auf das WMI-Objekt. Mit ihm können direkt Sachen (wie nennen sich die Unterkategorien?) angesteuert werden, die im Objekt enthalten sind (Beispiel: ServiceName, MacAddress). Durch das Ansteuern mit $_.XXX kann das bequem gemacht werden. 

    Dienstag, 10. Oktober 2017 08:35
  • Wenn der Name kein "Wireless" enthält, sondern vielleicht "WiFi" oder "Wi-Fi", dann funktioniert die Abfrage so nicht mehr. Es wird ja nur, wie Fahiko auch schon geschrieben hat, der Name abgefragt. Fahiko's Abfrage entsprechend erweitert und ein bissl modernisiert sähe dann so aus:
    Get-CimInstance -ClassName Win32_NetworkAdapter | Where-Object {$_.Name -match 'Wireless|WiFi|Wi-Fi'}


    Grüße - Best regards

    PS:> (79,108,97,102|%{[char]$_})-join''

    Dienstag, 10. Oktober 2017 09:14
  • Get-CimInstance -ClassName Win32_NetworkAdapter | Where-Object {$_.Name -match 'Wireless|WiFi|Wi-Fi'}
    $_.AdapterTypeID = 9

    -> https://msdn.microsoft.com/en-us/library/aa394216(v=vs.85).aspx

    Dann klappts auch in Chinesisch :-)) Und da man immer links filtern sollte:

    Get-CIMInstance -Classname Win32_Networkadapter -Filter "AdapterTypeID = 9"

    Blöd dabei ist nur, daß z.B. Intel gerne mal 802.3 (ID 0) für Wifi-Adapter verwendet :-((

    Bei mir auf dem HP-Laptop der 8260 - der hat eigentlich überhaupt keine Properties, über die man den zuverlässig als WLAN erkennen könnte - die NetConnectionID kann ich ja frei vergeben. Einzig Speed mit dem krummen Wert von 144 MBit wäre ein Anhaltspunkt...

    Availability                                : 3
    Name                                                : Intel(R) Dual Band Wireless-AC 8260
    Status                                            :
    StatusInfo                                    :
    DeviceID                                        : 11
    Caption                                         : [00000011] Intel(R) Dual Band Wireless-AC 8260
    Description                                 : Intel(R) Dual Band Wireless-AC 8260
    InstallDate                                 :
    ConfigManagerErrorCode            : 0
    ConfigManagerUserConfig         : False
    CreationClassName                     : Win32_NetworkAdapter
    ErrorCleared                                :
    ErrorDescription                        :
    LastErrorCode                             :
    PNPDeviceID                                 : PCI\VEN_8086&DEV_24F3&SUBSYS_00108086&REV_3A\34F39AFFFFEA457A00
    PowerManagementCapabilities :
    PowerManagementSupported        : False
    SystemCreationClassName         : Win32_ComputerSystem
    SystemName                                    : ########
    AutoSense                                     :
    MaxSpeed                                        :
    NetworkAddresses                        :
    PermanentAddress                        :
    Speed                                             : 144400000
    AdapterType                                 : Ethernet 802.3
    AdapterTypeId                             : 0
    GUID                                                : {C7E8C362-069F-4F12-A58B-70DCA00D19F0}
    Index                                             : 11
    Installed                                     : True
    InterfaceIndex                            : 12
    MACAddress                                    : 34:F3:9A:EA:45:7A
    Manufacturer                                : Intel Corporation
    MaxNumberControlled                 : 0
    NetConnectionID                         : Drahtlosnetzwerkverbindung
    NetConnectionStatus                 : 2
    NetEnabled                                    : True
    PhysicalAdapter                         : True
    ProductName                                 : Intel(R) Dual Band Wireless-AC 8260
    ServiceName                                 : NETwNs64
    TimeOfLastReset                         : 09.10.2017 11:21:55
    PSComputerName                            :
    CimClass                                        : root/cimv2:Win32_NetworkAdapter
    CimInstanceProperties             : {Caption, Description, InstallDate, Name...}
    CimSystemProperties                 : Microsoft.Management.Infrastructure.CimSystemProperties
    Dienstag, 10. Oktober 2017 10:17
  • Erstellen von Objekten:
    https://docs.microsoft.com/de-de/powershell/scripting/getting-started/cookbooks/creating-.net-and-com-objects--new-object-?view=powershell-5.1

    Aufruf von Programmen:
    http://windowsitpro.com/powershell/running-executables-powershell
    http://www.admin-source.de/BlogDeu/433/powershell-9-arten-ein-externes-programm-executable-zu-starten

    Freitag, 6. Oktober 2017 15:56
  • Moin,

    Olaf hat Recht. Aber wenn Du schon funktionierende WMI-Aufrufe hast, kannst Du sie mit Get-WMIObject bzw. Invoke-WMIMethod auch in PowerShell verwenden.


    Evgenij Smirnov

    I work @ msg services ag, Berlin -> http://www.msg-services.de
    I blog (in German) @ http://it-pro-berlin.de
    my stuff in PSGallery --> https://www.powershellgallery.com/profiles/it-pro-berlin.de/
    Exchange User Group, Berlin -> http://exusg.de
    Windows Server User Group, Berlin -> http://www.winsvr-berlin.de
    Mark Minasi Technical Forum, reloaded -> http://newforum.minasi.com

    Samstag, 7. Oktober 2017 05:28

Alle Antworten

  • Erstellen von Objekten:
    https://docs.microsoft.com/de-de/powershell/scripting/getting-started/cookbooks/creating-.net-and-com-objects--new-object-?view=powershell-5.1

    Aufruf von Programmen:
    http://windowsitpro.com/powershell/running-executables-powershell
    http://www.admin-source.de/BlogDeu/433/powershell-9-arten-ein-externes-programm-executable-zu-starten

    Freitag, 6. Oktober 2017 15:56
  • Hast Du schon mal über Group Policies nachgedacht? 

    Davon unabhängig ist dieses Forum nicht wirklich dafür gedacht, für Dich Scripte in andere Script-sprachen zu migrieren oder Dir das Scripten in Powershell beizubringen. Wir können gern versuchen, konkrete Fragen zu Powershell zu beantworten, aber das Debuggen von kompletten Scripten ist mit Sicherheit jenseits des Focus dieses Forums.


    Grüße - Best regards

    PS:> (79,108,97,102|%{[char]$_})-join''

    Freitag, 6. Oktober 2017 19:50
  • Moin,

    Olaf hat Recht. Aber wenn Du schon funktionierende WMI-Aufrufe hast, kannst Du sie mit Get-WMIObject bzw. Invoke-WMIMethod auch in PowerShell verwenden.


    Evgenij Smirnov

    I work @ msg services ag, Berlin -> http://www.msg-services.de
    I blog (in German) @ http://it-pro-berlin.de
    my stuff in PSGallery --> https://www.powershellgallery.com/profiles/it-pro-berlin.de/
    Exchange User Group, Berlin -> http://exusg.de
    Windows Server User Group, Berlin -> http://www.winsvr-berlin.de
    Mark Minasi Technical Forum, reloaded -> http://newforum.minasi.com

    Samstag, 7. Oktober 2017 05:28
  • Sorry, das war auch nicht das Ziel. Ich habe gedacht evtl. hat dies in diesem Forum schon mal jemand gemacht und kann mir sein Script/Vorgehen vorstellen.

    Ich habe in Powershell mit Get-WMIObject gearbeitet und bereits viel getestet, aber komischerweise erhalte ich nicht die gleiche ausgabe der Property NetConnectionID wie in VBScript.

    Montag, 9. Oktober 2017 14:37
  • Hast Du denn schon mal versucht, danach zu suchen? Wie man Registry-Settings ändert, wurde hier oder im englishen Powershell-Forum schon hunderte male gefragt und beantwortet.  ... und auch ausserhalb der beiden Foren ist das Internet quasi voll mit Beispielen, die Du Dir anpassen könntest.

    Grüße - Best regards

    PS:> (79,108,97,102|%{[char]$_})-join''


    • Bearbeitet BOfH_666 Montag, 9. Oktober 2017 14:46
    Montag, 9. Oktober 2017 14:46
  • Hi Evgenij

    Danke für die Antwort! Mit Get-WmiObject habe ich bereits einiges getestet, aber bin bisher nicht glücklich geworden. Wenn ich zb untenstehenden Befehl ausführe, erhalte ich alle Netzwerkadapter zurück.

    Get-WmiObject Win32_NetworkAdapter | where {$_.NetconnectionID -like '*'}

    Wenn ich aber explizit nur alle "Wireless" Adapter ausgeben möchte, wie ich dies in vbscript gemacht habe, erscheint keine Ausgabe.

    Get-WmiObject Win32_NetworkAdapter | where {$_.NetconnectionID -Like "%Wireless%"}
    Hast du eine Idee?


    Montag, 9. Oktober 2017 15:17
  • Hast du eine Idee?

    Powershell Basics lernen.  ;-)  Wildcards in Powershell sind die kleinen Sternchen - nicht die kleinen Prozentchen!  ... so wie Du es in Deinem ersten Beispiel schon gemacht hast!!

    Grüße - Best regards

    PS:> (79,108,97,102|%{[char]$_})-join''

    Montag, 9. Oktober 2017 15:22
  • > Wildcards in Powershell sind die kleinen Sternchen - nicht die kleinen Prozentchen!

    Naja, das LIKE bei Where-Object sieht dem LIKE bei WQL ja auch zum Verwechseln ähnlich :-) Und bei Regex ist es dann wieder was anderes...

    Im Ernst: Passiert mir auch öfter mal, daß ich falsche Wildcards verwende.

    Montag, 9. Oktober 2017 15:50
  • Mit diesen Sternchen habe ich es auch versucht, aber nun habe ich etwas spannendes herausgefunden.

    Get-WmiObject Win32_NetworkAdapter | where {$_.NetconnectionID -Like "*Wireless*"}

    Mit dem Befehl erhalte ich auf einem Windows 7 Client die gewünschte Ausgabe:

    ServiceName      : NETwNs64
    MACAddress       : F4:8C:50:A9:0E:25
    AdapterType      : Ethernet 802.3
    DeviceID         : 12
    Name             : Intel(R) Dual Band Wireless-AC 8260
    NetworkAddresses : 
    Speed            : 0

    Auf einem Windows 10 Client erhalte ich aber keine Rückgabe.

    Weitere Tipps?

    Dienstag, 10. Oktober 2017 08:16
  • Die NetconnectionID bezeichnet nichts anderes als den Namen. Ich weiss nicht, warum das in Windows 7 nicht so ist bzw. dass es dort funktioniert, unter Windows 10 wäre es aber folgendes: 

    Get-WmiObject Win32_NetworkAdapter | where {$_.Name -Like "*Wireless*"}

    Das ist schon die ganze Hexerei. 

    Ergänzung (Weiss nicht, ob dir das bereits bekannt ist): Das $_. referenziert auf das WMI-Objekt. Mit ihm können direkt Sachen (wie nennen sich die Unterkategorien?) angesteuert werden, die im Objekt enthalten sind (Beispiel: ServiceName, MacAddress). Durch das Ansteuern mit $_.XXX kann das bequem gemacht werden. 

    Dienstag, 10. Oktober 2017 08:35
  • Wenn der Name kein "Wireless" enthält, sondern vielleicht "WiFi" oder "Wi-Fi", dann funktioniert die Abfrage so nicht mehr. Es wird ja nur, wie Fahiko auch schon geschrieben hat, der Name abgefragt. Fahiko's Abfrage entsprechend erweitert und ein bissl modernisiert sähe dann so aus:
    Get-CimInstance -ClassName Win32_NetworkAdapter | Where-Object {$_.Name -match 'Wireless|WiFi|Wi-Fi'}


    Grüße - Best regards

    PS:> (79,108,97,102|%{[char]$_})-join''

    Dienstag, 10. Oktober 2017 09:14
  • Get-CimInstance -ClassName Win32_NetworkAdapter | Where-Object {$_.Name -match 'Wireless|WiFi|Wi-Fi'}
    $_.AdapterTypeID = 9

    -> https://msdn.microsoft.com/en-us/library/aa394216(v=vs.85).aspx

    Dann klappts auch in Chinesisch :-)) Und da man immer links filtern sollte:

    Get-CIMInstance -Classname Win32_Networkadapter -Filter "AdapterTypeID = 9"

    Blöd dabei ist nur, daß z.B. Intel gerne mal 802.3 (ID 0) für Wifi-Adapter verwendet :-((

    Bei mir auf dem HP-Laptop der 8260 - der hat eigentlich überhaupt keine Properties, über die man den zuverlässig als WLAN erkennen könnte - die NetConnectionID kann ich ja frei vergeben. Einzig Speed mit dem krummen Wert von 144 MBit wäre ein Anhaltspunkt...

    Availability                                : 3
    Name                                                : Intel(R) Dual Band Wireless-AC 8260
    Status                                            :
    StatusInfo                                    :
    DeviceID                                        : 11
    Caption                                         : [00000011] Intel(R) Dual Band Wireless-AC 8260
    Description                                 : Intel(R) Dual Band Wireless-AC 8260
    InstallDate                                 :
    ConfigManagerErrorCode            : 0
    ConfigManagerUserConfig         : False
    CreationClassName                     : Win32_NetworkAdapter
    ErrorCleared                                :
    ErrorDescription                        :
    LastErrorCode                             :
    PNPDeviceID                                 : PCI\VEN_8086&DEV_24F3&SUBSYS_00108086&REV_3A\34F39AFFFFEA457A00
    PowerManagementCapabilities :
    PowerManagementSupported        : False
    SystemCreationClassName         : Win32_ComputerSystem
    SystemName                                    : ########
    AutoSense                                     :
    MaxSpeed                                        :
    NetworkAddresses                        :
    PermanentAddress                        :
    Speed                                             : 144400000
    AdapterType                                 : Ethernet 802.3
    AdapterTypeId                             : 0
    GUID                                                : {C7E8C362-069F-4F12-A58B-70DCA00D19F0}
    Index                                             : 11
    Installed                                     : True
    InterfaceIndex                            : 12
    MACAddress                                    : 34:F3:9A:EA:45:7A
    Manufacturer                                : Intel Corporation
    MaxNumberControlled                 : 0
    NetConnectionID                         : Drahtlosnetzwerkverbindung
    NetConnectionStatus                 : 2
    NetEnabled                                    : True
    PhysicalAdapter                         : True
    ProductName                                 : Intel(R) Dual Band Wireless-AC 8260
    ServiceName                                 : NETwNs64
    TimeOfLastReset                         : 09.10.2017 11:21:55
    PSComputerName                            :
    CimClass                                        : root/cimv2:Win32_NetworkAdapter
    CimInstanceProperties             : {Caption, Description, InstallDate, Name...}
    CimSystemProperties                 : Microsoft.Management.Infrastructure.CimSystemProperties
    Dienstag, 10. Oktober 2017 10:17
  • Im Ernst: Passiert mir auch öfter mal, daß ich falsche Wildcards verwende.

    W A A S?? .... solche Schusselfehler passieren Dir? ... DIR? ... jetzt müssten wir Dir gleich mal eben 100 Punkte wieder abziehen!!  ;-)  :-D

    Ich glaub, den Unterschied macht dann, wie lange Du brauchst, um das zu bemerken und zu korrigieren.  ;-)


    Grüße - Best regards

    PS:> (79,108,97,102|%{[char]$_})-join''

    Dienstag, 10. Oktober 2017 11:39
  • Bei mir auf dem HP-Laptop der 8260 - der hat eigentlich überhaupt keine Properties, über die man den zuverlässig als WLAN erkennen könnte - die NetConnectionID kann ich ja frei vergeben. Einzig Speed mit dem krummen Wert von 144 MBit wäre ein Anhaltspunkt...

    ...oder man klinkt sich in irgendeine Treiberdatenbank ein und wertet die PNPDeviceID aus ;-)

    Evgenij Smirnov

    I work @ msg services ag, Berlin -> http://www.msg-services.de
    I blog (in German) @ http://it-pro-berlin.de
    my stuff in PSGallery --> https://www.powershellgallery.com/profiles/it-pro-berlin.de/
    Exchange User Group, Berlin -> http://exusg.de
    Windows Server User Group, Berlin -> http://www.winsvr-berlin.de
    Mark Minasi Technical Forum, reloaded -> http://newforum.minasi.com

    Dienstag, 10. Oktober 2017 12:41
  • Hi Leute

    Herzlichen Dank für eure wertvollen Tipps! Hammer!

    Powershell Skills werden aufjedenfall von Tag zu Tag besser ;-)

    Jetzt habe ich aber noch eine weitere letzte Frage und vielleicht kann mir hier auch jemand helfen auch wenn es nicht direkt mit Scripting / Powershell, sondern eher mit Windows Netzwerkadaptern zutun hat.

    Mit netsh.exe interface ipv4 show subinterface kann man sich ja alle Interfaces anschauen.

    Wenn ich dies auf dem HP Elitebook 840 G3 mit Win7 ausführe, erhalte ich folgende Ausgabe:

       MTU  MediaSenseState   Bytes In  Bytes Out  Interface
    ------  ---------------  ---------  ---------  -------------
    4294967295                1          0          0  Loopback Pseudo-Interface 1
      1300                5          0          0  Wireless Network Connection
      1400                1  1156592681  151703133  Local Area Connection

    Diese Netzwerkadapter sehe ich auch im Control Panel (-> Network and Internet -> Network Connections).

    Wenn ich das gleiche auf dem HP Elitebook 1040 mit Win10 ausführe, erhalte ich dies.

       MTU  MediaSenseState   Bytes In  Bytes Out  Interface
    ------  ---------------  ---------  ---------  -------------
    4294967295                1          0      12436  Loopback Pseudo-Interface 1
      1000                5          0          0  Wi-Fi
      1500                5          0          0  Cellular
      1000                1   13514782  131551083  Ethernet
      1500                5          0          0  Local Area Connection* 1

    Die ersten drei Adapter sehe ich auch alle schön im Control Panel und im Device Manager, aber was ist das für ein "Local Area Connection* 1" Adapter? Ein zweiter Ethernet Adapter? Wo sehe ich den?

    Wisst ihr das zufälligerweise auch? :)

    Mit besten Grüssen und schöner Mittwoch

    


    • Bearbeitet ynickburk Mittwoch, 11. Oktober 2017 07:34
    Mittwoch, 11. Oktober 2017 07:33
  • Der allererste "Loopback Pseudo-Interface 1" ist die Loopback-Adresse (also 127.0.0.1), die du immer aufrufen kannst. Die anderen drei siehst du dann dort, wo du auch bist. 

    Die letzte ist dann eine versteckte, nicht mehr benutzte Verbindung, die irgendwann mal erstellt wurde. Folge bitte mal folgendem Link, damit kannst du sie dann auch löschen. 

    https://www.rickygao.com.au/blog/how-to-delete-the-hidden-useless-local-area-connection/

    Mittwoch, 11. Oktober 2017 08:08
  • ..... aber was ist das für ein "Local Area Connection* 1" Adapter? Ein zweiter Ethernet Adapter? Wo sehe ich den?

    Wisst ihr das zufälligerweise auch? :)

    Bevor ich Dir Deine Fragen mit ein oder zwei Gegenfragen beantworte, möchte ich Dich bitten, falls Dir eine oder mehrere unserer Antworten geholfen haben, Dein Problem zu lösen, diese auch entsprechend als "Lösung" zu markieren. Dann finden Andere beim Suchen die Antwort schneller.

    Nun zu Deiner Netzwerkschnittstelle, auf der ja offenbar sowieso kein Betrieb herrscht: Warum musst Du das wissen? Stört Dich das Ding? Funktioniert irgendwas nicht?  Falls die Antworten "Neugier", "Nein" und "Nein" lauten, wäre meine Empfehlung: "Ignorieren!".  ;-)


    Grüße - Best regards

    PS:> (79,108,97,102|%{[char]$_})-join''

    Mittwoch, 11. Oktober 2017 08:08
  • Danke für deine Antwort Fahiko!

    Der "useless" Adapter ist eben komischerweise auch nicht unter hidden devices im device manager und kann ich daher nicht löschen.

    Ich muss in unserem Unternehmen die MTU size vom Ethernet Adapter von 1500 auf 1400 anpassen.

    Dies konnte ich dank euren Tipps mitterweile realisieren.
    Allerdings möchte ich verhindern, dass plötzlich ein Client über den vierten Local Area Connection* 1 Adapter kommuniziert, bei der die MTU size nicht angepasst ist.

    EDIT: Habe über die Registry herausgefunden, dass dies im Device Manager der Microsoft Wi-Fi Direct Virtual Adapter ist. Jetzt suche ich für was der genau gebraucht wird...
    Falls es jemand direkt weiss, darf er es gerne melden ;-)


    • Bearbeitet ynickburk Mittwoch, 11. Oktober 2017 09:17
    Mittwoch, 11. Oktober 2017 09:05
  • Habe die Antworten als hilfreich markiert - guter Tipp!

    Ja, aktuell herrscht dort kein Betrieb. Meinst du es könnte nicht sein, dass dieser Adapter in einer bestimmten Konstellation wieder verwendet wird? :-)

    EDIT: Habe über die Registry herausgefunden, dass dies im Device Manager der Microsoft Wi-Fi Direct Virtual Adapter ist. Jetzt suche ich für was der genau gebraucht wird...
    Falls es jemand direkt weiss, darf er es gerne melden ;-)
    • Bearbeitet ynickburk Mittwoch, 11. Oktober 2017 09:18
    Mittwoch, 11. Oktober 2017 09:09
  • Eigentlich hatte ich gehofft, das Thema damit abzuschließen, aber Du lässt nicht locker ....  ;-)

    Dieses "Loopback Pseudo-Interface 1" taucht ja z.B. auch nur dort auf und ist weder als Adapter in der Systemsteuerung noch als Device im Gerätemanager zu sehen. Im Gerätemanager hab ich z.B. noch ca 10 weitere "Netzwerkkarten", die aber alle nicht irgendwo direkt zu sehen sind. Man könnte also davon ausgehen, dass das virtuelle betriebssysteminterne Netzwerkschnittstellen sind, von denen Microsoft annimmt, das Windows sie braucht.


    Grüße - Best regards

    PS:> (79,108,97,102|%{[char]$_})-join''

    Mittwoch, 11. Oktober 2017 09:18
  • > netsh.exe interface ipv4 show subinterfac_e

    Geht ja noch - bei mir ist das noch mehr durcheinander :) Im Ernst - ich hab grad keine Ahnung, wie die Device-Namen korrelieren, aber dass Du in der GUI nicht alles siehst, war schon immer so.

    Mittwoch, 11. Oktober 2017 10:44
  • > EDIT: Habe über die Registry herausgefunden, dass dies im Device Manager der Microsoft Wi-Fi Direct Virtual Adapter ist. Jetzt suche ich für was der genau gebraucht wird...

    Google kaputt?

    https://lmgtfy.com/?q=windows+wifi+direct+virtual+adapter

    SCNR :-)

    Mittwoch, 11. Oktober 2017 10:46
  • Wenn deine Fragen geklärt wurden, denk bitte mal daran auch die Antworten zu markieren.

    Grüße, Denniver


    Blog: http://bytecookie.wordpress.com

    Kostenloser Powershell Code Manager v5: Link
    (u.a. Codesnippets verwalten + komplexe Scripte graphisch darstellen)

    Hilf mit und markiere hilfreiche Beiträge mit dem "Abstimmen"-Button (links) und Beiträge die eine Frage von dir beantwortet haben, als "Antwort" (unten).
    Warum das Ganze? Hier gibts die Antwort.

    Donnerstag, 12. Oktober 2017 08:16
    Moderator