none
Disabling F1 Help RRS feed

  • Frage

  • I am trying to disable F1 key from windows XP mode. I have a telnet program that requires F1 regularly and every time it gives me the help screen for virtual PC mode. I have tried the other things on the fourm (i.e. stop help and support service on the XP side, can't find it in services on the W7 side, and I tried to find helppane.exe to rename but couldn't). I cannot change the F1 in the program to something else.
    Mittwoch, 15. Juni 2011 05:57

Antworten

Alle Antworten

  • Hi,

    You may use DOSbox to run DOS applications instead of built-in Command Prompt.

    http://www.dosbox.com

    Also, you may refer to the following similar thread.

    http://answers.microsoft.com/en-us/windows/forum/windows_7-desktop/disable-f1f3-etc-hotkeys-in-windows-7-enterprise/20c2f130-aa0b-4362-90ad-a5cb358a072c


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Freitag, 17. Juni 2011 09:11
    Moderator
  • Hi

    Cannot use DOSBOX because the program is windows program not a dos program.

    Tried the other thread but it doesn't help.

    The problem is a W7 visualization problem. When I am running an app in XP mode, W7 does not recognize it as an active program but instead recognizes XP mode as active so when I press F1, the app receives the F1 and does it's thing but W7 also receives the F1 and puts up the XP mode help screen over the top which makes using the program almost impossible.

    I just need W7 to ignore it when I am talking to an XP mode app. The XP running in XP mode does.

     

    Dienstag, 21. Juni 2011 06:06
  • >I just need W7 to ignore it when I am talking to an XP mode app. The XP running in XP mode does.
     
    I have a really ugly workaround if you want to try it -- but use at
    your own risk.  It works for me and the only side effect is that the
    F1 key in VPC wont bring up the WVPC help, ever.
     
    If you're in en-us locality, the help file for the WVPC help is:
    C:\Windows\Help\mui\0409\virtualpc.chm
     
    What you need to do is take ownership of that file, then give full
    control permissions to both users and administrators.  Then rename
    that file to something else, say virtualpchelp.chm.  Then for good
    measure copy a shortcut of that file to the desktop in case you
    actually need to ever access it, then after that, F1 should work as
    normal for the VM and only the VM if the VM window has the focus.
     
    If you need more specific instructions on how to do that, let me know.
     
     

    Bob Comer - Microsoft MVP Virtual Machine
    Dienstag, 21. Juni 2011 14:25
  • Donnerstag, 23. Juni 2011 07:15
  • >(Bob?)
     
    That's definitely a better way to do it, don't know why I didn't think
    of trying that...
     
     

    Bob Comer - Microsoft MVP Virtual Machine
    Donnerstag, 23. Juni 2011 11:23
  • Bob, I thought you asked Ben that

    Donnerstag, 23. Juni 2011 17:02
  • Nah, wasn't me.
     
     

    Bob Comer - Microsoft MVP Virtual Machine
    Donnerstag, 23. Juni 2011 18:01
  • I have found that if you go into the settings for your Virtual Machine and select "Keyboard", change the setting to "To the virtual machine", the F1 help for virtual PC no longer comes up!  The only thing to note with this is that to get control of the keyboard and mouse back onto the client machine, you now need to use ALT CTRL +Left Arrow key instead of just the ALT +Left Arrow.

    Mittwoch, 18. Januar 2012 10:19