none
Drucker am entfernten Printserver (Windows Server 2008 R2) installieren. RRS feed

  • Allgemeine Diskussion

  • Hallo!

    Ich habe bei einem Hoster einen Windows Server 2008 R2 gemietet. Drauf habe ich Active-Directory installiert.

    Mein Kumpel, der eine Spedition unterhält, soll sich mit seinen Clients daran authentifizieren.


    Dass klappt auch einwandfrei. Nun dachte ich, auch den Netzwerkdrucker über den AD-Printserver installieren zu können.

    Da hakt es aber mit meinem Verständnis dafür. Und über Google, meine ich immer nur Konstellationen gefunden zu haben, wo sich der AD im gleichen Netzwerk wie der Drucker befindet.

    Mein Domain-Controller hat eine andere IP wie das bestehende Firmennetzwerk. Der betreffende Drucker hängt mit der IP: 192.168.2.103 an einer Switch. Die Switch mündet derzeit noch an einen Windows Server 2003, der jedoch komplett entfernt werden soll. Somit würde die Switch mit dem Drucker und zwei Clients direkt an einer Fritzbox münden, in der noch zwei weitere Clients angeschlossen sind.

    Ich möchte nun, dass der HP6600 über den AD Printserver zur Verfügung gestellt wird. Wenn ich im Printserver auf Druckerhinzufügen gehe, erreiche ich den Drucker nicht mit seiner IP.

    Habt Ihr einen Tipp für mich? Macht das angestrebte Ziel überhaupt Sinn?

    Freue mich auf eine Rückmeldung von euch!


    Gruß Thor Duisenberg
    Dienstag, 11. Februar 2014 14:02

Alle Antworten

  • der server braucht eine vpn Verbindung in das netz wo der drucker steht.

    außer es wird mit rdp auf dem server gearbeitet, dann können die Clients den lokalen drucker an den terminalserver durchgeben

    Dienstag, 11. Februar 2014 16:48
  • Hi,

    Am 11.02.2014 15:02, schrieb Thor Duisenberg:

    Ich habe bei einem Hoster einen Windows Server 2008 R2 gemietet.
    Drauf habe ich Active-Directory installiert. [...] Dass klappt auch
    einwandfrei. Nun dachte ich, auch den Netzwerkdrucker über den
    AD-Printserver installieren zu können.

    - Du hast 2 Netzwerke mit VPN verbunden
    - Der Client kann den DC erreichen, der DC kann den Client erreichen
    Mit anderen Worten deine IP Routen stimmen.

    Wenn der DC den Client mit der IP 192.168.2.x erreichen kann, dann erreicht er auch 192.168.2.103

    Du erstellt am DC einen neuen Drucker mit IP anschluss und gibst diesen Drucke frei.

    Ob die Umleitung des Druckjobs über das Internet/VPN und wieder zurück zum CLient Sinn macht und Datenvolumentechnisch erträglich ist, musst du ausprobieren.

    Tschö
    Mark


    Mark Heitbrink - MVP Windows Server - Group Policy

    Homepage: http://www.gruppenrichtlinien.de - deutsch
    GPO Tool: http://www.reg2xml.com - Registry Export File Converter

    Dienstag, 11. Februar 2014 19:15

  • Hallo Thomas, hallo Mark!

    Ja, VPN habe ich auch installiert.


    In den Adaptereinstellungen des Clients befindet sich eine VPN-Verbindung, die offenbar funktioniert. Wenn ich Remote-Desktop beende, kann ich über VPN immernoch auf die Freigaben des DCs zugreifen. In den Einstellungen des Adapters (Client) steht momentan noch alles auf automatischen Bezug. (also keine IPS vorgegeben) Unter Status wird 168.178...usw angezeigt. Das sieht - wie ich glaube - gut aus.



    Auf dem DC befindet sich unter Adaptereinstellungen keine VPN-Verbindung. Muss ich da eine zweite Verbindung herstellen? Auf dem DC unter Netzwerkrichtlinien und Zugriffsdienste steht eine aktive Verbindung. Dort unter Status befindet sich diese IP: 169.254...usw. Ist das nicht eine IP mit eingeschränktem Zugriff? Ansonsten steht da noch: "NIcht NAP-fähig". (Unter NPS steht "Einwahl erlauben" grün abgehakt.)


    Wenn alles in Ordnung wäre, müsste sich ja gegenseitig auf die Freigaben zugreifen lassen. Momentan kann das nur der Client.
    Meine Fokus meiner Befürchtungen steht grad die IP: 169.254... was denkt ihr?


    Bin auf eure Hilfe gespannt!

    Viele Grüße
    Dienstag, 11. Februar 2014 20:04
  • Eine Ergänzung:

    Ich habe VPN kurz abgeschaltet und wieder aktiviert.

    Jetzt habe ich vom Client und vom DC aus die 169.254...usw-IP.

    Und die zwei DNS-IPS vom DC (80.237...)

    Und ich sehe grad, dass kein DHCP-Server aktiviert ist.

    Das ist doch bestimmt der Fehler?!

    Ich frag mich nur, warum ich eben eine 192-er-IP in diesem Status gesehen habe. :-|


    Freue mich trotzdessen noch auf eine Rückmeldung!
    Dienstag, 11. Februar 2014 20:15
  • Ergänzung 2:

    Habe auf dem Client die Adaptereinstellung für VPN geändert.
    Ich hatte dort den DNS vom DC angegeben. (Das dürfte falsch gewesen sein.)
    Wenn ich nun die DNS der Fritzbox angebe und die IP automatisch beziehen lasse, bekomme ich immernoch
    eine 169-er IP. Trage ich eine vor (192.168.178.111) kommt keine Verbindung zustande.
    Jetzt stehe ich erstmal auf dem Schlauch!


    PS: Ich habe hier einmal von 192.168.2.1 und von 192.168.178.1 gesprochen. Das resultiert daraus, da mein Laptop zu Testzwecken als Client benutzt wird und ich im Büro und daheim unterschiedliche Adressen habe. Also bitte nicht verwirren lassen.

    Dienstag, 11. Februar 2014 20:44
  • Hallo Mark!

    So, ich habe nun das Problem mit der VPN-Verbindung mittels dieser genialen Anleitung gelöst:

    http://znil.net/index.php?title=Windows:Windows_Server_2008_R2_als_VPN_Einwahlserver_f%C3%BCr_Windows_7_hinter_Firewall_mit_Boardmitteln#end


    Zumindest erhält der VPN-Adapter des Clients nun eine 192er IP und der DC vergibt eine 192er aus dem statischen Pool.

    (!) Aber, anpingen klappt trotzdem nicht. Zur Analyse habe ich auf dem Client und dem DC die Firewalls abgeschaltet.


    In der obigen Anleitung steht drin, man müsse noch Ports im Rooter freischalten.

    Im Speedport W 723V steht nun: Port TCP 1723 Weiterleitung für CLIENT (thor-pc)


    Für den DC müsse auch ein Port nach obiger Anleitung freigeschaltet werden.
    Da der DC dezentral stationiert ist, verfügt mein Speedport über keinen DC-Eintrag.

    Was macht man denn da? :-o


    Auf der Telekom-Seite passend zum Speedport stand, man müsse auch die Ports: 500,4500,1701 freischalten. Geholfen hat es nicht!

    Freue mich auf eine Antwort!

    Gruß Thor

    Nachtrag: Wie es aussieht, versteht der Speedport kein GRE-Protokoll.

    Mittwoch, 12. Februar 2014 09:54