none
Absender Microsoft Outlook in Fehler und Zustellberichten

    Frage

  • Hi,

    weiß jemand wie man Exchange 2010 SP1 den Absendernamen "Microsoft Outlook" für Zustell / Fehlerberichte abgewöhnen kann. Ich würde hier gerne "Mailer-Daemon" oder ähnliches setzen.

    Outlook im Exchange-Modus / OWA zeigt den DisplayName im AD an - den kann man ja im Transport mit ADSI-Edit setzen - aber via IMAP wird weiterhin "Microsoft Outlook" als Absender angezeigt... *nerv*

    Vielen Dank für eure Hinweise,

    BM

    Dienstag, 25. Oktober 2011 20:48

Antworten

Alle Antworten

  • HI,

    außer das es dich stört, gibt es irgendeinen anderen Grund das ändern zu wollen? Imho geht das nicht, aber ich kann mich auch irren.

     

    Edit: Für extern kann man (sollte man) eine postmasteradresse einrichten: http://technet.microsoft.com/de-de/library/bb430765.aspx

     


    Viele Grüße Walter Steinsdorfer MVP Exchange Server http://msmvps.com/blogs/wstein/
    Mittwoch, 26. Oktober 2011 04:24
    Moderator
  • Hi Walter,

    danke für die Antwort.

    Das mit der Postmaster-Adresse ist bekannt und wurde auch gesetzt (kann man in der Verwaltungskonsole bei den Transporteinstellungen eigentlich auch kaum übersehen) . Es geht nur um den Anzeigenamen der Zustellberichte unter IMAP.

    Wir haben trotz Exchange viele IMAP Nutzer (mit diversen Clients - MAC-Mail, Eudora, Thunderbird...) welche sich fragen - wieso sie von "Microsoft Outlook" Zustellberichte bekommen. Ist für den Nutzer nicht immer einleuchtend. Es hat also nur einen "störenden" Hintergrund.

    Wenn MS den Absendernamen wenigstens "Microsoft Exchange" genannt hätte...

    Aber vielleicht kennt ja noch jemand einen Trick.

    Mittwoch, 26. Oktober 2011 07:13
  • Hi Marshall,

    die Frage wurde auch gerade in der Exchange Maillist gepostet und ich poste mal Franks Antwort:
    Mein Quittungen Intern kommen auch von “Microsoft Outlook”
    Der Alias ist „MicrosoftExchange329e71ec88ae4615bbc36ab6ce41109e“
    Könnte also deiner sein

    Eine Suche gegen den GC mit „mailnickname=MicrosoftExchange329e71ec88ae4615bbc36ab6ce49e“  ergab ein Objekt in der Configuration Paritition
    lokal.de/Configuration/Services/Microsoft Exchange/Firma/Transport Settings/MicrosoftExchange329e71ec88ae4615bbc36ab6ce41109e

    und da finde ich das Objekt mit ADSIEDIT auch.

    Wenn man mit dem Alias mal „suchen“ geht kommt man z.B. auf
    http://technet.microsoft.com/en-us/library/bb430759.aspx

    Ich könnte mir vorstellen dass eine Änderung des Displaynamens dein „Problem“ löst Versuch es doch einfach einmal. Das Risiko dürfte sehr gering sein.
     -- Viele Grüße
    Christian

    Freitag, 28. Oktober 2011 13:45
    Moderator
  • ...hier also...

    http://www.exusg.de/


    Viele Grüße
    Christian

    Freitag, 28. Oktober 2011 13:47
    Moderator
  • Hi Christian,

    danke für deine Antwort. Für Outlook im Exchange Modus oder OWA gilt der Anzeige-Name tatsächlich (hatte ich eingangs mit ADSI-Edit gemeint). Für IMAP-User jedoch (komischerweise?) nicht :(

    Ist wohl fest codiert... Muss ich doch mal bei MS nachhaken - die sollten es ggf. wissen. *g*

    Viele Grüße,
    BM

    Samstag, 29. Oktober 2011 17:47
  • Hi Marshall,

    Ist wohl fest codiert... Muss ich doch mal bei MS nachhaken - die sollten es ggf. wissen. g

    hast du mal mit einem neuen IMAP-Profil getestet, nachdem du den Displayname geändert hast? Der Name des Senders "MS Outlook" wurde ja geändert und das sollte auch zum IMAP-Client durchgreifen.

    Könnte mir jetzt vorstellen, dass es noch in der AutovervollständigenListe zwischengespeichert ist und er dir jetzt einen Streich spielt...


    Viele Grüße
    Christian

    Dienstag, 1. November 2011 05:37
    Moderator
  • Hi,

    steht direkt in der Nachricht der Absender-Name. Auch sind bei IMAP zwei Attachments angehangen, welche bei MAPI nicht zu sehen sind. Die Aufbereitung der Informationen scheint andere Wege zu gehen.

    http://technet.microsoft.com/de-de/library/bb430759.aspx

    Hier stimmt die Doku nicht, denn "Microsoft Exchange" wird nicht als Absendernamen angezeigt, sondern "Microsoft Outlook"; und bei jedem Update Rollup (wie zb. vor kurzem bei RU6) bekommt man den Anzeige-Name wieder in das AD gepumpt...

    Naja - vielleicht bin ich ja der einzige Monk :)

    Dienstag, 1. November 2011 17:07
  • Hi,

    wenn es ein Problem darstellt kannst du natürlich ein Ticket bei MSPSS aufmachen. Wenn es von der Doku abweicht hast du gute Chancen das es als BUG behandelt wird und als DCR (Design Change Request) bei der Produktgruppe landet. Garantieren kann ich es nicht, Bugs wären kostenfrei und auch wenn du recht bekommst kann es sein das das Problem nicht behoben wird.

     


    Viele Grüße Walter Steinsdorfer MVP Exchange Server http://msmvps.com/blogs/wstein/
    Dienstag, 1. November 2011 19:44
    Moderator
  • Habe bei mir grade von E2010SP1RU5 auf RU6 aktualisiert und alle AD-Änderungen protokolliert

    der erste Eintrag war meine Änderung mit ADSIEDIT. danach wurden nichts mehr an den Objekt geändert

     

     identity                 ! action    ! field          ! value
    -------------------------------------------------------------------------------
     CN=MicrosoftExchange329e7! Modify    ! displayname    ! Exchange Postmaster
     CN=MyMailboxDelegation,CN! NewOrMove ! parentguid     ! System.Byte[]
     CN=MyMailboxDelegation,CN! Modify    ! ntsecuritydescr! System.Byte[]
     CN=MyMailboxDelegation,CN! Modify    ! msexchroleentri! c,Set-Mailbox,Micros
     CN=MyMailboxDelegation,CN! Modify    ! whencreated    ! 11/02/2011 12:43:32
     CN=MyMailboxDelegation,CN! Modify    ! systemflags    ! 1073741824
     CN=MyMailboxDelegation,CN! Modify    ! objectclass    ! top msExchRole
     CN=MyMailboxDelegation,CN! Modify    ! objectcategory ! CN=ms-Exch-Role,CN=S
     CN=MyMailboxDelegation,CN! Modify    ! msexchroleflags! -2095175680
     CN=MyMailboxDelegation,CN! Modify    ! msexchversion  ! 53017076763648
     CN=MyMailboxDelegation,CN! Modify    ! msexchroletype ! 91

    Also keine Zurücksetung des DisplayNamens

    http://www.msxfaq.de/internet/quittung.htm

     

     


    Exchange MVP www.msxfaq.net
    Mittwoch, 2. November 2011 12:51
  • Danke für den Test. Jedoch kann ich nur bei mir sagen, dass ich den Namen bisher nach jeden RU neu setzen musste. An welcher Stelle/wann er genau geändert wurde kann ich nicht beurteilen. Wie hast du die Änderungen mitgeloggt?

    >http://www.msxfaq.de/internet/quittung.htm

    Habe ich mir selbstverständlicherweise vor meiner Frage hier angesehen.

    [schleimmodus an]
    Beste Webseite im Exchange-Bereich!
    :))
    [schleimmodus aus]

    Im Ernst: Wird denn bei IMAP-Zugriff bei dir der gesetzte Name von der Transport-Config dann auch angezeigt? *Offtopic - denn bei nicht MAPI, sondern SMTP-Versenden kann ich - soweit mir bewusst ist - auch beliebigen Namen setzen (nicht Mail-Adresse) und es wird nicht der Display-Name hergenommen*

    Mittwoch, 2. November 2011 20:15
  • Hi,

    wenn es ein Problem darstellt kannst du natürlich ein Ticket bei MSPSS aufmachen. Wenn es von der Doku abweicht hast du gute Chancen das es als BUG behandelt wird und als DCR (Design Change Request) bei der Produktgruppe landet. Garantieren kann ich es nicht, Bugs wären kostenfrei und auch wenn du recht bekommst kann es sein das das Problem nicht behoben wird.

     


    Viele Grüße Walter Steinsdorfer MVP Exchange Server http://msmvps.com/blogs/wstein/

    Die meisten Probleme muss man aussitzen, da sich der "Meldeprozess" für Kleinigkeiten einfach nicht lohnt. Zb. warte ich schon seit einem SP und 6 RU, dass im OWA in der Mail-Vorschau aus "Bis:" endlich "An:" wird ;)

    Mittwoch, 2. November 2011 22:22
  • Ich werde es mal im Auge behalten, wer wann das Feld ändert.

    Zum Logging: In Umgebungen mit Revisionsanforderungen ist es üblich, "Changes" zu tracken. DAS kann man schon mit dem Eventlog machen

    http://www.msxfaq.de/konzepte/auditing.htm

    Für so schnelle Tests in umgebungen mit genau einem DC und wenn ich nur wissen will, was sicht geändert hat (aber nicht wer es war) dann reicht mir mein eigenes Tool: http://www.msxfaq.de/tools/get-adchanges.htm  oder etwas einfacher als http://www.msxfaq.de/tools/get-usnchanges.htm (nur auf Objektebene)

    Ein weiterer Anhaltspunkt ist der "USNLastChanged" bzw "LastModified" Eintrag am Objekt. Wenn das Datum oder die USN "vor" deinem Setup liegt, dann kann es das Setup nicht gewesen sind

     

    Zum Zugriff. Eigentlich sollte es egal sein, wie der Client die Mail liest. auch der DR/NDR ist eine MEssage, die du im Messagetracking nachverfolgen kannst. und da ist es eine MAil

    die hat einen "MAIL FROM"  (den man aber in Outlook nicht sicht) und eben im HEader auch ein "From"  und da steht auch der DIsplayname drin.

    Schau dir im IMAP-Client doch mal den Header an, was da drin steht.

     

     

     

     

     

     

     

     


    Exchange MVP www.msxfaq.net
    Donnerstag, 3. November 2011 08:34
  • die hat einen "MAIL FROM"  (den man aber in Outlook nicht sicht) und eben im HEader auch ein "From"  und da steht auch der DIsplayname drin.

    Schau dir im IMAP-Client doch mal den Header an, was da drin steht.


    IMAP:

    ---

    MIME-Version: 1.0
    From: Microsoft Outlook <mailer-daemon@xxx>
    To: <xxx
    Date: Sun, 6 Nov 2011 13:57:25 +0100
    Content-Type: multipart/report; report-type=delivery-status;
        boundary="4a581023-50f4-49f7-97e8-b7e68426dfb3"
    X-MS-Exchange-Organization-SCL: -1
    Content-Language: de-DE
    Message-ID: <278f94a8-66cc-4529-a82e-f5757d7cbff1@xxx>
    In-Reply-To: <4ECA03E61A30CA47BD09659E8D57B296D76D89@xxx>
    References: <4ECA03E61A30CA47BD09659E8D57B296D76D89@xxx>
    Thread-Topic: Axel kommt am Montag
    Thread-Index: Acycg3EhfqlK+vinTZuRP60Y9i4ltwAADBz6
    Subject: Zugestellt: Axel kommt am Montag
    X-MS-Exchange-Organization-AuthSource: xxx
    X-MS-Exchange-Organization-AuthAs: Internal
    X-MS-Exchange-Organization-AuthMechanism: 05

    ---

    mailer-daemon@xxx ist eine mail-adresse, die ich in der org-onfig eingetragen habe.

    MicrosoftExchangeRecipientEmailAddresses                  : {SMTP:mailer-daemon@xxx, smtp:MicrosoftExchange329
                                                                e71ec88ae4615bbc36ab6ce41109e@xxx, smtp:MicrosoftE
                                                                xchange329e71ec88ae4615bbc36ab6ce41109e@xxx, smtp
                                                                :MicrosoftExchange329e71ec88ae4615bbc36ab6ce41109e@xxx}
    MicrosoftExchangeRecipientReplyRecipient                  : xxx
    MicrosoftExchangeRecipientPrimarySmtpAddress              : mailer-daemon@xxx


    Sonntag, 6. November 2011 13:50
  • Ok. also in der IMAP Mail steht dirn

    "From: Microsoft Outlook mailer-daemon@xxx"  und das zeigt der IMAP-Client auch korrekt an.

    Auf der Rechten Seite zeigst du uns aber Outlook per MAPI, korrekt ?

    Und da hat Exchange eine "Funktion" die Absenderadressen, wenn Sie von "vertrauten Systemen" kommt, gegen die GAL auflöst.

    Das gibt es schon lange  http://support.microsoft.com/kb/174755 

    und auch bei Ex2010 SP1 immer noch

    http://technet.microsoft.com/en-us/library/bb430743.aspx

    Ich hab in meiner Exy2007 "StandardVM" noch mal nachgeschaut. Da steht als "Displayname" tatsächlichj "Microsoft Exchange" drin und nicht "Microsoft Outlook".  So kann es passieren.  und das hast du eventuell mit einer Konfig angepasst ? ich denke dein Outlook erkennt die interne Mail als "Trusted  (Du kannst mal den SCL-Level prüfen, ob der auf "-1" steht) und dann nimmt er die SMTP-Adresse des Absenders und macht ne GAL-Suche.  ignoriert also den im "FROM: mit übergebenen namen.

    Wenn die Mail von Extern kommt, macht er das genau nicht, um eben "phishing" zu erschweren. Wer also von extern eine MAil bekommt und die From-Adresse zeigt einen "internen Namen" ab, dann ist auch immer die SMTP-Adresse dahinter ein Hinweis, dass die Mail "anonym" reingekommen ist.  möglicherweise als "falsch ist.

    Frank

     


    Exchange MVP www.msxfaq.net
    Sonntag, 6. November 2011 17:31
  • Rechts ist MAPI. Man kann ja in seinem Outlook zum Testen das selbe Konto einmal als Exchange, einmal als IMAP konfigurieren Testmail an sich selbst senden - mit Übermittlungsbericht...

    In Exchange 2007 steht noch "Microsoft Exchange", bei 2010(SP1) "Microsoft Outlook" (das stimmt nicht mit der Technet überein).
    (DisplayName von .../CN=TransportSettings/CN=MicrosoftExchange329e71ec88ae4615bbc36ab6ce41109e, habe ich zu "Mailer-Daemon" geändert)

    Die frage ist halt wo er den Namen "Microsoft Outlook" herzaubert für das "From".

    Das ist jetzt nicht das größte Problem, aber wie gesagt - Anfagen wieso man als Apple-Mail-Nutzer *igitt* Mails von "Microsoft Outlook" bekommt gibt es schon ab und zu. Microsoft Exchange wäre mir lieber und noch besser, wenn ich den selbst bestimmen könnte.

    Aber es ist nun mal kein Wunschkonzert. :)

    Danke für eure Hinweise...


    Montag, 7. November 2011 09:19