none
Exchange Empfangsconnector RRS feed

  • Frage

  • Hallo,

    ich habe 2 Exchange 2013 Server (Client-, Postfachserver). Beide können auch E-Mails empfangen, allerdings habe ich den FQDN bei den Empfangsconnectoren auf die externe Domain geändert (mx1.bla.com, mx2.bla.com) Dazu musste ich die Exchange Server Authentifizierung entfernen (beim Connector). Jetzt kann ich aber aus dem OWA oder über Exchange keine E-Mail mehr versenden. Über SMTP klappt es...

    Ich denke, dass ich nur einen neuen Empfangsconnector erstellen muss, aber ich habe keine Ahnung wie? Könnt ihr mir helfen?

    LG
    Julian

    Donnerstag, 23. Juli 2015 12:15

Antworten

  • Moin,

    ja, leider.

    Damit hast Du Dir hohe Komplexität und Fehleranfälligkeit geschaffen, ohne echten Mehrwert.

    Ich würde:

     - Den Mailbox-Server auch zum Clientzugriffsserver machen (Rolle nachinstallieren).

     - alle Connectoren auf diesem neu einrichten

     - alle URLs passend ändern

    Theoretisch geht das auch umgekehrt, den CAS zum MBX machen und die Postfächer verschieben.

    Und wenn die Connectoren wieder sauber sind, dann die Zertifikatseinbindung noch mal neu und nur noch genau das konfigurieren, was man braucht.


    Gruesse aus Berlin schickt Robert - MVP Exchange Server

    Freitag, 24. Juli 2015 08:41

Alle Antworten

  • Hi Julian,

    die erste Frage ist: was willst Du eigentlich erreichen? Exchange ist im Standard schon fertig für den Empfang interner und externer Mails konfiguriert, es besteht so keinerlei Notwendigkeit, an den Default-Connectors herumzuschrauben.

    Für Sachen wie anonymen Mailversand oder Relays legt man immer zusätzliche Connectors an.

    Und die Aussage " aus dem OWA oder über Exchange keine E-Mail mehr versenden. Über SMTP klappt es" ist widersprüchlich, da Mails bei Exchange im Standard immer über SMTP versendet werden, egal ob aus Outlook oder OWA (technisch gehen natürlich noch POP und IMAP).


    Gruß

    Ben

    MCSA Windows 8 (.1) MCSA Windows Server 2012 (R2)

    Wenn Dir meine Antwort hilft, markiere sie bitte entsprechend als Antwort! Danke! :-)

    Hinweis: Meine Posts werden "wie besehen" ohne jedwede Gewähr bereitgestellt, da menschliche, technische und andere Fehler nicht ausgeschlossen werden können.

    Donnerstag, 23. Juli 2015 14:33
  • Moin,

    welche Exchange Version hast Du denn genau?

    Wie äußert sich "kann keine Mails mehr" versenden? Entzünden die sich von selbst und sprengen sich in der Luft. ;) Eine Fehlermeldung oder ein Blick in die Warteschlange wäre hilfreich.

    Wenn Du an den Connectoren nichts rumgespielt hast, brauchst Du keinen neuen Connector. Den FQDN stellst Du ja nur bei den Frontend Connectoren ein (die mit Port 25). Von den Backend Connectoren (die mit Port 2525) lässt man die Finger. Die nutzt Exchange dann intern.


    Gruesse aus Berlin schickt Robert - MVP Exchange Server

    Donnerstag, 23. Juli 2015 14:33
  • @Ben:

    > Und die Aussage " aus dem OWA oder über Exchange keine E-Mail mehr versenden. Über SMTP klappt es ist widersprüchlich," 

    Nicht unbedingt. Für SMTP rein/raus werden die Frontend-Transport-Connectoren (Port 25 oder 587) benutzt, während die server-internen Dinge wie OWA/Outlook über die Backend-Connectoren (Port 2525 oder 465) laufen.

    Es ist daher durchaus vorstellbar, dass man zwischen Postfächern nicht mehr senden kann, vom gleichen Server aber durchaus nach draußen. Und wenn man den Backend-Connectoren verbastelt und dort z.B. Port 25 einstellt, dann kann es so aussehen, als könnte man Mails per SMTP empfangen, es gehen aber keine Mails mehr von Postfach A nach Postfach B.

    Genaueres weiß man aber erst, wenn der OP seine Konfiguration und seine Aufgabenstellung besser beschreibt.

    (Was bin ich froh, dass dieses Drama in 2016 wieder vereinfacht wurde!)


    Gruesse aus Berlin schickt Robert - MVP Exchange Server

    Donnerstag, 23. Juli 2015 16:43
  • Hallo,

    danke für die Antworten.

    Sobald ich den FQDN (der ja von außen ersichtlich ist / telnet mx1.server.com 25 => EHLO srv1.bla.local)  ändern wollte trat dieser Fehler auf:

    Fehler: Wenn das AuthMechanism-Attribut eines Empfangsconnectors den Wert "ExchangeServer" enthält, muss der FQDN-Parameter auf dem Empfangsconnector auf einen der folgenden Werte festgelegt werden: den FQDN des Transportservers "srv1.bla.local", den NetBIOS-Name des Transportservers "SRV1" oder "$null".

    Deswegen habe ich beim Empfangsconnector "Default Frontend SRV1" die ExchangeServer Anthentifizierung (Haken) weggeben und konnte diesen nun ändern. Das Problem ist, dass ich über SMTP Mails senden kann aber über OWA nicht. Die Mail bleibt dann einfach im Postausgang hängen.


    Wenn ich den Standardconnector nicht verändern soll... Könnt ihr mir helfen wie ich einen eigenen anlegen kann, damit sich der Server nach außen aber richtig meldet...
    • Bearbeitet Julian Lampert Donnerstag, 23. Juli 2015 21:02 bla korrigieren
    Donnerstag, 23. Juli 2015 20:55
  • Hallo,

    das sind dann mal die Connectoren von SRV1 (Frontend)...

    Das sind alle die, die automatisch seit der Installation da sind, da habe ich nichts gemacht außer versucht den FQDN zu ändern. Fehler oben => EHLO FQDN muss mit externem Hostname stimmen, ggeht aber nicht, deswegen habe ich die Exchange Auth. deaktiviert => E-Mail senden ging nicht => Jetzt wieder alles auf Anfang.

    Die auf SRV2 (Postfachserver) sehen gleich aus...


    • Bearbeitet Julian Lampert Donnerstag, 23. Juli 2015 21:35 Text und so
    Donnerstag, 23. Juli 2015 21:27
  • Moin,

    1. Bitte keine Screenshots!

    Ein "Get-ReceiveConnectors | fl" bringt die gleichen Infos, nur deutlich übersichtlicher.

    2. Wenn das alle Connectoren sind, fehlen da welche.

    3. Und weil ich da irgendwie einen bösen Verdacht bekomme: Du hast zwei Exchange-Server, welche Rollen sind auf den jeweiligen Servern installiert?


    Gruesse aus Berlin schickt Robert - MVP Exchange Server

    Freitag, 24. Juli 2015 06:56
  • @Robert: OK, daran habe ich nicht gedacht, stimmt.

    Ja, da bin ich auch froh - beim Umstieg von 2010 auf 2013 bin ich erstmal verzweifelt. ;-) Mal sehen, wann Microsoft dann wieder die Rollentrennung empfiehlt, wahrscheinlich dann 2017. ;-)


    Gruß

    Ben

    MCSA Windows 8 (.1) MCSA Windows Server 2012 (R2)

    Wenn Dir meine Antwort hilft, markiere sie bitte entsprechend als Antwort! Danke! :-)

    Hinweis: Meine Posts werden "wie besehen" ohne jedwede Gewähr bereitgestellt, da menschliche, technische und andere Fehler nicht ausgeschlossen werden können.

    Freitag, 24. Juli 2015 07:40
  • Hallo,

    alles klar keine Screenshots mehr ;)

    Ja, ich habe 2 Exchange Server einer ist der Frontendserver (Clientzugriff) und der andere Postfachserver. Die Empfangsconnectoren waren bereits so angelegt, ich habe nur die Sendeconnectoren konfiguriert. Hat sich der böse Verdacht bestätigt?

    LG

    Julian

    Freitag, 24. Juli 2015 08:03
  • Moin,

    ja, leider.

    Damit hast Du Dir hohe Komplexität und Fehleranfälligkeit geschaffen, ohne echten Mehrwert.

    Ich würde:

     - Den Mailbox-Server auch zum Clientzugriffsserver machen (Rolle nachinstallieren).

     - alle Connectoren auf diesem neu einrichten

     - alle URLs passend ändern

    Theoretisch geht das auch umgekehrt, den CAS zum MBX machen und die Postfächer verschieben.

    Und wenn die Connectoren wieder sauber sind, dann die Zertifikatseinbindung noch mal neu und nur noch genau das konfigurieren, was man braucht.


    Gruesse aus Berlin schickt Robert - MVP Exchange Server

    Freitag, 24. Juli 2015 08:41
  • Am 24.07.2015 schrieb Robert Wille [MVP]:

    Hi Robert,

     - Den Mailbox-Server auch zum Clientzugriffsserver machen (Rolle nachinstallieren).

    Geht nur nicht bei 2013, oder wurde da was geändert, was ich übersehen habe?

    Theoretisch geht das auch umgekehrt, den CAS zum MBX machen und die Postfächer verschieben.

    Auch das dürfte bei 2013 eigentlich nicht gehen.

    Bye
    Norbert


    Dilbert's words of wisdom #34:
    When you don't know what to do, walk fast and look worried.
    nntp-bridge Zugriff auf die MS Foren wieder möglich:
    https://communitybridge.codeplex.com/

    Freitag, 24. Juli 2015 22:29
  • Norbert, damit hast Du natürlich recht.

    Woran man auch erkennt, dass ich schon seit Jahren nicht mehr den Bedarf hatte, irgendwas nachzuinstallieren, weil ich gleich immer wie empfohlen Multi-Role benutzt habe.


    Gruesse aus Berlin schickt Robert - MVP Exchange Server

    Samstag, 25. Juli 2015 10:33
  • Am 25.07.2015 schrieb Robert Wille [MVP]:
    Hi,

    Norbert, damit hast Du natürlich recht.

    Woran man auch erkennt, dass ich schon seit Jahren nicht mehr den Bedarf hatte, irgendwas nachzuinstallieren, weil ich gleich immer wie empfohlen Multi-Role benutzt habe.

    Naja bei 2010 wars halt ganz praktisch, wenn man doch mal einen Fehler
    hatte, die Rolle einfach entfernen und wieder installieren zu können. ;)

    Bye
    Norbert


    Dilbert's words of wisdom #34:
    When you don't know what to do, walk fast and look worried.
    nntp-bridge Zugriff auf die MS Foren wieder möglich:
    https://communitybridge.codeplex.com/

    Samstag, 25. Juli 2015 22:07
  • hallo zusammen

    Ich hab das absolute gleiche Problem was Julain Lampert hat. Der unterschied zumir ist, das ich Postfach u. Clientzugriff Server auf einer maschine habe u. Exchange 2016 läuft. Der mail fluss funktioniert bei mir, nur der FQDN im haeder von den mails die rein u. rausgehen wie sich mein server meldet das ist nicht gut überhaupt nicht.

    Der <host.domain.local [interne ip] >

    wie kann man das änder.

    Gruß

    Uwe

    Mittwoch, 20. Januar 2016 15:14
  • Da Du nicht das gleiche Problem hast, mach doch bitte einen neuen Thread auf und häng Dich nicht an alte ran. Das wird sonst unübersichtlich.

    Den FQDN kannst Du im Connector ändern, sieht man sogar hier oben im Screenshot.


    Gruesse aus Berlin schickt Robert - MVP Office Servers and Services (Exchange Server)

    Mittwoch, 20. Januar 2016 15:22
  • Hallo Robert

    habe ich

    https://social.technet.microsoft.com/Forums/de-DE/6812f211-6f4f-45eb-abb2-e78eccdae940/smtpbanners-empfangsconnector-nder?forum=exchange_serverde

    Gruß

    Uwe

    Mittwoch, 20. Januar 2016 15:33