locked
Umbenennen - wie geht's richtig? RRS feed

  • Frage

  • Hallo Forum,

    das Problem: Wenn ein Rechner bei uns im Netzwerk ausgetauscht wird, wird temporär ein neuer Rechnername vergeben, da sich ja nicht zwei Rechner mit gleichem Namen im Netz befinden können. Vor Ort wird der Computer dann umbenannt und erhält den Namen des alten Rechners. Trotzdem antworten nach Neustart, Domäne raus / rein und Löschen des Kontos mit dem nun nicht mehr gebrauchten temporären neuen Namen BEIDE Namen auf die Ping-Anfrage (mit gleicher IP).
    Auch nach Ändern über die Netzwerk-ID (möglicherweise läuft dort etwas falsch), antwortet der erste Name noch.

    Kann mir da vielleicht jemand weiterhelfen, z.B. mit einer Step-by-Step-Anleitung, wie die Umbenennung richtig funktioniert, so dass nur der ALTE Name wieder antwortet...

    Vielen Dank!
    Montag, 21. Juli 2014 12:07

Antworten

  • Hallo,

    das kommt weil dein DNS-Server den Eintrag im Cache hat.

    Du kannst den Cache auf dem DNS-Server in der DNS Verwaltungsconsole über "Cache löschen" zurücksetzten.

    Dann sollte dein Client nur noch über den aktuellen Namen Antworten.

    Gruß
    Stefan


    st_fbg

    Montag, 21. Juli 2014 12:32
  • Moin

    je nach Ausgestaltung deines Netzes (Größe, mehrere DNS-Server etc. ) braucht es unter Umständen einige Zeit, bis Änderungen im AD sauber auf alle Server verteilt sind. Daher auch nicht zu schnell hinterteinander Rechner-Name im AD löschen und dann sofort wieder neu einrichten. Wenn die Replikation noch nicht vollständig durchgelaufen ist und mehrere DNS-Server im Einsatz sind, gibt es o.g. Probleme.

    Montag, 21. Juli 2014 13:56
  • Hi,

    wir machen das so, dass wir auf dem neuen Client über die Kommandozeile ein "ipconfig /registerdns" ausführen. Das beschleunigt die Registrierung des Clients im DNS erheblich. :-)

    Aktuell müssen wir das sogar bei jedem neuen Client machen, weil sich der DNS-Eintrag nicht mehr von selbst aktualisiert.

    Gruß

    Ben

    Dienstag, 22. Juli 2014 07:23
  • Moin

    Hast du mehrere DNS-Server im Netz? Wenn ja, sind diese alle fest in einer bestimmten Reihenfolge in den Netzwerkeinstellungen vorgegeben? Wenn ja, tausch die Reihenfolge und schau mal, was dann passiert. Eventuell hapert es bei der Replikation zwischen den DNS-Servern.

    Dienstag, 22. Juli 2014 08:32
  • Hallo Kollegen,

    vielen Dank für die schnellen und hilfreichen Reaktionen von Euch!
    Durch Eure Hilfe konnte ich den Fehler eingrenzen. Die Lease-Zeit war zu hoch eingestellt und die Einträge waren im Cache hängen geblieben...

    Somit nochmals vielen Dank an alle!

    Boory01

    Dienstag, 22. Juli 2014 10:22

Alle Antworten

  • Hallo,

    schau mal in Deinen DNS Zonen auf dem entsprechenden A record ob dort eine SID gelistet ist oder der Rechnername. Wenn SID, dann den Eintrag löschen, replizieren lassen bei mehreren DNS Servern und dann mit ipconfig -registerdns nochmals probieren.


    Best regards

    Meinolf Weber
    MVP, MCP, MCTS
    Microsoft MVP - Directory Services
    My Blog: http://msmvps.com/blogs/mweber/

    Disclaimer: This posting is provided AS IS with no warranties or guarantees and confers no rights.

    Montag, 21. Juli 2014 12:31
  • Hallo,

    das kommt weil dein DNS-Server den Eintrag im Cache hat.

    Du kannst den Cache auf dem DNS-Server in der DNS Verwaltungsconsole über "Cache löschen" zurücksetzten.

    Dann sollte dein Client nur noch über den aktuellen Namen Antworten.

    Gruß
    Stefan


    st_fbg

    Montag, 21. Juli 2014 12:32
  • Moin

    je nach Ausgestaltung deines Netzes (Größe, mehrere DNS-Server etc. ) braucht es unter Umständen einige Zeit, bis Änderungen im AD sauber auf alle Server verteilt sind. Daher auch nicht zu schnell hinterteinander Rechner-Name im AD löschen und dann sofort wieder neu einrichten. Wenn die Replikation noch nicht vollständig durchgelaufen ist und mehrere DNS-Server im Einsatz sind, gibt es o.g. Probleme.

    Montag, 21. Juli 2014 13:56
  • Hi,

    wir machen das so, dass wir auf dem neuen Client über die Kommandozeile ein "ipconfig /registerdns" ausführen. Das beschleunigt die Registrierung des Clients im DNS erheblich. :-)

    Aktuell müssen wir das sogar bei jedem neuen Client machen, weil sich der DNS-Eintrag nicht mehr von selbst aktualisiert.

    Gruß

    Ben

    Dienstag, 22. Juli 2014 07:23
  • Moin

    Hast du mehrere DNS-Server im Netz? Wenn ja, sind diese alle fest in einer bestimmten Reihenfolge in den Netzwerkeinstellungen vorgegeben? Wenn ja, tausch die Reihenfolge und schau mal, was dann passiert. Eventuell hapert es bei der Replikation zwischen den DNS-Servern.

    Dienstag, 22. Juli 2014 08:32
  • Hallo Kollegen,

    vielen Dank für die schnellen und hilfreichen Reaktionen von Euch!
    Durch Eure Hilfe konnte ich den Fehler eingrenzen. Die Lease-Zeit war zu hoch eingestellt und die Einträge waren im Cache hängen geblieben...

    Somit nochmals vielen Dank an alle!

    Boory01

    Dienstag, 22. Juli 2014 10:22