none
RootCA; regelmäßige Backups mit certutil RRS feed

  • Frage

  • Hi Community,

    unsere neue RootCA wollte ich jetzt regelmäßig über eine Batchdatei sichern, welche das 'certutil -backup ...' und 'regedit /e ...' zu einem bestimmten Zeitpunkt ausführt. Jedoch scheint es, dass das certutil Kommando nicht ausgeführt wird, wenn kein User am System angemeldet ist. Gibt es da keine Möglichkeit die RootCA ohne Logon zu sichern? Im Systemstate Backup ist ja nicht alles drin, was ich kürzlich erst feststellen musste.

    Thx & Bye Tom

    Montag, 14. Oktober 2013 09:45

Antworten

  • Mit welcher Fehlermeldung im Task Scheduler respektive Event-Log "TaskScheduler\Operational" wird der Task beendet?

    Wie hast Du den geplanten Task im Detail konfiguriert?

    Unter welchen Benutzer wird der "Scheduled Task" gestartet?

    Sind hier "Run with highest privileges" und "Run wether user is logged on or not" aktiviert?

    --

    Tobias Redelberger
    StarNET Services (HomeOffice)
    Frankfurter Allee 193
    D-10365 Berlin
    Tel: +49 (30) 86 87 02 678
    Mobil: +49 (163) 84 74 421
    Donnerstag, 17. Oktober 2013 13:41

Alle Antworten

  • Mit welcher Fehlermeldung im Task Scheduler respektive Event-Log "TaskScheduler\Operational" wird der Task beendet?

    Wie hast Du den geplanten Task im Detail konfiguriert?

    Unter welchen Benutzer wird der "Scheduled Task" gestartet?

    Sind hier "Run with highest privileges" und "Run wether user is logged on or not" aktiviert?

    --

    Tobias Redelberger
    StarNET Services (HomeOffice)
    Frankfurter Allee 193
    D-10365 Berlin
    Tel: +49 (30) 86 87 02 678
    Mobil: +49 (163) 84 74 421
    Donnerstag, 17. Oktober 2013 13:41
  • Hi,

    du sicherst in einen LW Buchstaben im Netzwerk? Dann ist UNC die Lösung.

    HKLM kann keine Laufwerke mappen.


    Tschö
    Mark Heitbrink - MVP Windows Server - Group Policy
    Homepage: www.gruppenrichtlinien.de - deutsch
    GPO Tool: www.reg2xml.com - Registry Export File Converter

    Donnerstag, 17. Oktober 2013 13:48
  • Servus,

    >Sind hier "Run with highest privileges" und "Run wether user is logged on or not" aktiviert?

    Die Geschichte mit der Checkbox bei den "highest privileges" war das Problem. Vermutlich wird damit wohl eine Command Shell im Administratormodus gestartet.

    Thx & Bye Tom

    Donnerstag, 17. Oktober 2013 15:20
  • Servus,

    >du sicherst in einen LW Buchstaben im Netzwerk? Dann ist UNC die Lösung.

    Zum testen des Scripts sichere ich erst mal lokal auf dem Server mit einem LW-Buchstaben basiertem Pfad. Aber das war nicht das Problem (Siehe Antwort an Norbert)

    Das Script schaut so aus und scheint zu tun, für was es gebaut ist:

    @echo 0n
    
    set CERTUTIL="C:\Windows\System32\certutil.exe"
    set REGEDIT="C:\Windows\regedit.exe"
    set FORFILES="C:\Windows\System32\forfiles.exe"
    
    set CERTREGCONFIG="HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\CertSvc\Configuration"
    
    %FORFILES% /P "C:\orgfiles\_Cert_Backup" /S /D -6 /C "cmd /c rd /S /Q @file"
    
    mkdir "C:\orgfiles\_Cert_Backup\%date%"
    
    %CERTUTIL% -backup -p "mysecretpasswd" -f -gmt -seconds -v C:\orgfiles\_Cert_Backup\%date%
    %REGEDIT% /e c:\orgfiles\_Cert_Backup\%date%\certconf.reg %CERTREGCONFIG%

    Thx & Bye Tom


    Donnerstag, 17. Oktober 2013 15:24