none
Remote Server returned '420 4.2.0 Recipient deferred because there is no Mdb'

    Frage

  • Hi,

    We have a mail server running Exchange 2013 in hybrid mode. We have migrated all mailboxes to Office 365 with no problems.

    However, when new user accounts have been created, they are unable to recieve external email. The accounts are on Office365, but the NDR that we recieve is generated by our exchange server.

    The message in the NDR is "Remote Server returned '420 4.2.0 Recipient deferred because there is no Mdb'"

    This user can send emails to external accounts, and these emails come from username@domain.com

    I can send an email from an external account to this user by emailing username@domain.onmicrosoft.com, it is only when using username@domain.com that I recieve this NDR

    Any help would be greatly appreciated.

    Donnerstag, 15. September 2016 14:24

Antworten

  • Hi

    I think you have issue in mail routing, try to do enable to enable-remotemailboxes for this user, 2ndly check that this user is licensed in O365. this user is under license with a validated domain ?

    regards.

    H.Shakir

    • Als Antwort markiert Stevie_f Freitag, 16. September 2016 09:04
    Donnerstag, 15. September 2016 15:43

Alle Antworten

  • Hi

    I think you have issue in mail routing, try to do enable to enable-remotemailboxes for this user, 2ndly check that this user is licensed in O365. this user is under license with a validated domain ?

    regards.

    H.Shakir

    • Als Antwort markiert Stevie_f Freitag, 16. September 2016 09:04
    Donnerstag, 15. September 2016 15:43
  • Hi,

    We have a mail server running Exchange 2013 in hybrid mode. We have migrated all mailboxes to Office 365 with no problems.

    However, when new user accounts have been created, they are unable to recieve external email. The accounts are on Office365, but the NDR that we recieve is generated by our exchange server.

    The message in the NDR is "Remote Server returned '420 4.2.0 Recipient deferred because there is no Mdb'"

    This user can send emails to external accounts, and these emails come from username@domain.com

    I can send an email from an external account to this user by emailing username@domain.onmicrosoft.com, it is only when using username@domain.com that I recieve this NDR

    Any help would be greatly appreciated.

    Sounds like you need to add an smtp alias to that account.  Do you have an email address policy in place?

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread

    Donnerstag, 15. September 2016 17:40
  • Thanks, that solved it.

    I hadn't enabled remote mailboxes for the new users

    Freitag, 16. September 2016 09:05
  • Hello,

    sorry to bring this post back to life.

    I am in the same situation. We are migrating our users to O365, but for newcomers we just create the AD account on-premises, whilst the mailbox is created following the license activation. These users can't get emails from outside but they can send outside. I have unsuccessfully played with proxy address attribute on AD. Now I came to this post and perhaps enable-remotemailboxes could fix the issue. What's the exact command to be executed and where? On-premises there is no mailbox as I said before. 

    Thank you very much.

    Regards,

    Mittwoch, 16. Mai 2018 14:25