none
Windows Server 2008 R2 Fonts - Probleme RRS feed

  • Frage

  • Hallo,

    wir haben mehrer Windows Server 2008 R2 Server auf denen sich eine bestimmte Schriftart nicht installieren lässt.

    Zum Verhalten:

    - angemeldet als lokaler Administrator

    - Font-Dateien in %windir%\fonts kopiert

    - Installation erfolgreich lt. Meldung

    Jedoch wird diese Schriftart nach einem Neustart bzw. abmelden und wieder anmelden im Fontsordner nicht angezeigt. Versucht man diese neu zu installieren, dann meldet das System, dass diese Schriftart installiert ist. Angezeigt wird sie jedoch nicht und ist somit auch nicht verfügbar.

    An der Schriftart selber kann es nicht liegen, da die Schriftart in unserer Umgebung sauber installiert wird (auch Windows Server 2008 R2) und auch nach Neustarts bzw. nach Abmeldung und Anmeldung immer noch sichtbar ist.

    Jemand eine klevere Idee? Ich komme hier ehrlich gesagt leider nicht weiter.

    Donnerstag, 18. Dezember 2014 11:53

Antworten

  • Hi,

    in der Registry unter "HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Fonts" werden alle auf dem System vorhandenen Fonts aufgelistet. Sind die betroffenen Schriftarten da eventuell auch noch drin? Für eine Neuinstallation könnte es helfen, die Einträge dort zu entfernen und dann nochmal die Installation zu versuchen.

    Ansonsten fand ich noch den Wert "Auto Deactivation Exclude" im Schlüssel "\Font Management" interessant (etwas weiter oben), dort sind mE Systemschriftarten enthalten, die vor dem Löschen oder was auch immer geschützt werden sollen. Ich hab leider auf die Schnelle keine weiteren Infos zu diesem Wert gefunden.

    Idee 1: vielleicht gibt es in einem der "Font..."-Schlüssel irgendeinen Wert, der Deine Schriftarten deaktiviert/löscht/sonstwas - dann wäre es einen Versuch wert, diesen zu entfernen (vorher notieren bzw. einen Export machen)

    Idee 2: füg Deine Schriftarten dem Wert "Auto Deactivation Exclude" hinzu. Vielleicht bleiben sie dann nach einem Neustart erhalten.


    Gruß

    Ben

    MCITP Windows 7

    Wenn Dir meine Antwort hilft, markiere sie bitte entsprechend als Antwort! Danke! :-)

    Hinweis: Meine Posts werden "wie besehen" ohne jedwede Gewähr bereitgestellt, da menschliche, technische und andere Fehler nicht ausgeschlossen werden können.

    Dienstag, 23. Dezember 2014 12:46
  • Hi,

    Am 18.12.2014 12:53, schrieb SADFR:

    - Font-Dateien in %windir%\fonts kopiert
    [...] Jedoch wird diese Schriftart nach einem Neustart bzw. abmelden und
    wieder anmelden im Fontsordner nicht angezeigt.

    Nur kopieren reicht nicht, dann fehlt der "GUI" Anzeigeteil, der aus der Registry kommt

    zB
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Fonts
    "Meine Schriftart Standard (TrueType)"=meinfont.ttf

    Tschö
    Mark


    Mark Heitbrink - MVP Windows Server - Group Policy

    Homepage: http://www.gruppenrichtlinien.de - deutsch
    GPO Tool: http://www.reg2xml.com - Registry Export File Converter

    Dienstag, 23. Dezember 2014 20:13

Alle Antworten

  • Hi,

    kommt die Fehlermeldung auch, wenn Du auf die Schriftart rechts klickst und dort "Installieren" auswählst?
    Sind die Schriftarten tatsächlich im Dateisystem (also unter C:\WINDOWS\Fonts") nicht vorhanden? Das wundert mich etwas, ich wüsste nicht, warum Windows automatisch Schriftarten entfernen sollte... Aber es gibt alles. ;-)

    Vielleicht heißen die auch irgendwie anders? Mit einem funktionierenden Server wirst Du es aber sicher schon verglichen haben...


    Gruß

    Ben

    MCITP Windows 7

    Wenn Dir meine Antwort hilft, markiere sie bitte entsprechend als Antwort! Danke! :-)

    Hinweis: Meine Posts werden "wie besehen" ohne jedwede Gewähr bereitgestellt, da menschliche, technische und andere Fehler nicht ausgeschlossen werden können.

    Donnerstag, 18. Dezember 2014 15:06
  • Es kommt ja keine Fehlermeldung beim Installieren. Egal, ob ich die Dateien per Rechsklick installiere oder beim Kopieren in das Verzeichnis. Soweit ist alles gut. Anschließend werden die Dateien auch im Fonts Ordner angezeigt.

    Nur nach einem Neustart bzw. abmelden und wieder anmelden sind die Dateien nicht mehr im Fonts Ordner vorhanden.

    Habe ich so auch noch nicht erlebt daher die Frage :)

    Donnerstag, 18. Dezember 2014 15:34
  • Hi,

    in der Registry unter "HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Fonts" werden alle auf dem System vorhandenen Fonts aufgelistet. Sind die betroffenen Schriftarten da eventuell auch noch drin? Für eine Neuinstallation könnte es helfen, die Einträge dort zu entfernen und dann nochmal die Installation zu versuchen.

    Ansonsten fand ich noch den Wert "Auto Deactivation Exclude" im Schlüssel "\Font Management" interessant (etwas weiter oben), dort sind mE Systemschriftarten enthalten, die vor dem Löschen oder was auch immer geschützt werden sollen. Ich hab leider auf die Schnelle keine weiteren Infos zu diesem Wert gefunden.

    Idee 1: vielleicht gibt es in einem der "Font..."-Schlüssel irgendeinen Wert, der Deine Schriftarten deaktiviert/löscht/sonstwas - dann wäre es einen Versuch wert, diesen zu entfernen (vorher notieren bzw. einen Export machen)

    Idee 2: füg Deine Schriftarten dem Wert "Auto Deactivation Exclude" hinzu. Vielleicht bleiben sie dann nach einem Neustart erhalten.


    Gruß

    Ben

    MCITP Windows 7

    Wenn Dir meine Antwort hilft, markiere sie bitte entsprechend als Antwort! Danke! :-)

    Hinweis: Meine Posts werden "wie besehen" ohne jedwede Gewähr bereitgestellt, da menschliche, technische und andere Fehler nicht ausgeschlossen werden können.

    Dienstag, 23. Dezember 2014 12:46
  • Hi,

    Am 18.12.2014 12:53, schrieb SADFR:

    - Font-Dateien in %windir%\fonts kopiert
    [...] Jedoch wird diese Schriftart nach einem Neustart bzw. abmelden und
    wieder anmelden im Fontsordner nicht angezeigt.

    Nur kopieren reicht nicht, dann fehlt der "GUI" Anzeigeteil, der aus der Registry kommt

    zB
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Fonts
    "Meine Schriftart Standard (TrueType)"=meinfont.ttf

    Tschö
    Mark


    Mark Heitbrink - MVP Windows Server - Group Policy

    Homepage: http://www.gruppenrichtlinien.de - deutsch
    GPO Tool: http://www.reg2xml.com - Registry Export File Converter

    Dienstag, 23. Dezember 2014 20:13
  • Hallo,

    Vielen Dank an alle für Ihre Beiträge!

    @SADFR, haben die Tipps weitergeholfen? Wenn ja, markieren Sie bitte die richtige Lösung als Antwort.

    Wenn Sie eine andere Lösung gefunden haben, bitte teilen Sie sie der Community mit, sodass auch andere Benutzer als der Fragesteller davon profitieren können.

    Gruß,

    Michaela


    Bitte haben Sie Verständnis dafür, dass im Rahmen dieses Forums, welches auf dem Community-Prinzip „IT-Pros helfen IT-Pros“ beruht, kein technischer Support geleistet werden kann oder sonst welche garantierten Maßnahmen seitens Microsoft zugesichert werden können.

    Montag, 29. Dezember 2014 08:32
    Moderator