none
nslookup löst nicht auf RRS feed

  • Frage

  • Hallo zusammen,

    ich habe einen Windows Server 2016 und daran einen Linux Debian als Router und DNS Forwarder eingerichtet. Mein Problem ist dass das Internet auf dem Server total Lahm ist, und nur teilweise Funktioniert. Wenn ich nslookup eingebe, dann kommt das dabei raus:

    c:\users\Administrator>nslookup www.heise.de Server: UnKnown Address: ::1 Nicht autorisierte antwort: Name: www.heise.de Addresses: 2a02:2e0:3fe:1001:7777:772e:2:85 193.99.144.85

    Das ist das was da raus kommt. Pingen geht immer, und auch schnell mit einer MTU von 1412. Ich habe leider nicht all zu viel Ahnung von der ganzen Sache, weil sonst wäre es auch sicher so, dass ich das Problem gelöst hätte können :P

    Ich hoffe ihr versteht mein Problem und habt Lösungen dafür!

    mfg Tobias Benedikt

    Donnerstag, 14. September 2017 12:51

Alle Antworten

  • Dies tritt dann auf, wenn im Netz mehrere DNS-Server vorhanden sind.
    Früher konnte man eine DNS-Hierarchie festlegen, seit Windows10/Server 2016 geht das irgnedwie nicht mehr.
    Nun wird eine DNS-Abfrage quasi gleichzeitig gesendet (Broadcast). Und da ist es leider so, dass nun der Schnellste gewinnt.
    Hast du also z.B. einen DNS-Server, der nur deine lokalen Computer meldet, aber Anfragen zu unbekannten Computern nicht an einen Router weiter leitet, kommt die Antwort "unbekannt" schnell zurück.
    Weitere DNS-Anfragen werden dann nicht mehr gemacht.

    Ich hatte das Problem bei einer VPN-Verbindung, die alle DNS-Auflösungen beantwortet hatte und somit Internet-Anfragen nicht beantwortet wurden. Insgesamt wurde das Netz dann auch sehr langsam.
    Dies konnte man mit DNS-Suffix-Einstellungen auf der VPN-Konfig dann einschränken.

    Ach ja und noch was:
    Irgendwo stand dann auch geschrieben, dass das Verfahren von NSLOOKUP von Windows selber so nicht mehr verwendet wird.
    • Bearbeitet Der Suchende Donnerstag, 14. September 2017 13:07
    Donnerstag, 14. September 2017 13:05
  • Moin,

    das sieht ja aus, als ob der Windows-Rechner bei sich selbst als DNS eingetragen wäre. Ist es der Fall? Und läuft da ein DNS-Server mit einem korrekten Forwarder?

    Was passiert denn, wenn Du nslookup www.heise.de <IP des Linux-Routers> eingibst?


    Evgenij Smirnov

    I work @ msg services ag, Berlin -> http://www.msg-services.de
    I blog (in German) @ http://it-pro-berlin.de
    my stuff in PSGallery --> https://www.powershellgallery.com/profiles/it-pro-berlin.de/
    Exchange User Group, Berlin -> http://exusg.de
    Windows Server User Group, Berlin -> http://www.winsvr-berlin.de
    Mark Minasi Technical Forum, reloaded -> http://newforum.minasi.com

    Donnerstag, 14. September 2017 13:18