none
Remote Desktop -- Aero Glass? RRS feed

  • Frage

  • Hi,

    Ich habe mir nun vor wenigen Tagen auch Windows 7 Professional (von MSDNAA) auf meinen Rechnern installiert. Mein Problem ist nun, dass ich überall im Internet gelesen habe, dass Aero Glass auch über den Remotedesktop verfügbar sein soll, falls auf beiden Rechner 7 oder auf beiden Vista läuft (unter bestimmten Umständen sogar mit Server08 rc2)...
    Bei mir ist das, obwohl ich 32bit Farbtiefe eingestellt habe, alle Häckchen zur Leistung gesetzt habe und auch die Geschwindigkeit auf Lan gestellt habe, leider nicht der Fall. Mir wird nur Windows Basic in dem Hellblau angezeigt.
    Auf beiden PCs sind die neuesten Grafiktreiber installiert und auch Aero ist aktiviert und funktioniert. Nur eben per Remotedesktop nicht.

    Konfigurationen:

    PC1 (auf den connectet werden soll):
    - NVIDIA GeForce 6800GS 256MB
    - Athlon X2 3800+
    - Windows 7 x86 Professional (32bit)
    - 1GB DDR1 RAM

    PC2 (auf dem der RDP angezeigt werden soll):
    - Radeon Mobility 4650 HD 512MB
    - Intel C2D P8800
    - Windows 7 x64 Professional (64bit)
    - 4GB DDR3 RAM

    Kann man Aero-Glass irgendwie erzwingen? Per Reg-Hack oder sowas? Kann ich zumindest irgendwie für das Hellblaue Basic Design die Farbe ändern? Über den normalen weg (über Themes) geht das nämlich nicht im RDP... Wenn ich im RDP in die Systemsteuerung gehe und dort unter Themes schaue wird mir außerdem folgender Satz angezeigt: "Mindest ein Design wurde durch die Einstellungen der Remotedesktopverbindung deaktiviert." Welche Einstellung soll das sein wenn ich doch alle Einstellungen angeschaltet habe??

    Für Anregungen und Hilfe wäre ich sehr dankbar.

    MFG

    merless

    Donnerstag, 20. August 2009 20:38

Alle Antworten

  • Noch keiner versucht???

    Dienstag, 25. August 2009 17:11
  • Hallo merless

    funktioniert es vom anderen Computer aus?

    gibt es irgendwelche Fehlermeldungen im Ereignisprotokoll?

    Gruß
    Andrei

    Montag, 31. August 2009 11:18
    Moderator
  • Hallo Andrei,

    Danke für deine Antwort.
    Nein, habe es gerade mal ausprobiert, es funktioniert auch andersherum nicht. Im Ereignisprotokoll wird auf beiden PCs folgender Fehler im Ereignisprotokoll aufgeführt

    "Der Desktopfenster-Manager konnte nicht gestartet werden, da der Remoteclient kein Remoting der Desktopzusammenstellung unterstützt."

    Hast du die Möglichkeit das Ganze selbst mal zu probieren?

    Greetz
    Donnerstag, 3. September 2009 20:17
  • Hallo

    ja, habe das gerade mit 2 Windows 7 (nVidia Quadro NVS 160M) getestet und Aero funktioniert.

    ich würde auf die ATI Treiber tippen, da ATI noch keinen Support für Windows 7 anbietet und die Treiber wahrscheinlich immer noch die Vista Treiber sind. Hast du die Möglichkeit von einem anderen Computer aus zu testen?

    Gruß
    Andrei
    Freitag, 4. September 2009 08:48
    Moderator
  • http://blogs.msdn.com/rds/archive/2009/06/23/aero-glass-remoting-in-windows-server-2008-r2.aspx#9889456

    "Aero glass remoting is supported on the remote desktop host if it is Windows 7 Client Ultimate or Enterprise edition, or Windows 2008 Server R2 Standard, Enterprise or DataCenter edition."

    Das Verhalten scheint also kein Bug zu sein. Hab leider auch noch keine Lösung gefunden es mit Windows 7 Professional als Host aktiviert zu bekommen.
    Freitag, 4. September 2009 13:29
  • Hallo nochmal,

    Ich hab leider im Moment nicht die Möglichkeit es an noch einem anderen, dritten Computer zu testen. Aber beide Fehlerursachen klingen logisch. Dann muss ich wohl einfach abwarten, ob es doch noch irgendwann funktioniert, mit neuen Treibern und / oder neuen Windows Updates. Die Ati-Treiber sind aber, zumindest laut Downloadliste Windows 7 Mobility Treiber. Ich habe jetzt aber auch noch irgendwo gelesen, dass man für das Feature über RDP wohl auf beiden Rechnern mindestens 512MB Grafikspeicher braucht und das ist ja leider nicht der Fall bei mir. Vielleicht ist auch das der Fehler.
    Trotzdem danke an euch zwei.

    Grüße
    Freitag, 4. September 2009 14:41
  • Hi!

    Auch wenn der Thread schon etwas älter ist hier ein kleiner Tipp der bei mir zum Erfolg führte:

     

    - Installiert einen VNC Server (z.B. UltraVNC) nach dem ihr alle Einstellung zum Aktivieren der Desktop Effekte getroffen habt

    - Deaktiviert bei der Benutzeranmeldung STRG+ALT+ENTF, das verhinderte bei mir aufgrund eines Bugs die Anmeldung

    - Schaltet euch auf den Server und aktiviert das Theme, deaktivert dann wieder die VNC Verbindung

    - Klinkt euch jetzt via RDP mit aktiver Option für Desktopeffekte auf dem Server ein

     

    Und siehe da die Effekte sind trotz der Meldung aktiv. Es kann sogar der Wallpaper und die Fensterrahmenfarbe verändert werden. Übrigens das funktionerte auch obwohl ich via einer Windows 7 Pro Version auf den Server zugegriffen habe.

     

    Viel Erfolg!


    • Als Antwort vorgeschlagen FlyCron Dienstag, 20. September 2011 16:50
    • Bearbeitet FlyCron Dienstag, 20. September 2011 16:51
    Dienstag, 20. September 2011 16:50
  • Hatte grade das selbe Problem, mit einem WHS2011 und fand inzwischen Folgendes

    http://technet.microsoft.com/de-de/library/dd759195.aspx


    Zum manuellen Konfigurieren der Desktopgestaltung auf einem Server mit dem Host für Remotedesktopsitzungen ist Folgendes erforderlich:

    • Installieren des Features Desktop Experience.

    • Starten des Design-Diensts.

    • Aktivieren der Gruppenrichtlinieneinstellung Desktopgestaltung für Remotedesktopsitzung zulassen.

    • Festlegen der maximalen Farbtiefe auf 32 Bits pro Pixel.


    Aber das Einzige, was letztendlich funktionierte:

    • Neuen Benutzer erstellen, als Administrator
    • Als diesen Benutzer anmelden (damit die Benutzereinstellungen erstellt werden)
    • Dann wieder als Administrator anmelden und die Rollen dieses Benutzers Ändern.
    • (Admin-Gruppe entfernen / Benutzer-Gruppe und Remotedesktop-Gruppe hinzufügen)
    • Als Antwort vorgeschlagen Guido Over Dienstag, 13. März 2012 07:26
    Montag, 12. März 2012 22:59
  • Verzeiht die frage wieso sollte man via Remote Desktop "Glas" haben wollen?
    Dienstag, 13. März 2012 08:38
  • Zumindest das Desktoptheme kannst du auf Vista/2008+ wieder einschalten:

    nachdem du per RDP verbunden bist, diesen Regeintrag(in der RDP-Session) löschen:

    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\ThemeManager\Remote


    (komplett mit unterschlüsseln)

    evtl. über .reg-Datei

    Windows Registry Editor Version 5.00
    [-HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\ThemeManager\Remote]

    dann über Designs:

    control desk.cpl,,@themes

    ein anderes auswählen

    ref:

    http://www.win2008workstation.com/forum/viewtopic.php?p=4150#p4150


    Donnerstag, 20. März 2014 11:50