none
Server 2012 r2 braucht extrem viel RAM (DNS)? RRS feed

  • Frage

  • Hallo,

    haben zwei DCs 2012 r2 (aktuellste Patches) einen virtuellen und einen physikalischen Server, laufen schon seit über einem Jahr.

    Sei kurzem braucht der physikalische Server DC01 immer mehr RAM bzw. er läuft voll, bis der Server keinen RAM mehr hat. Man sieht zwar nicht ob es der DNS Server ist aber dies ist der einzige Dienst der viel RAM (400Mb) benötigt. Habe schon den ganzen Tag versucht dieses Problem zu lösen, leider ohne Erfolg.

    Hat jemand einen Tipp?

    Schöne Grüße

    Donnerstag, 17. März 2016 14:18

Antworten

Alle Antworten

  • Moin,

    was soll der Server sonst mit dem Speicher machen? Speicher ist dazu da, benutzt zu werden.

    Gibt es akute Probleme, Abstürze, etc.?


    This posting is provided AS IS with no warranties.

    Donnerstag, 17. März 2016 17:47
  • Hallo,

    wie oben schon geschrieben der Server nimmt sich den Arbeitsspeicher in sekundentakt, 
    alle ca. 5 Sekunden wird der freie Arbeitsspeicher um (ca. 2 MB) weniger.

    Bis dass man keinen freien Speicher zur Verfügung mehr hat und dann kann man sich eh vorstellen, was mit dem Server los ist.

    Donnerstag, 17. März 2016 18:13
  • Hallo,

    zuerst einmal würde ich gerne wissen wie viel Speicher denn der DC hat.

    Auf einem DC laufen normalerweise deutlich mehr Dienste als nur der DNS Server Dienst.

    Welcher Prozess hat den wie viel Speicher in Benutzung

    Infos dazu findet man im ressourcenmonitor oder mit dem Powershell Befehl get-process

    Gruß Benjamin


    Benjamin Hoch
    MCSE: Data Platform
    MCSA: Windows Server 2012
    Blog

    Donnerstag, 17. März 2016 19:10
  • Hallo,

    der DC hat 16GB RAM und die laufen mit der Zeit voll. Habe einen Virenscanner schon darüber laufen lassen, nichts gefunden. Anbei habe ich zwei Screenshots, es ist extrem eigenartige Situation.

    Der Server hat schon wieder den ganzen RAM verbraucht.

    Donnerstag, 17. März 2016 20:37
  • Wenn der DNS 400 MB von den 14700 MB Ram belegt, dann kann dieser nicht das Problem sein.

    Schau dir mal die tatsächliche RAM Belegung im Ressourcenmontior an, dort sollte sich ein anderes Bild ergeben.

    Ich frage mich aber warum auf dem Server so derart viele Prozesse des Virenscanner laufen.

    Gruß Benjamin


    Benjamin Hoch
    MCSE: Data Platform
    MCSA: Windows Server 2012
    Blog

    Donnerstag, 17. März 2016 20:47
  • Was für Rollen sind auf dem Server installiert? Hyper-V?

    This posting is provided AS IS with no warranties.

    Donnerstag, 17. März 2016 21:14
  • Hallo leider sieht man im Ressourcenmonitor auch nichts wohin der RAM verschwindet, dies ist ja das Eigenartige. Habe schon mit dem Prozessmonitor auch darüber gesehen finde einfach nicht wohin der RAM verschwindet?
    Donnerstag, 17. März 2016 21:16
  • Hallo,

    auf dem Server sind folgenden Rollen installiert,

    AD DS
    Datei/Speicherdienste
    DNS

    des war es und es ist nichts neues installiert worden.

    Schöne Grüße

    Freitag, 18. März 2016 05:58
  • Du könntest mal mit dem Process Explorer von sysinternals versuchen weitere Informationen über die laufenden Prozesse zu bekommen.

    https://technet.microsoft.com/de-de/sysinternals/bb842062.aspx



    This posting is provided AS IS with no warranties.

    • Als Antwort vorgeschlagen Benjamin.Hoch Freitag, 18. März 2016 09:07
    Freitag, 18. März 2016 08:33
  • Hallo,

    habe ich auch schon gemacht, man findet gar nichts was irgendwie hohen RAM verbraucht.

    Freitag, 18. März 2016 08:42
  • Da es schwer ist die Ursache zu beseitigen wenn man das Problem nicht eingrenzen kann sehe ich jetzt drei Möglichkeiten.

    Supportfall bei Microsoft aufmachen,

    Einen Spezialisten (Berater/Consultant) holen, der vor Ort nachsieht,

    Server platt machen und neu aufbauen,


    Benjamin Hoch
    MCSE: Data Platform
    MCSA: Windows Server 2012
    Blog

    • Als Antwort vorgeschlagen Benjamin.Hoch Freitag, 18. März 2016 09:08
    Freitag, 18. März 2016 08:49
  • Hallo,

    werden jetzt einen neuen DC hochziehen und dann den alten DC löschen.

    Es ist echt extrem eigenartig, sowas hab ich noch nie gesehen und gehabt.

    Freitag, 18. März 2016 09:02
  • etwas wurde jetzt gefunden, der svchost darunter befindet sich der NSI Dienst und dieser scheint das Problem zu verursachen. Mal weitersuchen ob man des Problem noch genauer eingrenzen kann.
    Freitag, 18. März 2016 10:42
  • Hallo,

    nach der Neuinstallation des DCs hatten wir wieder das gleiche Problem, habe mir nochmals mit dem ProcessExplorer die Saxhe genauer angesehen und bin darauf gekommen, dass die RemoteRegistrierung die Schuld war.

    Bind dann auf den Forumeintrag http://www.mcseboard.de/topic/206721-ad-domain-controller-dfs-namespace-memory-leak/ gestoßen und jetzt haben wir eine Lösung:-)!

    Schöne grüße

    • Als Antwort markiert net-com Dienstag, 22. März 2016 11:50
    Dienstag, 22. März 2016 11:50