none
Excel 2010: AddIN werden nicht immer geladen RRS feed

  • Frage

  • Hallo Leute,

    ich habe für unsere Kanzlei ein AddIn erstellt, welches beim Excel-Start immer geladen werden soll. Starte ich die Programmverbindung direkt, funktioniert das auch einwandfrei. Möchte ich aber aus dem Explorer eine Excel-Datei per Doppelklick öffnen, so wird das AddIN nicht geladen.

    Das Pfad zum AddIn lautet: C:\Users\66\AppData\Roaming\Microsoft\AddIns\Ribbon.xlam

    Erkennbar ist es daran, dass kein individueller Ribbon-Reiter erstellt wird.

    Das AddIn wird aber als geladen markiert (Reiter Entwickelertools -> AddIn: X Ribbon)

    Erst wenn ich den Haken herausnehme und speichere und wieder neu setze, wird das AddIn jetzt richtig geladen. Das ist aber total nervig.

     

    Öffne ich die Datei aber über ein Batchbefehl, so wird mein AddIn wieder richtig geladen.

    Beispiel:

    "C:\Program Files (x86)\Microsoft Office\Office14\EXCEL.EXE" "\\server2010\stammdaten\111\11126\14 = Jahresabschluss\Kto.Aufstellungen.xlsx"
    

    Hat einer schon einmal das gleiche Problem gehabt und gibt es hierfür eine Lösung?

    Danke schon einmal im voraus.

    Gruß Ahmed

    Freitag, 7. Januar 2011 14:05

Antworten

  • Hallo Leute,

    das Problem hat sich erledigt. Der Fehler lag daran, dass in einem VB6-Programm noch eine Instanz im Hintergrund offen war. Aus diesem Grunde ist der Aufruf fehlgeschlagen, da das Öffnen einer Datei in der gleichen Excel-Instanz erfolgte.

    Durch den Batch-Aufruf erzwinge ich aber eine neue Instanz, so dass auch die AddIn's richtig geladen werden. Beim Beenden des VB6-Programmes wird die unsichtbare Instanz sauber geschlossen. Aus diesem Grunde betrachte ich mein Problem als erledigt.

    Gruß Ahmed

    • Als Antwort markiert Ahmed Martens Mittwoch, 19. Januar 2011 13:52
    Mittwoch, 19. Januar 2011 13:51