none
Warten auf Benutzerprofildienst... RRS feed

  • Allgemeine Diskussion

  • Hallo zusammen,

    Ich habe seit einiger Zeit das Problem, dass der Benutzerprofiledienst bei den Domaincontrollern Probleme beim Anmelden verursacht. Die DCs laufen unter Server 2008 non R2, aktueller Patchstand.

    In unregelmäßigen Abständen hängt einer der beiden DCs beim anmelden über RDP oder lokal bei "Warten auf Benutzerprofildienst" fest. Das Eventlog sieht nachdem ich den DC neugestartet habe folgendermaßen aus:

    http://i50.tinypic.com/n6rl8z.png

    Auf den DCs wird lediglich ein VBScript beim Anmelden ausgeführt was eine Freigabe einbindet. Es sind auch nur die beiden DCs von dem Problem betroffen, bei anderen Windowsservern ist das Problem noch nie aufgefallen.

    Ansonsten wurde an der Konfiguration der DCs nichts geändert, keine neuen Rollen hinzugefügt etc.

    Bisher stehe ich bei diesem Problem echt auf dem Schlauch. Hoffe Ihr habt noch ein paar Tips wo ich nachschauen kann.

    Danke und Grüße

    Michael

    Donnerstag, 22. November 2012 10:25

Alle Antworten

  •  
     Schön, nur ist das ohne die Event-Details nicht sehr aussagefähig... Ich
    würde allen Warnungen und Fehlern nachgehen und die Stück für Stück beheben.
     

    NO THEY ARE NOT EVIL, if you know what you are doing: Good or bad GPOs?
    Wenn meine Antwort hilfreich war, freue ich mich über eine Bewertung! If my answer was helpful, I'm glad about a rating!
    Donnerstag, 22. November 2012 11:30
  • Am 22.11.2012 schrieb Michael-TG:

    In unregelmäßigen Abständen hängt einer der beiden DCs beim anmelden über RDP oder lokal bei "Warten auf Benutzerprofildienst" fest. Das Eventlog sieht nachdem ich den DC neugestartet habe folgendermaßen aus:

    http://i50.tinypic.com/n6rl8z.png

    GPO-FAQ No. 36 setzen, beide Einstellungen.
    http://www.gruppenrichtlinien.de/Grundlagen/faq.htm Wenn das nichts
    hilft, die Profile auf dem Server löschen und neu anlegen lassen.

    Auf den DCs wird lediglich ein VBScript beim Anmelden ausgeführt was eine Freigabe einbindet. Es sind auch nur die beiden DCs von dem Problem betroffen, bei anderen Windowsservern ist das Problem noch nie aufgefallen.

    Weshalb denn ein VB-Script? Versuch es doch per Group Policy
    Preferences.

    Servus
    Winfried


    Connect2WSUS: http://www.grurili.de/tools/Connect2WSUS.exe
    GPO's: http://www.gruppenrichtlinien.de
    Community Forums NNTP Bridge: http://communitybridge.codeplex.com/

    Donnerstag, 22. November 2012 17:12
  • Erstmal danke für die Antworten.

    @Martin

    Da bin ich gerade dabei die Fehler im Eventlog zu beheben, gestern ist mir noch aufgefallen das die Automatische Defragmentierung noch aktiviert war (Mittwochs um 1:00).

    Desweitern habe ich heute noch diverse Ausschlüsse für denn Virenscanner konfiguriert. (http://support.microsoft.com/kb/822158/de)

    @Winfried

    Diese beiden Policies sind schon bei mir aktiviert. Stimmt ich hätte das Netzlaufwerkmapping auch via GPP machen können, aber ich habe das VBScript auch schon testweise mal deaktivert aber der Fehler ist trotzdem aufgetreten. Also kann ich das zumindest als Fehlerquellle ausschließen.

    Grüße

    Michael

    Freitag, 23. November 2012 07:35
  • Am 23.11.2012 schrieb Michael-TG:

    @Winfried

    Diese beiden Policies sind schon bei mir aktiviert. Stimmt ich hätte das Netzlaufwerkmapping auch via GPP machen können, aber ich habe das VBScript auch schon testweise mal deaktivert aber der Fehler ist trotzdem aufgetreten. Also kann ich das zumindest als Fehlerquellle ausschließen.

    Und was ist mit Profil löschen oder zumindest umbenennen?

    Servus
    Winfried


    Connect2WSUS: http://www.grurili.de/tools/Connect2WSUS.exe
    GPO's: http://www.gruppenrichtlinien.de
    Community Forums NNTP Bridge: http://communitybridge.codeplex.com/

    Freitag, 23. November 2012 15:00
  • Hallo zusammen,

    @Winfried, Das mit dem Profil habe ich noch nicht getestet, werde ich aber heute nachholen.

    @Alle anderen, Sieht schlecht aus, der DC hat sich Samstag Morgen um 3:08 neugestartet. Das Event um 3:08:23 zeigt die Fehlermeldung im Screenshot

    http://i46.tinypic.com/351yhwm.png

    Aus Gründen die ich mir nicht erklären kann crasht die lsass.exe weg.

    Um 3:08:30, ein Event später gibt es folgende Meldung: "Ein kritischer Systemprozess C:\Windows\system32\lsass.exe ist fehlgeschlagen mit den Statuscode 255. Der Computer muss neu gestartet werden."

    Ich habe nochmals nachgeschaut ob um diese Urzeit irgendwas per Aufgabenplanung angestoßen wird, Fehlanzeige.

    "SFC /Verifynow" hat nichts ergeben. Auch ein Minidump ist nicht erstellt worden.

    Langsam gehen mir echt die Ideen aus.

    Grüße

    Michael

    Montag, 26. November 2012 09:51
  • Am 26.11.2012 schrieb Michael-TG:

    @Winfried, Das mit dem Profil habe ich noch nicht getestet, werde ich aber heute nachholen.

    Heute geht zwar noch gut 3 Stunden, aber evt. hast Du es ja schon
    testen können.

    @Alle anderen, Sieht schlecht aus, der DC hat sich Samstag Morgen um 3:08 neugestartet. Das Event um 3:08:23 zeigt die Fehlermeldung im Screenshot


    http://i46.tinypic.com/351yhwm.png

    Aus Gründen die ich mir nicht erklären kann crasht die lsass.exe weg.

    Um 3:08:30, ein Event später gibt es folgende Meldung: "Ein kritischer Systemprozess C:\Windows\system32\lsass.exe ist fehlgeschlagen mit den Statuscode 255. Der Computer muss neu gestartet werden."

    Welche Dienst bietet der DC sonst noch an?

    Ich habe nochmals nachgeschaut ob um diese Urzeit irgendwas per Aufgabenplanung angestoßen wird, Fehlanzeige.

    Auch keine Datensicherung mit einem 3rd Party Produkt?

    "SFC /Verifynow" hat nichts ergeben. Auch ein Minidump ist nicht erstellt worden.

    Wenn es nur ein DC ist, solltest Du über eine Neuinstallation
    nachdenken.

    Servus
    Winfried


    Connect2WSUS: http://www.grurili.de/tools/Connect2WSUS.exe
    GPO's: http://www.gruppenrichtlinien.de
    Community Forums NNTP Bridge: http://communitybridge.codeplex.com/

    Montag, 26. November 2012 20:01
  • @Winfried,

    Der DC der zurzeit von dem Problem betroffen ist arbeitet noch als DHCP Server.

    Eine Datensicherung findet mit HP Dataprotector statt (Disk Agent V 6.11), diese habe ich aber letzte Woche Freitag schon deaktivert. Kann also als Fehlerursache auch ausgeschlossen werden.

    Das Profil habe ich jetzt auch mal gelöscht, mal sehen ob es was bringt.

    Grüße

    Michael

    Dienstag, 27. November 2012 09:26