none
Exchange 2010// Abwesenheitsnotiz und Autodiscover funktioniert nicht bzw. nur teilweise. RRS feed

  • Frage

  • Hallo alle zusammen,

    In unserer Umgebung funktionieren die Abwesenheitsnotizen nur teilweise und die E-Mail Autokonfiguration läuft mit Fehlern durch.

    Vorab die Systeminformationen:

    Windows Server 2008 R x64

    Exchange 2010 Version 14.3 (Build 123.4)

    Clients nutzen Outlook 2010/2013

    Alle aktuellen Windows Updates sind installiert.

    Abwesenheitsnotizen

    Die Abwesenheitsnotizen funktionieren unter Outlook nur bei wenigen z.b. bei mir, wobei ich noch nicht habe aus machen können was mich von den anderen Usern unterscheidet, abgesehen von den Exchange-Administratorenrechte. An meinem Client kann es auch nicht liegen, da ich schon mehrere Postfächer auf meinem Client verbunden habe - selbes Problem - Outlook meldet: "Ihre Einstellungen für automatische Antworten können nicht angezeigt werden, da der Server zurzeit nicht verfügbar ist. Versuchen Sie es später erneut."

    Über OWA lassen sich die Abwesenheitsnotiz generell, bei jedem User, nutzen.

    Autodiscover

    folgende Fehler bekomme ich beim ausführen der E-Mail Autokonfiguration...

    AutoErmittlung für https://owa.haberbeck.de/autodiscover/autodiscover.xml Fehlgeschlagen (0x80004005)

    AutoErmittlung für https://haberbeck.de/autodiscover/autodiscover.xml Fehlgeschlagen (0x80004005)

    AutoErmittlung für https://autodiscover.haberbeck.de/autodiscover/autodiscover.xml Fehlgeschlagen (0x80004005)

    Lokale AutoErmittlung für haberbeck.de Fehlgeschlagen (0x8004010F)

    Diensteintragssuche für https://autodiscover.haberbeck.de/autodiscover/autodiscover.xml Fehlgeschlagen (0x80004005)

    AutoErmittlung für https://owa.haberbeck.de/autodiscover/autodiscover.xml Fehlgeschlagen (0x80004005)

    Diensteintragsuche für haberbeck.de Fehlgeschlagen (0x80004005)

    Das AutodisoverVirtualDirectory habe ich erneuert.

    Remove-AutoDiscoverVirtualDirectory -Identity "srv-mail-001\Autodiscover (Default Web Site)"

    New-AutodiscoverVirtualDirectory -WebsiteName "Default Web Site" -BasicAuthentication $true -WindowsAuthentication $true

    Set-AutodiscoverVirtualDirectory -Identity * –internalurl “https://owa.haberbeck.de/autodiscover/autodiscover.xml”

    Wenn man die Seite “https://owa.haberbeck.de/autodiscover/autodiscover.xml” aufruft, bekommt man die Meldung "Serverfehler in der Anwendung /Autodiscover." angezeigt, testet es am besten selbst.

    Die restlichen Verzeichnisse habe ich dementsprechend angepasst...

    Set-ClientAccessServer –Identity * –AutodiscoverServiceInternalUri “$urlpath/autodiscover/autodiscover.xml”
    Set-webservicesvirtualdirectory –Identity * –internalurl “$urlpath/ews/exchange.asmx”
    Set-oabvirtualdirectory –Identity * –internalurl “$urlpath/oab”
    Set-owavirtualdirectory –Identity * –internalurl “$urlpath/owa”
    Set-ecpvirtualdirectory –Identity * –internalurl “$urlpath/ecp”

    Unser Zertifikat habe ich für https://owa.haberbeck.de ausstellen lassen und eingebunden.

    Im DNS habe ich die folgenden Einträge...

    Unter Haberbeck.de -> _TCP -> SRV-Eintrag: _Autodiscover (Domäne:haberbeck.de ; Dienst: _Autodiscover; Protokoll: _TCP; Portnummer: 443; Host der diesen Dienst anbietet: owa.haberbeck.de)

    Unter unserer lokalen Domäne haberbeck.local -> Alias (CNAME) -> Aliasname: autodiscover ; dieser eintrag zeigt auf unserern Exchange Server.

    ->Alias (CNAME) ->Aliasname: owa; dieser eintrag zeigt auf unserern Exchange Server.

    Was für Informationen fehlen euch?

    Vielen Dank im Vorraus für die Hilfe.

    Den

    Montag, 20. Oktober 2014 09:11

Antworten

  • Hi,

    die Fehlermeldung 0x80004005 bedeutet "Zugriff verweigert". Schau doch mal nach, ob an den Berechtigungen für das virtuelle Verzeichnis irgendwas verstellt ist.

    Wenn Du die Autodiscover-URL manuell aufrufst, musst Du eine Seite mit XML-Code und der Fehlermeldung 600 "Ungültige Anforderung" (o.ä.) bekommen. Alles andere deutet auf eine Fehlkonfiguration hin. Ein Serverfehler darf da jedenfalls nicht kommen.

    Die DNS-Einträge sollten so passen. Bei den PowerShell-Befehlen hast Du hoffentlich die Variable $urlpath irgendwo vorher deklariert? ;-)


    Gruß

    Ben

    MCITP Windows 7

    Wenn Dir meine Antwort hilft, markiere sie bitte entsprechend als Antwort! Danke! :-)

    Hinweis: Meine Posts werden "wie besehen" ohne jedwede Gewähr bereitgestellt, da menschliche, technische und andere Fehler nicht ausgeschlossen werden können.

    • Als Antwort markiert Den_admin Dienstag, 21. Oktober 2014 12:58
    Montag, 20. Oktober 2014 10:50
  • Problem gelöst!!!!! Danke Sehr euch beiden!

    letztendlich lag es vermutlich daran....

    -IIS Berechtigungen waren nicht korrekt gesetzt - angepasst nach dieser Anleitung http://www.frankysweb.de/exchange-2010-virtuelle-verzeichnisse-im-iis/

    -Temp-Verzeichnisse von .NET gelöscht (http://www.aspnetzone.de/forums/thread/217700.aspx )

    Je nach Betriebssystem

    • C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files\ (Windows XP)
    • C:\Users\[username]\AppData\Local\Temp\Temporary ASP.NET Files\ (Windows 7)
    • C:\WINDOWS\Microsoft.NET\Framework64\v2.0.50727\Temporary ASP.NET Files\ (64 bit)

    • Als Antwort markiert Den_admin Dienstag, 21. Oktober 2014 12:57
    Dienstag, 21. Oktober 2014 12:57

Alle Antworten

  • Hi,

    die Fehlermeldung 0x80004005 bedeutet "Zugriff verweigert". Schau doch mal nach, ob an den Berechtigungen für das virtuelle Verzeichnis irgendwas verstellt ist.

    Wenn Du die Autodiscover-URL manuell aufrufst, musst Du eine Seite mit XML-Code und der Fehlermeldung 600 "Ungültige Anforderung" (o.ä.) bekommen. Alles andere deutet auf eine Fehlkonfiguration hin. Ein Serverfehler darf da jedenfalls nicht kommen.

    Die DNS-Einträge sollten so passen. Bei den PowerShell-Befehlen hast Du hoffentlich die Variable $urlpath irgendwo vorher deklariert? ;-)


    Gruß

    Ben

    MCITP Windows 7

    Wenn Dir meine Antwort hilft, markiere sie bitte entsprechend als Antwort! Danke! :-)

    Hinweis: Meine Posts werden "wie besehen" ohne jedwede Gewähr bereitgestellt, da menschliche, technische und andere Fehler nicht ausgeschlossen werden können.

    • Als Antwort markiert Den_admin Dienstag, 21. Oktober 2014 12:58
    Montag, 20. Oktober 2014 10:50
  • Hi Ben,

    Danke erstmal für die schnelle korrespondenz.

    Die Berechtigungen für das virtuelle Verzeichnis habe ich nach dieser "Anleitung" ( http://www.frankysweb.de/exchange-2010-virtuelle-verzeichnisse-im-iis/ ) angepasst, leider ohne Erfolg. 

    Sprich bei der Autokonfiguration kommen immer noch dieselben Fehler....

    Ja, den Platzhalter "$urlpath" habe ich jeweils durch "https://owa.haberbeck.de" ersetzt. ^^

    Hast du vielleicht noch eine Idee, wo ich schauen kann?

    Gruß

    Den


    Montag, 20. Oktober 2014 13:58
  • Hi,

    es könnte noch ein clientseitiges Problem sein:

    http://blogs.msdn.com/b/anthonw/archive/2012/03/21/autodiscover-xml-failed-0x80004005-and-bpos.aspx

    Hast Du nach der Konfiguration des virtuellen Verzeichnisses ein "iisreset" gemacht?

    Kannst Du den CNAME anpingen? (also "ping autodiscover.haberbeck.local").

    Wo ich jetzt persönlich nicht so drin stecke, aber was Du probieren könntest: entferne den CNAME, mW sollte entweder SRV oder CNAME reichen (nicht beides, vor allen Dingen ist der CNAME (haberbeck.local) anders als der SRV (haberbeck.de)).


    Gruß

    Ben

    MCITP Windows 7

    Wenn Dir meine Antwort hilft, markiere sie bitte entsprechend als Antwort! Danke! :-)

    Hinweis: Meine Posts werden "wie besehen" ohne jedwede Gewähr bereitgestellt, da menschliche, technische und andere Fehler nicht ausgeschlossen werden können.

    Montag, 20. Oktober 2014 14:26
  • Kannst du mit Fiddler mal den Aufruf "tracen".  Evt gibt es da noch irgendwelche Infos?
    Montag, 20. Oktober 2014 17:54
  • @Ben: Die Registry-Pfade für die Clientseitige Problemlösung habe ich gecheckt. - OK

    Den IIS-Reset habe ich abschließend durchgeführt.

    CNAME lässt sich anpingen.

    Im Prinzip sollte es kein Rolle Spielen ob beide (CNAME und SRV-Eintrag) vorhanden sind, der CNAME zeigt ja nur auf den Mailserver... oder sehe ich das falsch (?!)

    Wenn ich nun versuche die Seite  https://owa.haberbeck.de/autodisover/autodiscover.xml von intern aufzurufen bekomme ich folgende Meldung ->

    "Serverfehler

    404 - Datei oder Verzeichnis wurde nicht gefunden."

    von Extern bekomme ich immer noch die meldung: "serverfehler in der anwendung /autodiscover. "

    @Jörg: Fiddler sagt mir im Header beim Zugriff auf   https://owa.haberbeck.de/autodisover/autodiscover.xml -> HTTP/1.1 500 Internal Server Error  



    • Bearbeitet Den_admin Dienstag, 21. Oktober 2014 09:59
    Dienstag, 21. Oktober 2014 09:52
  • Wenn Du owa.haberbeck.de anpingst, wird da die interne IP des Exchange-Servers aufgelöst? 

    Oben im Link hast Du übrigens noch einen Fehler drin, das muss .../autodiscover/..., nicht .../autodisover/... heißen. Hoffentlich hast Du das nicht so eingerichtet... ;-)

    Ist das virtuelle Verzeichnis im IIS vorhanden? 404 heißt eigentlich "nein".


    Gruß

    Ben

    MCITP Windows 7

    Wenn Dir meine Antwort hilft, markiere sie bitte entsprechend als Antwort! Danke! :-)

    Hinweis: Meine Posts werden "wie besehen" ohne jedwede Gewähr bereitgestellt, da menschliche, technische und andere Fehler nicht ausgeschlossen werden können.

    Dienstag, 21. Oktober 2014 10:16
  • Wenn das nur ein "Schreibfehler" bzgl. Autodiscover hier im Forum war, hast du zufällig einen HTTP-Redirect im IIS konfiguriert? 

    Grüße

    Jörg

    Dienstag, 21. Oktober 2014 10:35
  • Der Exchange ist Virtuell aufgesetzt und hat 2 IP-Adressen 172.16.34.7 und 172.16.34.8 (das hätte ich vorher erwähnen sollen- sorry). Wenn ich "owa.haberbeck.de" anpinge wird immer eine der IP-Adressen erreicht. für die 172.16.34.8 ist ein redirect eingerichtet - wobei ich nicht weiß weswegen. 

    Die IP 172.16.34.8:80 wird auf das Verzeichnis "c:\inetpub\autodiscover" umgeleitet.(ich deaktiviere die Umleitung erstmal)

    Die Virtuellen Verzeichnisse sind vorhanden und lassen sich aufrufen.

    Das war ein Tippfehler, die Seite https://owa.haberbeck.de/autodiscover/autodiscover.xml lässt sich weiterhin mit  der Meldung "serverfehler in der anwendung /autodiscover. " aufrufen

    Bindungen der Default Web Site:

    https    443   172.16.34.8

    https    443   172.16.34.7

    https    443   127.0.0.1

    http       80   127.0.0.1




    • Bearbeitet Den_admin Dienstag, 21. Oktober 2014 12:09
    Dienstag, 21. Oktober 2014 11:51
  • Problem gelöst!!!!! Danke Sehr euch beiden!

    letztendlich lag es vermutlich daran....

    -IIS Berechtigungen waren nicht korrekt gesetzt - angepasst nach dieser Anleitung http://www.frankysweb.de/exchange-2010-virtuelle-verzeichnisse-im-iis/

    -Temp-Verzeichnisse von .NET gelöscht (http://www.aspnetzone.de/forums/thread/217700.aspx )

    Je nach Betriebssystem

    • C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files\ (Windows XP)
    • C:\Users\[username]\AppData\Local\Temp\Temporary ASP.NET Files\ (Windows 7)
    • C:\WINDOWS\Microsoft.NET\Framework64\v2.0.50727\Temporary ASP.NET Files\ (64 bit)

    • Als Antwort markiert Den_admin Dienstag, 21. Oktober 2014 12:57
    Dienstag, 21. Oktober 2014 12:57
  • Super, danke für die Rückmeldung!

    Gruß

    Ben

    MCITP Windows 7

    Wenn Dir meine Antwort hilft, markiere sie bitte entsprechend als Antwort! Danke! :-)

    Hinweis: Meine Posts werden "wie besehen" ohne jedwede Gewähr bereitgestellt, da menschliche, technische und andere Fehler nicht ausgeschlossen werden können.

    Mittwoch, 22. Oktober 2014 06:54