none
Ändern Netzwerkprofil RRS feed

  • Allgemeine Diskussion

  • Ich habe eine Server 2012 installiert. Die Netzwerkkarte ist aktuell auf DHCP eingestellt und bekommt auch eine IP vom 2008 DHCP mit korrekter IP und Gateway. Der PC ist in einer Arbeitsgruppe. Auf dem 2012 ist im Netzwerk-Freigabecenter "xyz.local" - Öffentliches Netzwerk erkannt - das ist falsch, es müsste Privat sein. Laut allen MS-Dokus die ich gefunden habe, erkennt ein Server den Netzwerktyp über NLA und berücksichtigt dabei, ob eine GW ins Internet gefunden wird. Hier wird sie gefunden, unter Netzwerktyp steht "Internet".

    Warum wird der Netzwerktyp trotzdem falsch erkannt? Bzw. wie kann man den Typ manuell umstellen?

    H.Kistner

    Mittwoch, 9. Januar 2013 19:59

Alle Antworten

  • Hällo,

    du kannst den Netzwerktyp beispielsweise mittels Registry-Eintrag ändern. Siehe hierzu: http://social.technet.microsoft.com/Forums/en-US/winservercore/thread/89714024-b5a9-4ac6-bd83-d485a8d5f5ce

    Alternativ geht es auch per Powershell: http://blogs.msdn.com/b/powershell/archive/2009/04/03/setting-network-location-to-private.aspx

    Auf die Frage, warum das falsch erkannt wird, kann ich auch keine vernünftige Antwort geben. Bei einem Kunden hatte ich auch einen schon lange in Betrieb befindlichen Rechner, der immer im Domänen-Profil war und auch passend erkannt wurde, der ohne Änderungen am System nach einem Neustart auf einmal im öffentlichen Profil war, wo die Firewall den Zugriff dicht gemacht hat. Da war kein Zugriff mehr auf den SQL möglich. Habe es dann fest per Registry vorgegeben, seit dem ist Ruhe.


    Guido Over
    MCITP Server Administrator 2008
    MCITP Enterprise Administrator 2008
    MCSA Windows Server 2008
    MCSA Windows Server 2012

    Donnerstag, 10. Januar 2013 07:26
  • Hallo,

    danke für den Tip. Ich kann zwar in der Registry den Wert im profil von 0 auf 2 ändern, aber nach einem Neustart ist es wieder 0 und damit "öffentliches Netzwerk". Ich habe testweise auch noch den Namen des Profils im gleichen Registryzweig geändert, das übersteht den Neustart. Vermutlich trägt Win2012 den profiltyp bei jedem Neustart neu ein.

    Hat jemand eine Idee, wie man das permanent eintragen könnte?

    H.Kistner

    Dienstag, 15. Januar 2013 13:50
  • Hast du irgendwelche GPOs, die den Registry-Wert wieder umbiegen?

    Guido Over
    MCITP Server Administrator 2008
    MCITP Enterprise Administrator 2008
    MCSA Windows Server 2008
    MCSA Windows Server 2012

    Dienstag, 15. Januar 2013 13:57
  • Ich habe keinerlei GPOs erstellt. Das ist ein Server frisch installiert, bisher keine Zusatzsoftware, außer den Treibern für den HP Proliant ML110. Ich habe auch mal probiert, fixe IPs für Server / Gateway / DNS einzutragen, hilft nicht.

    Gruß,

    Holger

    Mittwoch, 16. Januar 2013 17:08
  • Hallo Alex,

    ich habe netsh int ip reset durchgeführt, nach dem Neustart dann die IP des servers und Gateway neu eingetragen - denn die war genau wie Netmask leer, nur DNS stand noch drin. Hat nicht geholfen. Dann netsh advfirewall reset, auch danach wie mein LAN als "Öffentlich" erkannt.

    Mit dieser nicht funktionierenden NLA und der Unmöglichkeit, den Typ manuell einzustellen, hat MS mal wieder einen Bock geschossen.

    Gruß,

    Holger

    Montag, 4. Februar 2013 12:40