none
Zertifikat kann nicht verlängert werden RRS feed

  • Frage

  • Hallo zusammen,

    auf einem SBS 2008 Server lässt sich das Sicherheitszertifikat vom Exchange nicht neu erstellen oder verlängern.

    Wenn man versucht dies klassisch über die SBS Konsole zumachen, wird erkannt das das Zertifikat abgelaufen ist und beim Versuch das Problem zu beheben läuft der Assistent nicht zu Ende ( Auch nicht nach mehrere Stunden).

    Ein Neustart vom Server hat leider nichts gebracht, über den IIS passiert das gleiche beim Versuch das Zertifikat zu verlängern.

    Versuche ich eine neues Zertifikat über die Powershell oder über den IIS zu erstellen, wird auch kein neues Zertifikat erstellt.

    Nachdem man beim IIS auf "Fertigstellen" klickt, läuft der Balken und es passiert weiter nichts, genauso beim Versuch über die Powershell.

    Das Betriebssystem ist auf dem aktuellsten Stand, der Exchange hat den Stand 2007 SP1 RU10.

    Hatte bereits versucht das SP3 zu installieren (Mit setup /M:Upgrade) ; allerdings bleibt dieser immer bei 99% "ClientAccess-Serverfunktion" stehen. (Auch nach mehreren Stunden)

    Im Log steht am Ende:

    [14.11.2016 19:09:32] [2] Going to remove https binding on port 443 from Default Web Site...

    [14.11.2016 19:09:35] [2] Error has been found on this box.

    [14.11.2016 19:09:35] [2] SBS certificates error found, the error is CERT_NOT_FOUND

    Vermutlich weil das Zertifikat bereits abgelaufen ist, hat noch jemand eine Idee was man versuchen könnte?

    Gruß

    Marco

    Donnerstag, 12. Januar 2017 11:51

Alle Antworten

  • Vermutlich weil das Zertifikat bereits abgelaufen ist, hat noch jemand eine Idee was man versuchen könnte?

    Moin,

    vielleicht auf die Tippel-Tappel-Tour? Nachschauen, welche Namen im abgelaufenen Zertifikat drin sind, einen Request generieren, von der CA des SBS ausstellen lassen und in Exchange aktivieren...


    Evgenij Smirnov

    I work @ msg services ag, Berlin -> http://www.msg-services.de
    I blog (in German) @ http://it-pro-berlin.de
    my stuff in PSGallery --> https://www.powershellgallery.com/profiles/it-pro-berlin.de/
    Exchange User Group, Berlin -> http://exusg.de
    Windows Server User Group, Berlin -> http://www.winsvr-berlin.de
    Mark Minasi Technical Forum, reloaded -> http://newforum.minasi.com

    Sonntag, 15. Januar 2017 10:56
  • Moin,

    beim Versuch ein Request zu generieren, passiert leider nichts, genauso wie beim Versuch das Zertifikat zu er stellen...

    Montag, 16. Januar 2017 07:14
  • Hallo,

    ich habe das Problem schon an 4 SBS 2011 Servern. Mit dem Assistenten passiert gar nichts. Wenn ich certsrv aufrufe, öffnet sich die zwar die Startseite, jedoch geht es nicht weiter.

    Ich habe dann mal gewagt, die Zertifikatsdienste zu deinstallieren und per Powershell wieder zu installieren, das ging zwar, aber der Zertifikatsdienst lässt sich nun nicht mehr starten.

    Was ist denn nur hier passiert? Liegt es an einem Microsoft Update?

    Komme hier nicht weiter.

    Gruß Mike

    Montag, 30. Januar 2017 12:37
  • Hallo,

    ich hatte auf einem SBS2008 einmal das gleiche Problem. Letztendlich konnte ich dieses Problem nur mittels Trick lösen. Datum/Uhrzeit des Server auf einen Zeitpunkt zurücksetzen an dem das Zertifikat noch gültig war. SBS Asisstenten für die Zertifikatserneuerung durchlaufen lassen. Uhrzeit wieder richtig stellen.
    Wichtig: während dieser Aktion sollte die I-Net Verbindung unterbrochen sein und außer dem Admin kein weiterer Benutzer oder Rechner im Netz aktiv sein.

    MfG

    Montag, 30. Januar 2017 16:23
  • Naja, ich glaube nicht, das es daran liegt, denn es öffnen sich ja nicht mal richtig die Seiten von der Zertifizierungsstelle. An der Stelle fasse ich das Zertifikat ja noch gar nicht an.

    Gibt es hier keinen Microsoft Mitarbeiter, der sich mal darum kümmern kann? Muss ich jetzt einen Supportfall aufmachen, wo man nur ein gebrochenes Englisch hört, der Mitarbeiter mich gar nicht versteht, weil ich deutsch spreche und letztendlich wie beim letzten SBS Supportfall keine Lösung gefunden wird?

    LG Mike

    Mittwoch, 1. Februar 2017 12:37
  • Nein, hier gibt es keine Microsoft-Mitarbeiter. Die, die hier schreiben, sind als Privatpersonen hier.

    Evgenij Smirnov

    I work @ msg services ag, Berlin -> http://www.msg-services.de
    I blog (in German) @ http://it-pro-berlin.de
    my stuff in PSGallery --> https://www.powershellgallery.com/profiles/it-pro-berlin.de/
    Exchange User Group, Berlin -> http://exusg.de
    Windows Server User Group, Berlin -> http://www.winsvr-berlin.de
    Mark Minasi Technical Forum, reloaded -> http://newforum.minasi.com

    Mittwoch, 1. Februar 2017 14:34
  • Hat hier sonst keiner das Problem?

    LG Mike

    Montag, 6. Februar 2017 15:04
  • Hi Ich habe exakt das gleiche Problem bei einem Kunden und komme hier nicht weiter. Gibt es eine Lösung?

    Btw: es ist ein SBS2011 der allerdings von einme 2008er migriert wurde.


    und nochwas: ist auf den anderen Problemservern auch datev installiert?
    • Bearbeitet AlexNann00 Mittwoch, 5. April 2017 19:43
    Mittwoch, 5. April 2017 19:25
  • Hi habe exakt das gleiche Problem - bei meinem SBS2011 ist tatsächlich DATEV installiert - bringen die am Ende etwas durcheinander? 
    Mittwoch, 24. Mai 2017 15:34
  • Moin,

    das habe ich bereits ein paarmal in den Foren gelesen - man muss wohl das DATEV-Sicherheitspaket temporär deinstallieren, dann funktioniert die Zertifikatserneuerung mit dem Assistenten wieder.

    Selber natürlich nie getestet oder gesehen, denn ich betreue schon länger keine SBS- und auch keine DATEV-Kunden (zumindest keine mit lokalen DATEV-Serverinstallationen).


    Evgenij Smirnov

    I work @ msg services ag, Berlin -> http://www.msg-services.de
    I blog (in German) @ http://it-pro-berlin.de
    my stuff in PSGallery --> https://www.powershellgallery.com/profiles/it-pro-berlin.de/
    Exchange User Group, Berlin -> http://exusg.de
    Windows Server User Group, Berlin -> http://www.winsvr-berlin.de
    Mark Minasi Technical Forum, reloaded -> http://newforum.minasi.com

    Mittwoch, 24. Mai 2017 18:16
  • es ist genau so wie Evgenij Smirnov schreibt - wenn keiner mit DATEV-Anwendungen arbeitet das DATEV-Sicherheitspaket deinstallieren. Zertifikate aktualisieren. Falls nötig das Sicherheitspaket wieder installieren. Fertig!

    Freitag, 26. Mai 2017 14:18