none
Internetzugriff auf Exchange/Postfächer RRS feed

  • Frage

  • Guten Tag,

    seit geraumer Zeit versuche ich, eine Verbindung mit Outlook (2007 und 2013) übers Internet zum  Exchange2007SP3 herzustellen.

    Das soll schon mal funktioniert haben. Aber wie, weiß keiner (kein VPN und wahrscheinlich auch ohne DYNDNS).

    zu den Fakten:

    OWA ist eingerichtet und funktioniert.               Externe URL:https://festeIP/owa

    ActiveSync ist eingerichtet .                               Externe URL:https://festeIP/owa 

    Ich habe ActiveSync überprüft mit www.testexchangeconnectivity.com.

    Mit Autoermittlung funktioniert es nicht und mit manuell verbindung auf   https://festeIP/owa wird es nicht überprüft (falsches Format !)

    Outlook Anywhere war deaktiviert.

    Bei der Aktivierung von Outlook Anywhere kann ich unter Externer Hostname nicht die festeIP vergeben.

    Wenn ich dort z.B. mail.firma.de angebe, ist noch offen, wo dann die zuordnung bzw. die Veröffentlichung zur festen IP erfolgt ?

    Die Aktivierung von OutlookAnywhere ist sehr kurz und einfach. Doch es funktioniert einfach nicht bzw. es findet nicht zusammen.

    Über Informationen bzw. Hilfe wäre ich dankbar.

    Dienstag, 13. August 2013 11:26

Antworten

Alle Antworten

  • Hmm, wo fängt man an...

    Also ActiveSync wirst du auch unter /OWA nicht erreichen, die URL muss /Microsoft-Server-ActiveSync lauten. Wenn du mit testexchangeconnetivity.com testet, dann darfst du nur die "Base" URL dort angeben, also nur dein https://festeip , die richtige URL wird dann vom Tool selbst aufgerufen.

    Naja den Namen pflegst du im DNS, wenn du deine Zone nicht selber hostest , dann wahrscheinlich bei deinem Provider. 

    Und ein gut gemeinter Rat, es scheint das du noch relativ neu in dem Thema bist, such dir jemanden der dich vor Ort oder Remote unterstützt.

    Gruß

    Jörg

    Dienstag, 13. August 2013 12:14
  • Hi Patrick,

    bekommst du denn eine Fehlermeldung, wenn du dich über OWA verbindest?

    Wenn Autodiscover nicht sauber eingerichtet ist, kannst du Outlook auch manuell einrichten. Wichtig ist das Zertifikat, dem der Client vertrauen muss:
    http://www.rackspace.com/knowledge_center/article/manually-setting-up-outlook-2010-with-microsoft-exchange-2010

    Viele Grüße
    Christian

    Dienstag, 13. August 2013 17:21
    Moderator
  • Hi Christian,

    OWA funktioniert ohne Probleme.

    Das selbsterstellte bzw. verlängerte Zertifikat des Servers, ist auf meinem PC als vertrauenswürdige Stammzertifizierungsstelle installiert. Zertifikatswarnungen kommen keine.

    Allerdings sehen ich Verwendungszeck : Serverauthentifizierung    >   passt das ?

    Die manuelle Einrichtung von Outlook kenne ich. Es kann nur keine Verbindung zum Exchangeserver bzw. zur festen IP aufgebaut werden. 

    Manuelle Einrichtung ActiveSync mit festerIP : Benutzer und Passwort wird abgefragt. 

    Es kommen ein paar Sicherheitshinweise. "Der Name auf dem Sicherheitszertifikat stimmt nicht mit dem Namen der Website überein" Autodiscover war auch dabei. 

    Ist klar, da ich über die festeIP komme. 

    Ich habe mir mal das Zertifikat von Autodiscoer angeschaut.

    Dieses Zertifikat ist für den Provider ausgestellt. Ich hätte vermutet für meinen Exchangeserver.

    Fehler: Anmeldung am ExchangeSync-E-Mail-Server fehlgeschlagen - der Server wurde nicht gefunden

    Gruß Patrick

    Mittwoch, 14. August 2013 05:45
  • Hi Patrick,

    das Cert sollte stimmig sein und pass einfach mal deine Hosts-Datei auf den Namen an. Danach kannst du mal ins IIS-Log des Server schauen, ob etwas ankommt. Vielleicht versuchst es auch ersteinmal intern über HTTPS hinzubekommen, bevor du die externe Komponente hinzufügst.

    Viele Grüße

    Christian

    Mittwoch, 14. August 2013 06:49
    Moderator
  • Hi Christian,

    ich habe die feste IP in die Host-Datei eingetragen (C:\Windows\System32\drivers\etc\host.txt).

    Man. Einrichtung Outlook Fehler:

    Es gibt ein Problem mit dem Sicherheitszertifikat des Proxyservers.

    Der Name der Zielwebsite entspricht nicht der festenIP.

    Outlook kann keine Verbindung mit dem Proxyserverherstellen (Fehlercode:10)

    Intern funktioniert  ActiveSync.

    Extern scheint es auch zu funktionieren, wenn ich auf festeIP\RPC eingebe.

    Wo kann ich den die IIS-Logs mir anschauen ?

    



    Mittwoch, 14. August 2013 10:05
  • Schau mal wie Outlook gesetzt ist und ansonsten Outlookprovider anpassen: http://ares.gobien.be:8080/2013/05/exchange-2010-outlook-anywhere-proxy-security-certificate-wildcard-domain-com/

    Viele Grüße
    Christian

    Donnerstag, 15. August 2013 19:06
    Moderator
  • Hi Christian,

    das bringt mich nicht weiter.

    Ich gebe die Feste IP ein.

    Ich glaube, so bringt es nichts.

    Ich werde gleich noch mal auflisten bzw. schreiben, wie ich was eingerichtet habe.

    Patrick

    Freitag, 16. August 2013 05:15
  • Hi Patrick,

    steht die IP im cert? ...eher nicht, also muss es da knallen...

    Es ist manchmal besser auf das System zu schauen und mit einem DL alles durchzugehen als die Glaskugel zu befragen. :-)

    Warte jetzt mal auf die ausführliche Beschreibung - bitte mit Angaben zum Cert.

    Grüße

    Christian

    Freitag, 16. August 2013 05:26
    Moderator
  • 1. OutlookAnywhere aktivieren > Eingabe der festenIP als Externer Hostname nicht möglich !

                                                      > also habe ich mail.firma.de eingegeben 

    Jetzt stellt sich die Frage, wie erreiche ich diese IP aus dem Internet ?

    Es gibt eine Internetdomäne beim Provider firma.de, muß dort eine Zuordnung oder eine DNS-Eintrag erfolgen ? Die interne Domäne lautet firma.local

    Sprich mail.firma.de, wird der fetsenIp zugeordnet.

    2. OutlookAnywhere Client einrichten

     > ich habe eigentlich immer die feste IP als Exchange-Proxyserver angegeben

    > wenn Punkt 1 geklärt ist und ich mit dem Namen mail.firma.de arbeiten kann, dann kann der Client mit mail.firma.de arbeieten oder firma.de

    > dann könnte man noch den Outlook-Provider anpassen

    Vielleicht ist es jetzt klarer, wo das Problem liegt oder die Probleme liegen.

      Gruß Patrick

    Freitag, 16. August 2013 05:39
  • Hallo Patrick,

    zu 1. Ok, das sind jetzt basics. :-( Bei deinem Domainprovider musst du einen A-record mit Zeiger auf deine IP setzen lassen ... oder du kannst es selber machen. Manchmal muss auch eine Subdomain "mail".firma.de eingerichtet werden:
    http://hilfe-center.1und1.de/domains-c82638/dns-einstellungen-c82657/was-sind-dns-einstellungen-a783568.html

    Bei welchem Provider bist du?

    zu 2. Ich weiß immer noch nicht, was im Cert steht und wer es ausgestellt hat?!?!

    Wenn die IP dort nicht drin steht, kann es nicht klappen. Mit der Hosts-Datei bekommst du es ohne Provider hin, aber es muss alles über mail.firma.de gehen und dieser muss im Cert stehe > OWA-Test.

    Grüße

    Christian  

    Freitag, 16. August 2013 05:57
    Moderator
  • Hi Christian,

    1. das Standardzertifikat war letztes Jahr abgelaufen.

    Da habe ich es verlängert.

    Ich bin den Anweisungen sämtlicher Anleitungen gefolgt. Doch nie funktionierte die Verlängerung.

    Doch irgendwann, irgenwie habe ich es dann doch verlängert bekommen oder neu ausgestellt.

    Es war für mich schwer ersichtlich, was da passierte bzw. es ging nicht so, wie in den Anleitungen.

    Mit dem selbsterstellten Zertifikat, funktioniert Outlook intern bzw. auch OWA.

    2. Am Freitag, habe ich Outlook Anywhere auf dem Server (für mail.firma.de) aktiviert.

    Seitdem, bringt Outlooks folgenden Fehler:  

    .

    Meine Host-Datei (ich bin ein externer Benutzer )habe ich auch mit mail.firma.de befüllt. Aber ich bekamm genau die gleiche Fehlermeldung wie die internen Benutzer.

    Gruß Patrick


    • Bearbeitet Patrick10315 Dienstag, 20. August 2013 11:16 soll nicht zu sehen sein
    Montag, 19. August 2013 09:47
  • Akzeptiert der Client das Cert wirklich und ist der Name wirklich im Cert? ...ich glaube eher nicht...

    http://exchangeserverpro.com/outlook-2013-ssl-trust-errors-when-connecting-to-exchange-server/
    http://support.microsoft.com/kb/923575/en-us

    Auch OWA wird laufen , aber wenn du über mail.****.de gehst, wird auch eine Cert-Fehlermeldung kommen, oder?

    Grüße
    Christian


    Montag, 19. August 2013 13:36
    Moderator
  • Hi,

    der Client hatte bis zur Aktivierung von Outlook Anywhere kein Prbolem mit dem Zeitifikat gehabt.

    Ich habe jetzt Outlook Anywhere erstmal wieder deaktiviert.

    Im Zertifikat, steht glaube ich nur der Servername (Standardzertifikat).

    Auf OWA wird über die feste IP zugegriffen, aus dem Internet.

    Gruß Patrick

    Dienstag, 20. August 2013 07:21
  • Hi Christian,


    Ich werde jetzt ein SSL- Zertifikat kaufen.

    Was man da schon wieder alles wissen soll !!!

    Ich denke, ich brauche 2 interne Namen server und server.firma.local.

    Sowie eine externen Namen für Outlook Anywhere mail.server.de und vielleicht für die Homepage www.firma.de.

    Patrick


    Dienstag, 20. August 2013 11:21
  • Hi Patrick,

    deshalb schraube ich auch nicht an meinem Auto - es gibt leute die können es besser und bei 200 auf der Autobahn ... naja.

    Es kann auch mit einem Namen gehen:
    http://www.cohesivelogic.com/2011/01/exchange-2010-single-name-ssl-certificates/

    Viele Grüße
    Christian

    • Als Antwort markiert Alex Pitulice Montag, 2. September 2013 07:26
    Dienstag, 20. August 2013 11:32
    Moderator
  • Du wirst aber wahrscheinlich kein offizielles Zertifikat mit einem "internen" Servernamen bekommen.
    Dienstag, 20. August 2013 15:05
  • Habe ich, aber ich habe doch nur deine URL wieder gegeben - änderst du sie auch?

    Grüße

    Christian

    PS: Markierst du bitte noch die hilfreichen Beiträge, wenn es erledigt ist.


    Dienstag, 20. August 2013 17:21
    Moderator