none
E2k10 Empfangsconnectoren Verständnisfrage RRS feed

  • Frage

  • Hallo,

    ich habe mal eine Verständnisfrage.
    Umgebung:
    Standort A: Mailgateway, CAS/HUB Server und einen Mailboxserver
    Standort B: einen Server mit der Rolle CAS/HUB/Mailbox
    Jeglicher externe Mailverkehr verläuft über das eine Mailgateway am Standort A

    Nun soll von einer Anwendung, von einem Windows Client am Standort B, eine Mail an Extern verschickt werden. Nun dachte ich mir, ich lege wie für die Clients am Standort A am Standort B auch einen Empfangsconnector "Extern Relay" an und nehme den Client darin auf. Nur leider funktioniert dann der Mailversand nach extern nicht. Das Relaying funktioniert nur dann, wenn ich am Standort A im Empfangsconnector den Client aus Standort B mit aufnehme. Es sieht so aus, als wäre es gar nicht notwendig Empfangsconnectoren am Standort B zu erstellen.
    Was mich außerdem wunderte ist, das der Client direkt aus der Anwendung (es ist Outlook installiert aber der Versand erfolgt aus der Anwendung) intern Mails verschicken konnte, ohne das ich ihn in den Empfangsconnector fürs interne Relaying aufnehmen musste. Für nicht Windowsgeräte muss man die Adressen ins Relaying aufnehmen, aber den Windowsrechner scheinbar nicht. Kann mir das jemand erklären?


    Danke!

    Mittwoch, 27. November 2013 08:51

Alle Antworten

  • Moin,

    da wir weder die Dritt-Anwendung noch die Konfig der Empfangsconnectoren kennen, ist jede Antwort eigentlich nur Spekulation.

    Theoretisch ist alles möglich, was Du beschreibst. 


    Gruesse aus Berlin schickt Robert - MVP Exchange Server

    Mittwoch, 27. November 2013 09:47
  • Die Drittanwendung kenne ich auch nicht.

    Dann frage ich mal theoretischer. Wäre es nicht ein normales vorgehen, auf jedem HUB Server eines Standorts eigene Empfangsconnectoren zu konfigurieren?

    Danke!

    Mittwoch, 27. November 2013 10:03
  • Das kann man pauschal nicht sagen.

    Wenn die Anwendung normales SMTP nutzt, musst Du natürlich auch die Adresse des Mail-Servers in dieser Anwendung ändern. Und auf dem Mail.-Server muss es einen Connector geben. Dann sind Standort aber egal, weil der Server überall stehen kann.


    Gruesse aus Berlin schickt Robert - MVP Exchange Server

    Mittwoch, 27. November 2013 10:16
  • In der Anwendung wurde der Mailserver eingetragen und trotz erstelltem Empfangsconnector für das externe Relaying konnte der Client mit der App nur intern Mails verschicken. Funktioniert hat es erst dann, als ich den Server auf Standort A umstellte und den Server entsprechend in der APP geändert hatte.

    Danke

    Mittwoch, 27. November 2013 10:21
  • Wie gesagt, alles nur Spekulation, ohne die Anwendung zu kennen. Hast Du während des Fehlers mal ins SMTP-Protokoll geschaut? Oder den Transport-Dienst neugestartet? Eventuell war ja auch nur die Remote IP-Adresse falsch eingetragen - alles schon erlebt.

    Aber zumindest ist das kein Standardverhalten.


    Gruesse aus Berlin schickt Robert - MVP Exchange Server

    Mittwoch, 27. November 2013 17:53
  • Hallo

    danke für die Antwort!
    Ich hatte aus Mangel an Zeit nur das Logging für die Empfangsconnectoren scharf geschaltet, doch wurde dort überhaupt gar nichts geloggt.

    Falsche IP kann ich ausschließen. Transportdienst hatte ich nicht neu gestartet.

    Danke!

    Donnerstag, 28. November 2013 09:56
  • Wenn da nichts geloggt wurde, dann wurde da auch nichts hingeschickt, denn auch bei einem sofort wieder getrennten Verbindungsversuch gibt es immer einen Eintrag im SMTP-Log.

    Gruesse aus Berlin schickt Robert - MVP Exchange Server

    Donnerstag, 28. November 2013 10:29
  • Dann stellt sich mir die Frage warum bei einem eingerichteten Empfangsconnector keine Mails über ihn geschickt werden, wenn in der Applikation der entsprechende Server angegeben wurde. Wie funktioniert denn hier das Mailrouting? Kann ich das irgendwie überprüfen?

    Danke!

    Freitag, 29. November 2013 08:34