none
Nach Umbenennung des File - Servers kein lokaler UNC Pfad auf dem alias möglich RRS feed

  • Frage

  • Hallo,

     

    wir haben unseren File Server neu aufgesetzt und die Daten migriert. Daher hat der neue File Server einen neuen Computername erhalten.

    Da wir allerdings nicht alle Scripte anpassen wollen habe ich einen DNS Alias mit dem alten Servernamen eingetragen und den "DisableDistrictNameChaching" Parameter in der Reg auf 1 gesetzt.

    Der Zugriff von der Clients auf den UNC Pfad \\alterServername\freigabe funktioniert.

    Aber nun das große Proble: Ich bekomme, lokal auf den neuen File Server, wenn ich im Explorer versuche auf  \\alterServername\freigabe zuzugrreifen eine LOGIN Aufforderung.

    Wenn kennt eine lösung?

     

    Montag, 17. Mai 2010 09:09

Antworten

  • Servus,

    das liegt am Authentifizierungsprotokoll "Kerberos". Du müsstest noch zwei SPNs (Service Principal Name) erstellen.
    Installiere dir dazu unter Windows 2000 und Windows Server 2003 die "Windows Support Tools". Ab Windows Server 2008 ist das Tool SETSPN "on bord".

    Wenn der Computername des Dateiservers "Fileserver01.Domäne.DE" und der CNAME "Alias.Domäne.de" lautet, gebe die folgenden beiden Befehle in der Kommandozeile ein:

    setspn -a HOST/CNAME Fileserver01

    und

    setspn -a HOST/CNAME.Domäne.de Fileserver01


    Anschließend leere den Ticketcache oder starte den Server neu. Danach sollte es funktioneren.


    Viele Grüße aus Mainz
    Yusuf Dikmenoglu - Microsoft MVP - Directory Services
    Blog: LDAP://Yusufs.Directory.Blog/
    Montag, 17. Mai 2010 11:20

Alle Antworten

  • Servus,

    das liegt am Authentifizierungsprotokoll "Kerberos". Du müsstest noch zwei SPNs (Service Principal Name) erstellen.
    Installiere dir dazu unter Windows 2000 und Windows Server 2003 die "Windows Support Tools". Ab Windows Server 2008 ist das Tool SETSPN "on bord".

    Wenn der Computername des Dateiservers "Fileserver01.Domäne.DE" und der CNAME "Alias.Domäne.de" lautet, gebe die folgenden beiden Befehle in der Kommandozeile ein:

    setspn -a HOST/CNAME Fileserver01

    und

    setspn -a HOST/CNAME.Domäne.de Fileserver01


    Anschließend leere den Ticketcache oder starte den Server neu. Danach sollte es funktioneren.


    Viele Grüße aus Mainz
    Yusuf Dikmenoglu - Microsoft MVP - Directory Services
    Blog: LDAP://Yusufs.Directory.Blog/
    Montag, 17. Mai 2010 11:20
  • Hallo Yusuf,

    vielen Dank. Das was die Lösung.

    Gruß

    Jonny

    Dienstag, 18. Mai 2010 06:00
  • Das freut mich. Danke für die Rückmeldung.
    Viele Grüße aus Mainz
    Yusuf Dikmenoglu - Microsoft MVP - Directory Services
    Blog: LDAP://Yusufs.Directory.Blog/
    Dienstag, 18. Mai 2010 06:55
  • Hallo Yusuf,

    vielen Dank. Das was die Lösung.

    Gruß

    Jonny


    Ich löse dieses "Problem" meistens mit einer Anpassung in der Registrierung! - Default "hört" der Server nur auf seinen Hostnamen, das lässt sich mit dieser Änderung umgehen!
    Alles sollte so einfach wie möglich sein, nicht einfacher!
    Samstag, 5. Juni 2010 05:47