none
Schlechte Performance bei virtualisiertem Fileserver (Hyper-V) RRS feed

  • Allgemeine Diskussion

  • Hallo,

    wir haben einen neuen Server angeschafft, der ausschließlich als Fileserver genutzt werden soll.

    Da es die Hardware und die Lizensierung (Windows 2012 R2 Standard für Host und VM) hergibt, wollte ich mal eine virtualisierte Lösung testen.

    Leider ist die Performance miserabel, schon das Aufrufen eines Shares der VM (z.B. \\VM\Freigabe1 von anderen Arbeitsstationen aus dauert mehrere Sekunden und die Übertragungsraten sind sehr klein (Total Commander zeigt 80kB/s an).

    Der Host (Dell R320, 16GB RAM, RAID5, 2 Virtuelle Disks 250GB & 7TB) ist nur Memberserver in der Domain, und es läuft auch nur die Hyper-V-Rolle. Eine Netzwerkkarte aktiv, diese wird auch vom Hyper-V über den virtuellen Switch genutzt.

    Die VM hat 2 dynamische VDHX-laufwerke, 2 virtuelle CPUs, 8GB RAM dynamisch. Serverrolle File-Server und Datendeduplikation, die DD ist jedoch deaktiviert. VM ist ebenfalls Memberserver der Domain.

    Kopiere ich vom Host auf eine Freigabe der VM, so läuft alles in normaler Geschwindigkeit, Total Commander zeigt 30-50 MB/s und mehr an. Kopiere ich von einer Arbeitsstation im Netz auf den Host, so ist das auch normal schnell, nur das Kopieren von einer Arbeitsstation auf die VM läuft katastrophal langsam.

    Also denke ich, dass die schlechte Performance nicht mit der VM oder dem Speichersystem zusammenhängt, sondern irgendwie mit der Netzwerkanbindung über den "Virtual Switch".

    Ich habe testweise im Virtual Switch diverse Netzwerkdienste abgeschaltet (Topologieerkennung, IPV6), ohne Auswirkung auf Funktion und Performance.

    Woran könnte die schlechte Performance liegen? Ich weiss, dass man VHDX-Laufwerkdateien für optimale Performance nicht unbedingt auf RAID5-Disks legen sollte, aber so ein Leistungseinbruch (>Faktor 1000) ist dadurch nicht zu erklären, oder?

    Grüße

    M.Roth




    • Bearbeitet MickyRoth Freitag, 18. April 2014 11:56
    Freitag, 18. April 2014 11:52

Alle Antworten

  • Lösung gefunden, Server performt jetzt! Es war eine Einstellung der Netzwerkkarte ("Virtuelle Maschinen Warteschlange" musste deaktiviert werden).

    Die Kollegen vom mcseboard.de haben mir geholfen:

    http://www.mcseboard.de/topic/197831-schlechte-performance-bei-virtualisiertem-fileserver-2012-r2-hyper-v/?p=1228453


    • Bearbeitet MickyRoth Freitag, 18. April 2014 21:19
    Freitag, 18. April 2014 21:18