none
Zugewiesener Zugriff für weitere Benutzer, nur 2 Apps auswählbar RRS feed

  • Frage

  • Ich habe einen neuen Benutzer angelegt und möchte den TZugriff auf eine App zuweisen, sodass der neue Benutzer seinen Account ausschließlich nur mit dieser App starten kann (Kioskmodus)

    Soweit funktioniert das auch. Allerdings stehen nur 2 App zur Auswahl: "Groove" und "OneNote". Andere Apps sind nicht auswählbar. Ich benötige aber zur Auswahl die App "Edge".

    Warum funktioniert das nicht?

    Montag, 18. Juli 2016 12:49

Antworten

  • Habe die Lösung gefunden!

    Es geht tatsächlich mit Google!

    • die Google-App über den anderen Benutzer installieren
    • PC neustarten
    • Powershell als Admin ausführ
    • Code Set-AssignedAcess -UserName kiosk -AUMID GoogleInc.GoogleSearch_yfg5n0ztvskxp!App
    • PC neustarten
    • mit neuem Nutzer anmelden

    Bleibt dennoch das Rätsel, warum diese Option mit dem "Edge" einen schwarzen Bildschirm verursacht.

    Werde auch noch mal andere Apps testen.

    Noch mals Herzlichen Dank @Peter Hagendorf, ohne Sie hätte ich das nie hinbekommen! (-:
    Mittwoch, 20. Juli 2016 19:29

Alle Antworten

  • Ich habe einen neuen Benutzer angelegt und möchte den TZugriff auf eine App zuweisen, sodass der neue Benutzer seinen Account ausschließlich nur mit dieser App starten kann (Kioskmodus)

    Soweit funktioniert das auch. Allerdings stehen nur 2 App zur Auswahl: "Groove" und "OneNote". Andere Apps sind nicht auswählbar. Ich benötige aber zur Auswahl die App "Edge".

    Warum funktioniert das nicht?

    PS: habe die Info aus dem Microsoft Chat bekommen, das hier die richtige Anlaufstelle für meine Frage ist.

    Warum bekommt man keine Antwort hier?

    Montag, 18. Juli 2016 18:01
  • user7411:

    Ist mit diesem Konto vor dieser Aktion denn schon mal eine Anmeldung erfolgt und alle Standard-Apps waren verfügbar/nutzbar?

    Warum bekommt man keine Antwort hier?

    Evtl. verwechselst du das Forum hier mit einem Chat? ;-)

    Dienstag, 19. Juli 2016 12:04
  • Erstmal Danke für die Rückantwort.

    Das mit der Verwechslungsgefahr mag stimmen, war aber sicher nicht beabsichtigt. Ist halt so, dass ich zu dem Themen schon längere Zeit mit dem MS-Support gechattet habe, die aber keine Lösung anbieten konnten, außer mich hierher zu verweisen. Mir ist auch erst später bewusst geworden, dass dies ein Forum ist. Sorry für die Ungeduld, aber suche schon längger nach eine Lösung und muss es immer wieder eklären, obwohl die Einrichtung ja eigentlich einfach ist.

    Auf deine Frage: ja, das Konto wurde entsprechend eingerichtet und alle Apps sind nutzbar.

    Nur eben die Zuweisung auf den Zugriff auf eine bestimmte App ist hier begrenzt auf "Groove". Und an diesem Punkt komme ich einfach nicht weiter.

    Dienstag, 19. Juli 2016 12:27
  • Für Ihr besseres Verständnis nenne ich Ihnen im Folgenden meine Vorgehensweise bei der Einrichtung des neuen Benutzer:

    • Alle Einstellung
    • Konten
    • Familie und weitere Benutzer
    • Diesem PC eine andere Person hinzufügen
    • Person hinzugefügt und Adminrechte erteilt, sowie der Support es mir gesagt hat. (Kontrolle in den Gruppenrichtlinien bestätigen die Zuordnung des neuen Benutzer als Administrator)
    • Den PC neu gestartet
    • Den neuen Benutzer angemeldet und Windows für den neuen Benutzer eingerichtet
    • Neuen Benutzer abgemeldet
    • PC neu gestartet
    • Mit dem Hauptkonto wieder angemeldet
    • (dann wieder zu)
    • Konto
    • Familien und weitere Benutzer
    • Zugewiesener Zugriff einrichten
    • Konto für zugewiesenen Zugriff auswählen
    • Neuen Benutzer als Konto ausgewählt
    • App auswählen, die auf dieses Konto zugreifen soll
    • (so, und jetzt kommt die Baustelle) !!!

    Unter „App auswählen, auf das dieses Konto zugreifen kann, ist nur die APP „Groove“ auswählbar! Andere Auswahlmöglichkeiten gibt es nicht!

    Es ist gewünscht, dass das andere Benutzerkonto ausschließlich mit einer App startet und keine andere Funktion hat.

    Ich möchte den „Zugewiesenen Zugriff der App „Edge“ oder einem anderen Browser zuteilen. Doch die Auswahlmöglichkeit besteht nicht!

    Warum nicht? Wo ist der Fehler?



    • Bearbeitet user7411 Dienstag, 19. Juli 2016 12:41
    Dienstag, 19. Juli 2016 12:36
  • user7411:

    * Alle Einstellung
    * Konten
    * Familie und weitere Benutzer
    * Diesem PC eine andere Person hinzufügen

    Einfacher:
    net user Trallala /add
    in einer Admin-CMD ausführen. Fertig ist das Konto.

    * Person hinzugefügt und Adminrechte erteilt,

    Das ist Unsinn, das Kiosk-Konto sollte ein eingeschränktes Standardkonto sein.

    Unter „App auswählen, auf das dieses Konto zugreifen kann, ist nur die APP „Groove“ auswählbar! Andere Auswahlmöglichkeiten gibt es nicht!

    Ich hatte das noch nie getestet, hab's gerade mal versucht, hier werden *überhaupt keine* Apps zur Auswahl angeboten, scheint mal wieder Win 10-Nonsens zu sein. :-/
    Ähnlicher Win 10-Unsinn: In den Benutzerkonten tut sich bei Klick auf "Eigene Umgebungsvariablen ändern" schon seit Beginn 1511 nichts mehr. Mit 10240 ging's noch.
    Es soll Abhilfe über die Powershell geben, siehe hier:

    Check out the Set-AssignedAccess command:
    https://msdn.microsoft.com/en-us/library/dn449301(v=winembedded.82).aspx
    if you are struggling to get the exact AppName (like I was), you should also try the Get-AppxPackage command:
    https://technet.microsoft.com/en-us/library/hh856044.aspx Be sure to run Powershell in administrative mode

    https://social.msdn.microsoft.com/Forums/sqlserver/en-US/e4d9c392-cf37-43ac-b4c3-88f1eb7b516b/w81-enable-an-app-to-show-as-an-option-for-assigned-access?forum=wpdevelop

    Warum nicht? Wo ist der Fehler?

    Wie gesagt, wohl Win 10-Nonsens. Versuche es via Powershell.



    Mittwoch, 20. Juli 2016 11:30

    Herzlichen Dank für die Mühe und die Informationen!

    Dachte mir schon, dass es noch einen anderen Weg geben muss eine Zuordnung herzustellen. Wußte leider nur nicht wie.

    Leider funktioniert es mit der Powershell auch nicht. 

    • habe Powershell als Admin gestartet und den folgenden Code eingetragen
    Set-assignedaccess –username UserName -AppUserModelId ‘DefaultBrowser_NOPUBLISHERID!Microsoft.InternetExplorer.Default’

    (Username) und den Browsernamen habe ich entsprechend angepasst, d.h.

    DefaultBrowser_NOPUBLISHERID!Microsoft.Edge.Default’

    Powershell hat diesen Befehl offenbar auch akzeptiert. Es gab keine Fehlermeldung.

    • wenn ich den PC jetzt neu starte und mich mit dem neuen Benutzer anmelde, bleibt der Bildschirm schwarz!, selbst wenn ich den Code hinten unverändert als 'InternetExplorer' anweise.

    Was mache ich falsch? Sorry, Sie haben sicher schon gemerkt, dass ich ein Laie bin!

    vielen Dank


    • Bearbeitet user7411 Mittwoch, 20. Juli 2016 18:51
    Mittwoch, 20. Juli 2016 16:10
  • Ich hab's mal so versucht:
    Set-AssignedAccess -UserName kiosk -AUMID Microsoft.MicrosoftEdge_8wekyb3d8bbwe!MicrosoftEdge
    Oder alternativ:
    Set-AssignedAccess -AppName Microsoft.MicrosoftEdge -UserName kiosk
    Wird beides akzeptiert und der Befehl "Get-AssignedAccess" zeigt an, dass Edge für das Konto "kiosk" zugewiesen ist. Wird auch in "Einstellungen" so angezeigt. Wenn man sich allerdings mit dem Konto anmeldet, landet man nur in tiefem Schwarz.
    Fazit: Wie so vieles in Win 10 ist das kaputter, unbrauchbarer Müll, vor allem die Update-Verwaltung ist völlig unbrauchbar. Da bleibt man besser bei Win 8.1.
    Die AUMIDs kann man sich z.B. so auflisten lassen:
    $installedapps = get-AppxPackage
    $aumidList = @()
    foreach ($app in $installedapps)
    {
        foreach ($id in (Get-AppxPackageManifest $app).package.applications.application.id)
        {
            $aumidList += $app.packagefamilyname + "!" + $id
        }
    }
    $aumidList

    Mittwoch, 20. Juli 2016 18:33
  • Mit der altenativen Methode "Set-AssignedAccess -AppName Microsoft.MicrosoftEdge -UserName kiosk" wird der Edge nun auch bei mir aufgelistet.

    Allerdings bleibt es tatsächlich beim tiefen schwarz! Obwohl im Taskmanager der Prozess Edge für den anderen Benutzer ausgeführt wird. Ich habe an einer anderen Stelle gelesen, dass man als Alternative die "Google-App" als Browser zuteilen könnte. nur weiß ich da leider nicht den Pfad. Werde  dies auch noch mal probieren und mit anderen Apps.

    Sie haben sich wirklich sehr bemüht und dafür danke ich Ihnen sehr. Bleibt mir am Ende wohl nur Ihr Fazit von WIN 10 zu teilen. Vielleicht wird es ja mit dem August-Update behoben. Ansonsten ist der Mehrnutzen dieses OS für mich auch nicht mehr erkennbar.




    • Bearbeitet user7411 Mittwoch, 20. Juli 2016 19:02
    Mittwoch, 20. Juli 2016 18:59
  • Habe die Lösung gefunden!

    Es geht tatsächlich mit Google!

    • die Google-App über den anderen Benutzer installieren
    • PC neustarten
    • Powershell als Admin ausführ
    • Code Set-AssignedAcess -UserName kiosk -AUMID GoogleInc.GoogleSearch_yfg5n0ztvskxp!App
    • PC neustarten
    • mit neuem Nutzer anmelden

    Bleibt dennoch das Rätsel, warum diese Option mit dem "Edge" einen schwarzen Bildschirm verursacht.

    Werde auch noch mal andere Apps testen.

    Noch mals Herzlichen Dank @Peter Hagendorf, ohne Sie hätte ich das nie hinbekommen! (-:
    Mittwoch, 20. Juli 2016 19:29
  • user7411:

    Es geht tatsächlich mit Google!

    Dass es damit gehen soll, hatte ich auch gelesen.

    Bleibt dennoch das Rätsel, warum diese Option mit dem "Edge" einen schwarzen Bildschirm verursacht.

    Wie gesagt: die Sache ist in Win 10 gründlich vermurkst.

    Werde auch noch mal andere Apps testen. Noch mals Herzlichen Dank @Peter Hagendorf, ohne Sie hätte ich das nie hinbekommen! (-:

    Prima, ich bin dadurch nun auch etwas schlauer geworden. :-)

    Mittwoch, 20. Juli 2016 23:30
  • hi zusammen, 

    wäre für diese Anforderung nicht Device Guard ein passendes Feature? Gerne auch in Kombination mit AppLocker?

    Donnerstag, 21. Juli 2016 08:37
  • Alexander Benoit:

    wäre für diese Anforderung nicht Device Guard ein passendes Feature? Gerne auch in Kombination mit AppLocker?

    Da wollen mir die Anforderungen so gar nicht gefallen. ;-)

    Donnerstag, 21. Juli 2016 12:14
  • Du musst die (Browser-)App auf dem Account des GASTBENUTZERS hochladen! Danach abmelden, zurück zum Administrator-Account und dort den `Zugewiesenen Zugriff´ für den Gastbenutzer einrichten (dort erscheint die App dann auch!). Wenn du dich danach auf dem Gastbenutzer-Account wieder anmeldest, erscheint nur noch die gewünschte Browser-App. Dort wieder raus mit `Strg-Alt-Entf´.
    Freitag, 23. März 2018 23:14