none
Exchange Verwaltungskonsole - WinRM-Fehler RRS feed

  • Frage

  • Hallo zusammen,

    auf einem SBS 2011 erscheint beim Starten der Exchange-Verwaltungskonsole folgenden Fehlermeldung:

    Initialisierungsfehler

    Fehler beim Suchen nach lokalem Exchange-Server:

    [server.unseredomaene.local]Beim verbinden mit dem Reomteserver ist folgender Fehler aufgetreten: Der WinRM-Client kann die Anforderung nicht verarbeiten. Der Inhaltstyp der HTTP-Antwort vom Zielcomputer kann nicht ermittelt werden. Der Inhaltstyp der HTTP-Antwort fehlt oder ungültig."

    Wie kann das Problem behoben werden?

    Vielen Dank für Antworten

    Albert

    Montag, 2. April 2012 17:58

Antworten

  • Hallo Albert,

    sicherlich hast Du, bevor Du die web.config verändert hast eine Sicherung der Datei gemacht. Stelle diese wieder her.

    Öffne nun die IIS-Konsole (Internetinformationsdienstemanager)

    - Navigiere zur Default Web Site (auswählen) und dann wähle in der Mitte "Module"

    - Entferne hier das Modul kerbauth (rechtsclick, entfernen)

    - Jetzt gehe auf das virtuelle Verzeichnis "Powershell"  dann wieder in der Mitte auf "Module"

    - Überprüfe unter Module dass hier "kerbauth" gelistet ist mit dem Modultyp "Systemeigen" und Eintragstyp "Lokal"

      Wenn "kerbauth" nicht gelistet ist, clicke rechts oben bei "Aktionen" auf "Systemeigene Module konfigurieren" und setze den Haken bei "kerbauth"

    führe jetzt einen IIS-Neustart durch - Kommandozeile : IISRESET /noforce

    Jetzt sollten Deine Exchange Werzeuge wieder funktionieren.


    Grüße, Christoph


    Montag, 9. April 2012 17:30

Alle Antworten

  • Hallo Albert,

    schau mal hier auf dem Exchange Team Blog, da sind alle Startfehler mit deren Behebung gelistet :

    http://blogs.technet.com/b/exchange/archive/2010/02/04/3409289.aspx


    Grüße, Christoph

    Montag, 2. April 2012 18:09
  • Hi Albert,

    kannst du bitte verifizieren dass unter "C:\windows\system32\inetsrv\config\schema" folgende Datei vorhanden ist "wsmanconfig_schema.xml" ?

    Um Testzweke kannst du auch ein Backup der applicationHost.config File erstellen, und dann eine von einem funktionierenden Server hinzufügen.

    Hoffe dass das hilft.

    Mfg,

    Vali

    Mittwoch, 4. April 2012 13:56
  • Hallo Christoph,

    vielen Dank für den Link. Den Link werde ich mir zu Gemüte führen. Ich werde dann nochmals ein Feedback geben.

    Viele Grüße

    Albert

    Mittwoch, 4. April 2012 16:35
  • Hallo Valentin,

    danke für deinen Hinweis. Die wsmanconfig_schma.xml ist vorhanden. Wo ist die applicationHost.config zu finden?

    Viele Grüße

    Albert

    Mittwoch, 4. April 2012 16:39
  • Hallo Albert,

    die Applicationhost.config befindet sich standardmässig in C:\Windows\System32\Inetsrv\config\ApplicationHost.config

    Weiteres wie gesagt in dem verlinkten Artikel.


    Grüße, Christoph

    Mittwoch, 4. April 2012 17:28
  • Hallo Christoph,

    ich habe mir den Artikel des Exchange Team Blog angesehen. Dort heißt es u.a:

    "1. Remote PowerShell uses Kerberos to authenticate the user connecting. IIS implements this Kerberos authentication method via a native module. In IIS Manager, if you go to the PowerShell Virtual Directory and then look at the Modules, you should see Kerbauth listed as a Native Module, with the dll location pointing to C:\Program Files\Microsoft\Exchange Server\v14\Bin\kerbauth.dll. If the Kerbauth module shows up as a Managed module instead of Native, or if the Kerbauth module has been loaded on the Default Web Site level (instead of, or in addition to, the PowerShell virtual directory), you can experience this issue. To correct this, make sure that the Kerbauth module is not enabled on the Default Web Site, but is only enabled on the PowerShell virtual directory. The entry type of "Local" indicates that the Kerbauth module was enabled directly on this level, and not inherited from a parent."

    Tatsächlich ist auf der Default "Kerbauth" aktiv. Möchte ich die Module des Verzeichnisses der Power Shell laden bekomme ich folgenden Fehlermeldung:

    "Fehler beim ausführen dieses Vorgang

    Dateiname: \\?\c:\Programm Files\Microsoft\Exchange\Server\V14\ClientAccess\PowerShell\web.config

    Zeilnnummer 33 Fehler: Doppelter Auflistungseintrag vom Typ "add" mit auf "kerbauth" festgelegtem eindeutigen Schlüsselattribut "name" kann nicht hinzugefügt werden"

    Danach ist dann fertig, und ich kann die Module nicht angezeigt bekommen. Schaue ich aber in Zeile 33 der web.config nach kann ich keinen doppelten Eintrag finden?

    Wie gehe ich am besten weiter vor?

    Frohe Ostern!

    Albert Kipp

    Samstag, 7. April 2012 12:33
  • Hallo Albert,

    ich würde in der Web.Config nach "kerbauth" suchern, vielleicht ist den doppelter Eintrag zu sehen. Am besten wäre die betroffene Web.config mit einer von einem funktionierenden Server zu vergleichen, im Bezug auf Kerbauth.

    Mfg,

    Vali

    Montag, 9. April 2012 10:35
  • Hallo Albert,

    sicherlich hast Du, bevor Du die web.config verändert hast eine Sicherung der Datei gemacht. Stelle diese wieder her.

    Öffne nun die IIS-Konsole (Internetinformationsdienstemanager)

    - Navigiere zur Default Web Site (auswählen) und dann wähle in der Mitte "Module"

    - Entferne hier das Modul kerbauth (rechtsclick, entfernen)

    - Jetzt gehe auf das virtuelle Verzeichnis "Powershell"  dann wieder in der Mitte auf "Module"

    - Überprüfe unter Module dass hier "kerbauth" gelistet ist mit dem Modultyp "Systemeigen" und Eintragstyp "Lokal"

      Wenn "kerbauth" nicht gelistet ist, clicke rechts oben bei "Aktionen" auf "Systemeigene Module konfigurieren" und setze den Haken bei "kerbauth"

    führe jetzt einen IIS-Neustart durch - Kommandozeile : IISRESET /noforce

    Jetzt sollten Deine Exchange Werzeuge wieder funktionieren.


    Grüße, Christoph


    Montag, 9. April 2012 17:30
  • Super Christoph, dein Post hat mir geholfen. Frage mich nur wie es dazu kommen kann...
    Mittwoch, 11. April 2012 13:10
  • Hallo,

    vielen Dank nochmals an Christoph für die richtigeLösung! Vielen Dank auch an alle anderen Helfer!

    Die gleiche Frage wie bbr habe ich mir übrigens auch gestellt!

    Viele Grüße

    Albert


    • Bearbeitet Albert Kipp Mittwoch, 11. April 2012 14:59
    Mittwoch, 11. April 2012 14:58