locked
Netzlaufwerke trennen sich und verbinden nicht mehr automatisch nach Neustart RRS feed

  • Frage

  • Hallo zusammen

    Vorerst folgende Situation habe ich:

    Netzwerk u.a mit folgenden Endgeräten:

    4x Windows 7 Pro SP1, tägl. Nutzung als Standardbenutzer (ohne Admin-Rechte), Netzwerkstandort "Arbeitsplatznetzwerk", Arbeitsgruppe "WORKGROUP"

    Durch Kauf einer Kassenlösung mit Debitoren und Auftragsbearbeitung wo o.g. Clients nun involviert sind, hat die zuständige Software Firma folgende Devices zusätzlich zur Verfügung gestellt:

    2x POS Kassen mit Windows XP , tägl. Nutzung als Administrator, Arbeitsgruppe "PAPETERIE"
    1 x Windows Server 2008, Arbeitsgruppe Arbeitsgruppe "PAPETERIE"

    Alle Endgeräte sind kabelgebunden im Netzwerk angeschlossen.

    Alle Clients und POS Kassen verfügen über ein Netzlaufwerk zu einer Freigabe auf dem Server. Die Freigabe ist generell gleich, also greifen alle Systeme auf den selben Ordner und Unterordner bzw. Dateien zu.
    Seit einigen Wochen muss ich jedoch feststellen, dass die Netzlaufwerke nicht immer korrekt oder gar nicht mit dem Server verbinden.
    Ein manueller Eingriff in Form von Trennen und Verbinden muss vorgenommen werden. Beim Verbinden wird stets die Möglichkeit ausgewählt, dass das Netzlaufwerk beim Anmelden mit dem Server verbindet.
    Für die Digital Natives, die an den PCs hauptsächlich arbeiten, habe ich schlussendlich eine Batch-Datei geschrieben, die wie folgt in etwa aussieht:

    net use M: /delete
    net use M: \\IP-ADRESSE\FREIGABE /user:USER PASSWORT /persistent:yes

    Heute schien angeblich selbst die Möglichkeit mit der Batch-Datei nicht zu funktionieren, sondern ein manueller Eingriff war nötig.

    Es existieren zwei weitere Ressourcen im lokalen Netzwerk (Karten-Slot am Drucker und Fileserver), die ebenfalls mit Netzlaufwerken verbunden sind und diese sind (soweit eingeschaltet) stets nach einem Neustart sofort erreichbar.

    Wo könnte das Problem liegen, dass die Netzlaufwerke mit dem einen Server nach einem Neustart sich nicht mehr verbinden?
    Wie könnte die Lösung aussehen?

    Falls die Frage kommt, warum Arbeitsgruppe und nicht Domäne, habe ich eine Antwort der Software Fa. aus einer ähnlichen Frage:

    "Da es sich ja nicht um einen Domainserver handelt haben wir die Arbeitsgruppe Papeterie auf dem Server erstellt und das dann auch so bei den Rechten vergeben."

    Die Administration des Servers und der Kassen liegt in den Händen der Software Fa. und sind nicht Teil meiner Aufgabe.

    Soweit ich auf dem Server gesehen habe, handelt es sich nur um einen Fileserver mit Benutzerverwaltung. Daten werden auf 2 HDDs gespiegelt und auf DAT gesichert.

    Momentan stehe ich etwas auf dem Schlauch.

    Für weitere notwendige Angaben, einfach melden.

    Lieben Gruss

    Marcel

    Montag, 25. März 2013 18:38

Alle Antworten

  • Ich versuch's mal - wird Dir aber nicht gefallen... ;-)
     
    > 2x POS Kassen mit Windows XP , tägl. Nutzung als Administrator,
    > Arbeitsgruppe "PAPETERIE"
     
    Bäh! Aber technisch erst mal egal...
     
    > Seit einigen Wochen muss ich jedoch feststellen, dass die
    > Netzlaufwerke nicht immer korrekt oder gar nicht mit dem Server verbinden.
     
    Fehlermeldungen im Wortlaut sind immer hilfreich, ggf. ein Screenshot.
    "nicht immer korrekt" ist etwas vage...
     
    > Heute schien angeblich selbst die Möglichkeit mit der Batch-Datei
    > nicht zu funktionieren, sondern ein manueller Eingriff war nötig.
    >
     
    "schien" ist auch etwas vage.
     
    > Wie könnte die Lösung aussehen?
    >
     
    Implementiere eine Domäne statt der diversen Workgroups.
     
    > "Da es sich ja nicht um einen Domainserver handelt haben wir die
    > Arbeitsgruppe Papeterie auf dem Server erstellt und das dann auch so
    > bei den Rechten vergeben."
     
    Das ist keine Antwort, sondern bestenfalls eine Ausrede.
     
    > Die Administration des Servers und der Kassen liegt in den Händen der
    > Software Fa. und sind nicht Teil meiner Aufgabe.
    >
     
    Schlecht. Zwei Parteien, die sich jetzt den schwarzen Peter zuspielen
    können... Ergebnisoffen statt ergebnisorientiert, natürlich.
     
    mfg Martin
     

    NO THEY ARE NOT EVIL, if you know what you are doing: Good or bad GPOs?
    Wenn meine Antwort hilfreich war, freue ich mich über eine Bewertung! If my answer was helpful, I'm glad about a rating!
    Montag, 25. März 2013 18:51
  • Hallo Martin

    Danke für deine Rückmeldung. Antworten sollen einen weiterbringen und müssen einem nicht gefallen ;-)

    Über die technische Ausstattung der POS Kassen muss man sich hier wirklich nicht auslassen ;-)

    Not my business ;-) Aber wie du schon sagtest, ist es nicht einfach, wenn zwei Firmen an einem Ort schaffen. Aber weiter unten liest du, welche Aufgabe der Server wohl eigentlich hat.

    Die Angaben, die ich gemacht habe, sind wirklich vage, jedoch sind das auch diese Angaben, die ich jedes Mal aufs Neue erhalte und da beginnt für mich der erbitterte Kampf der Rekonstruktion des Problems mit der Hoffnung, dass das Problem reproduzierbar ist.

    Eine der häufigsten Fehlermeldungen war, dass bei Öffnen des Netzlaufwerks die Meldung kam, dass der Zugriff verweigert wurde.

    Durch Trennen und Wiederverbinden des Laufwerks funktionierte es einwandfrei. Daher auch meine Batch Datei, die ich eingangs erwähnt habe.

    Welche Fehlermeldung nun gestern kam, konnte mir weder der Anwender noch die Software Firma nennen. Das macht das Ganze wirklich nicht einfacher.

    Der Server dient wie eingangs schon gesagt nur als Daten-Ressource mit Benutzerverwaltung, die Clients haben ein Programm installiert bekommen, die lediglich auf diese Ressource zugreifen (per Netzlaufwerk). Ob es daher Sinn macht eine Domäne zu erstellen, ist fraglich. Würde evtl. ein und die selbe Arbeitsgruppe Abhilfe schaffen? Ich meinte mich zu erinnern, dass das unter Windows eher produktiv als kontraproduktiv ist ;-)

    Ein Netzwerkproblem im Allgemeinen kann ich defintiv ausschliessen, da ich von ausserhalb auf alle Ressourcen zugreifen kann und andererseits auch intern auf den eigenen Fileserver, der per Netzlaufwerk eingebunden ist, stets Zugriff habe.

    Lieben Gruss

    Marcel

    Dienstag, 26. März 2013 07:54
  • Hallo,

    schau mal in http://support.microsoft.com/kb/937624 und http://support.microsoft.com/kb/954387 Nicht unbedingt auf die OS Version schauen, die Schritte sind wichtig.


    Best regards

    Meinolf Weber
    MVP, MCP, MCTS
    Microsoft MVP - Directory Services
    My Blog: http://msmvps.com/blogs/mweber/

    Disclaimer: This posting is provided AS IS with no warranties or guarantees and confers no rights.

    Dienstag, 26. März 2013 08:36
  • Hi Meinolf

    Besten Dank für deine Links. Der zweite Link bezieht sich eher auf das NAS, was ja gar nicht das Problem ist: Das Netzlaufwerk auf das NAS wie auch auf die Kartenslots der Drucker funktionieren ohne Probleme.

    Da wo es hakt, ist die Verbindung zwischen POS Kassen und hin und wieder Clients zum Server.

    Daher bin ich mir fast sicher, dass der erste Artikel auch nicht zum Ziel hilft :-(

    Marcel

    Dienstag, 26. März 2013 18:30
  • Hallo Marcel.
     
    > Der Server dient wie eingangs schon gesagt nur als Daten-Ressource mit
    > Benutzerverwaltung, die Clients haben ein Programm installiert
    > bekommen, die lediglich auf diese Ressource zugreifen (per
    > Netzlaufwerk). Ob es daher Sinn macht eine Domäne zu erstellen, ist
    > fraglich. Würde evtl. ein und die selbe Arbeitsgruppe Abhilfe
    > schaffen? Ich meinte mich zu erinnern, dass das unter Windows eher
    > produktiv als kontraproduktiv ist ;-)
     
    Hm ja. Workgroups sind hier eher selten ein Thema, da tue ich mich
    zugegebenermaßen auch schwer mit guten Tips... ;-((
     
    mfg Martin
     

    NO THEY ARE NOT EVIL, if you know what you are doing: Good or bad GPOs?
    Wenn meine Antwort hilfreich war, freue ich mich über eine Bewertung! If my answer was helpful, I'm glad about a rating!
    Dienstag, 26. März 2013 21:40
  • Hallo zusammen

    Nach längeren Recherchen habe ich per Zufall einen KB von MS gefunden. Keine Ahnung, ob es wirklich die Lösung zu dem Problem ist oder ich das korrekte Problem gefunden habe, jedoch denke ich es mal :-D
    Frei nach dem Motto: It is not a bug, it is a feature ;-)

    http://support.microsoft.com/kb/937624

    Lieben Gruss

    Marcel
    Donnerstag, 8. August 2013 07:02
  • Hallo Marcel,

    jetzt hast Du Dich des "nicht"-lesens schuldig gemacht, denn wenn Du genau hinschaust, ist der Artikel den Du im letzten Posting propagierst, genau der, den Dir Meinolf bereits vorgeschlagen hat - erster link - und den Du zurückgewiesen hast.

    Aber ich bin auf etwas gestoßen, das vielleicht wirklich helfen kann. Es sieht nur unter Win7 mittlerweile etwas anders aus und ist - zumindest bei mir - nicht über Windows+R sondern über das Command-Fenster aufrufbar:

    http://www.ratschlag24.com/comments/windows-vista-passwortgeschuetzte-netzwerk-und-nas-laufwerke-automatisch-ve

    Hoffe, der Link bleibt bestehen und es hilft Dir weiter.

    Lg. Frank

    Freitag, 16. August 2013 09:03